Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[erledigt]langsamer Programmstart - Ubuntu

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
GüNN1
Member
Member
Beiträge: 120
Registriert: 19. Jun 2007, 22:01
Wohnort: Stolzenhagen
Kontaktdaten:

[erledigt]langsamer Programmstart - Ubuntu

Beitrag von GüNN1 » 10. Feb 2008, 14:45

Immer wenn ich mit dem Netzwerk verbunden bin starten die Programme alle sehr zäh (sowohl bei wlan, als auch bei LAN). Sobald ich aber das Netzwerk ausschalte starten die Programme in normaler Geschwindigkeit (also z.B. Nautilus in 1-2Sek und nicht in 5-10Sek). Derartige Probleme hatte ich mit OpenSuse 10.3 nicht, möchte aber auch nicht wieder umsteigen.

Infos:

OS: Ubuntu Feisty Fawn
Cpu: Pentium M 1,6 GHz
RAM: 512 Mb
Graka: Radeon 9700 mobility

Code: Alles auswählen

uname -a
2.6.20-15-generic #2 SMP Sun Apr 15 07:36:31 UTC 2007 i686 GNU/Linux
sagt bescheid wenn ihr noch mehr Infos braucht...

Edit: Mittlerweile musste ich feststellen, dass die Programme auch bei Netzwerkinaktivität langsam starten. Allerdings konnte ich auch nicht feststellen wann die Proggys normal starten. Dazu muss ich sagen, dass es immer seltener wird, dass die Proggys normal starten.

Ich habe auch schon mit htop nach einem Prozess gesucht der den Rechner übermäßig auslastet bin aber nicht fündig geworden.

DOPPELPOST: http://www.ubuntu-forum.de/artikel/3103 ... 3%A4t.html


So grade wollte ich nochmal nach einem auslastenden Prozess suchen und bin über folgendes gestoßen:

http://two.xthost.info/gunn1/Bildschirm ... n:%20~.png

Ist es normal,dass sehr viele Anwendungen doppelt erscheinen , obwohl sie nur einmal gestartet wurden?
Zuletzt geändert von GüNN1 am 13. Feb 2008, 16:41, insgesamt 1-mal geändert.
Desktop: OpenSuse 11.2 mit KDE
Notebook: OpenSuse 11.2 mit KDE
Netbook: Archlinux mit Wmii

Werbung:
Benutzeravatar
Geier0815
Administrator
Administrator
Beiträge: 4289
Registriert: 14. Jun 2004, 09:12

Beitrag von Geier0815 » 11. Feb 2008, 13:48

Teste doch mal ob die Anwendungen geschlossen werden wenn Du nur einen der zwei Prozesse killst.
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

Benutzeravatar
GüNN1
Member
Member
Beiträge: 120
Registriert: 19. Jun 2007, 22:01
Wohnort: Stolzenhagen
Kontaktdaten:

Beitrag von GüNN1 » 11. Feb 2008, 18:48

Die doppelte (bzw. mehrfachen) Prozesse stehen meist für ein und die selbe Anwendung, d.h. wenn ich einen der Prozesse beende wird auch immer die dazugehörige Anwendung geschlossen.

Ich verstehe nur nicht warum Firefox und Totem gleich sechs Prozesse gleichen Namens haben, oder "gnome-session" auch zweimal auftaucht. Auch haben alle diese identischen Prozesse die gleiche RAM-Auslastung, allerdings greift nur einer der Prozesse auf die Cpu zu.

Hat irgendjmd. eine Idee in welche Richtung das Problem geht?
Desktop: OpenSuse 11.2 mit KDE
Notebook: OpenSuse 11.2 mit KDE
Netbook: Archlinux mit Wmii

Benutzeravatar
Geier0815
Administrator
Administrator
Beiträge: 4289
Registriert: 14. Jun 2004, 09:12

Beitrag von Geier0815 » 13. Feb 2008, 12:49

Entweder hast Du dir etwas wie einen rootkit eingefangen der Amok läuft oder dein System ist dabei sich zu verabschieden. Ob es bei dist-upgrade auch die Option --reinstall gibt, weiß ich nicht, solltest Du aber mal testen. Damit würde dein System komplett im derzeitigen Zustand reinstalliert werden. Aber wie gesagt: Ist nur 'ne Idee! Mach auf jeden Fall eine Datensicherung, denn im Zweifel kannst Du das gesamte System bügeln müßen.
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

Benutzeravatar
panamajo
Guru
Guru
Beiträge: 2587
Registriert: 12. Feb 2005, 22:45

Beitrag von panamajo » 13. Feb 2008, 13:35

Könnte aber auch an den 9 totem Videoplayern liegen ... :mrgreen:

Benutzeravatar
GüNN1
Member
Member
Beiträge: 120
Registriert: 19. Jun 2007, 22:01
Wohnort: Stolzenhagen
Kontaktdaten:

Beitrag von GüNN1 » 13. Feb 2008, 16:40

panamajo hat geschrieben:Könnte aber auch an den 9 totem Videoplayern liegen ... :mrgreen:
Auch ohne Totem is das System langsam.

Irgendwie hab ich keine Lust alles nochmal zu installieren, da da System erst seit 2 Wochen läuft.

Aber scheinbar führt ja wieder mal kein Weg dran vorbei...argh
Desktop: OpenSuse 11.2 mit KDE
Notebook: OpenSuse 11.2 mit KDE
Netbook: Archlinux mit Wmii

Benutzeravatar
panamajo
Guru
Guru
Beiträge: 2587
Registriert: 12. Feb 2005, 22:45

Beitrag von panamajo » 13. Feb 2008, 17:23

GüNN1 hat geschrieben:Irgendwie hab ich keine Lust alles nochmal zu installieren, da da System erst seit 2 Wochen läuft.
Warum sollte sich durch eine Neuinstallation etwas an deinem Problem ändern?

Solange du nicht herausfindest wo genau dein Problem liegt besteht eine gute Chance dass du dasselbe 2 Wochen nach der Neuinstallation wieder haben wirst.

Benutzeravatar
GüNN1
Member
Member
Beiträge: 120
Registriert: 19. Jun 2007, 22:01
Wohnort: Stolzenhagen
Kontaktdaten:

Beitrag von GüNN1 » 13. Feb 2008, 21:23

Naja es da ich keine Ahnung habe woran es liegt und mir bisher nicht wirklich geholfen werden konnte, dachte ich eine Neuinstallation wäre wohl die beste Lösung.

Aber ok das Sys bekommt noch ne kleine Chance^^, ich habe jetzt mal den Ansatz mit dem Rootkit verfolgt. Hab einfach mal "chkrootkit" über mein Sys laufen lassen, allerdings wurde nichts gefunden.

Noch ne kleine Beobachtung: Wenn ich online bin, starten alle Anwendungen recht flott (???). Trotzdem zeigt mir htop an, dass z.B. Firefox 7x als Dienst vorhanden ist.

Hoppala, hab grade mal mit Top meine Prozesse angeschaut und dort ist jeder Prozess nur einmal vorhanden. Hmmm vlt. sollte ich mal den htop Entwickler anschreiben (evt. Bug) !?

htop Version:

Code: Alles auswählen

htop --version
htop 0.6.3 - (C) 2004-2006 Hisham Muhammad.
Released under the GNU GPL.
Desktop: OpenSuse 11.2 mit KDE
Notebook: OpenSuse 11.2 mit KDE
Netbook: Archlinux mit Wmii

Benutzeravatar
GüNN1
Member
Member
Beiträge: 120
Registriert: 19. Jun 2007, 22:01
Wohnort: Stolzenhagen
Kontaktdaten:

Beitrag von GüNN1 » 18. Feb 2008, 20:01

So ich habe Ubuntu jetzt nue installiert und damit hat sich das Problem erledigt...
Desktop: OpenSuse 11.2 mit KDE
Notebook: OpenSuse 11.2 mit KDE
Netbook: Archlinux mit Wmii

Spasswolf
Member
Member
Beiträge: 69
Registriert: 15. Mär 2006, 14:47

Beitrag von Spasswolf » 18. Feb 2008, 23:06

htop (und top) kann so konfiguriert werden, das es nicht Prozesse sondern Threads anzeigt, daher kommen vermutlich die 7 firefox:
F2 -> Display options

Code: Alles auswählen

[x] Hide useland threads
Setzt du das auf an siehst du nur einen firefox.
Falls es mal wieder zum langsamen Programmstart kommt kann eventuell strace weiterhelfen.

Antworten