Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Problem mit rsync [OpenSUSE 10.2]

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Leeroy
Newbie
Newbie
Beiträge: 14
Registriert: 6. Dez 2007, 11:34

Problem mit rsync [OpenSUSE 10.2]

Beitrag von Leeroy » 4. Feb 2008, 10:55

Ich mache backup von ordner "A" auf die Externe Festplatte unter OpenSUSE 10.2.

Ich benutze dazu rsync und cronjob(Backup automatisieren)

Datei-Größe ist 14GB

Cronjob sollte backup jede Nacht machen
Das hat er auch gemacht aber nicht Vollständig!!!

Warum hat er nur paar GB Dateien kopiert und nicht alles?


Die Festplatten unter OpenSUSE 10.2 sind gespiegelt(RAID).Daten kopierung geht ziemlich langsam. Bring das etwas wenn ich OpenSUSE 10.3 installiere? Ich habe gehört dass 10.3 ist schneller als 10.2.

Werbung:
K4m1K4tz3
Advanced Hacker
Advanced Hacker
Beiträge: 987
Registriert: 19. Jan 2005, 13:54
Kontaktdaten:

Beitrag von K4m1K4tz3 » 4. Feb 2008, 16:30

Was für ein Dateisystem hat die Externe HDD?
Mein System: SUSE 11.4, x86_64, KDE 4.6

Mein Jabber: masterunderlined@jabber.ccc.de

Leeroy
Newbie
Newbie
Beiträge: 14
Registriert: 6. Dez 2007, 11:34

Beitrag von Leeroy » 5. Feb 2008, 00:36

Fat32

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16599
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Problem mit rsync [OpenSUSE 10.2]

Beitrag von whois » 5. Feb 2008, 06:52

Leeroy hat geschrieben:Warum hat er nur paar GB Dateien kopiert und nicht alles?
Wievel Prozent des Jobs hat er denn erledigt?
Liegt alles un einem Ordner?

Leeroy
Newbie
Newbie
Beiträge: 14
Registriert: 6. Dez 2007, 11:34

Beitrag von Leeroy » 5. Feb 2008, 09:32

Also server ist nicht bei mir und ich vermute dass der backup war noch nicht vollständig gemacht !

Wegen RAID ist das ganze kopierung ziemlich langsam :P

Die Dateien sind in einen Ordner!

-Problem mit rsync gelöst-

Nur noch eine Frage:
Die Festplatten unter OpenSUSE 10.2 sind gespiegelt(RAID).Daten kopierung geht ziemlich langsam. Bring das etwas wenn ich OpenSUSE 10.3 installiere? Ich habe gehört dass 10.3 ist schneller als 10.2.

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16599
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 5. Feb 2008, 10:24

Leeroy hat geschrieben: Ich habe gehört dass 10.3 ist schneller als 10.2.
Unwesentlich, allerdings der Bootvorgang ist etwas schneller aber das kommt bei einem Server eh so gut wie nie vor. :wink:
Deshalb lohnt sich bei einem gut funktionierenden System der Umstieg IMHO nicht.

Leeroy
Newbie
Newbie
Beiträge: 14
Registriert: 6. Dez 2007, 11:34

Beitrag von Leeroy » 5. Feb 2008, 10:33

Herzlichen Dank für hilfe :)

timotool
Member
Member
Beiträge: 54
Registriert: 18. Jan 2008, 23:49
Wohnort: Dortmund

Beitrag von timotool » 5. Feb 2008, 13:24

Leeroy hat geschrieben:Datei-Größe ist 14GB
Leeroy hat geschrieben:Fat32
Wie machst du das denn? Wenn ich das richtig im Kopf habe dürfen bei Fat32 die Dateien doch max 4 GB - 1 Byte groß sein?!?!
Denke das dürfte dann das Problem sein warum er nach ein paar GB (sprich fast genau 4 GB) aufhört mit dem kopieren...
Linux: OpenSuse 12.1
Kernel: 3.1.10-4.1_x86_64
System: DL380 G4 2x Xeon 3.6 GHz, 12GB Ram , 5x 300GB HP/Fujitsu SCSI320 10k @ Raid 5 + 1 Hotspare

Leeroy
Newbie
Newbie
Beiträge: 14
Registriert: 6. Dez 2007, 11:34

Beitrag von Leeroy » 6. Feb 2008, 09:31

Die Externe Festplatte war am anfang mit NTFS formatiert
Ich habe sie in Fat32 formatiert weil bei NTFS könnte ich nichts auf die festplatte schreiben(Unter Windows schon aber unter Linux nicht)

Wenn Fat32 ist schlecht was soll ich dann nehmen?

timotool
Member
Member
Beiträge: 54
Registriert: 18. Jan 2008, 23:49
Wohnort: Dortmund

Beitrag von timotool » 6. Feb 2008, 10:32

entweder open suse 10.3 nutzen, da ist imho die volle ntfs unterstützung (also auch schreibender zurgriff) schon enthalten... oder dein backup in mehrere dateien á <4GB aufteilen...
Linux: OpenSuse 12.1
Kernel: 3.1.10-4.1_x86_64
System: DL380 G4 2x Xeon 3.6 GHz, 12GB Ram , 5x 300GB HP/Fujitsu SCSI320 10k @ Raid 5 + 1 Hotspare

K4m1K4tz3
Advanced Hacker
Advanced Hacker
Beiträge: 987
Registriert: 19. Jan 2005, 13:54
Kontaktdaten:

Beitrag von K4m1K4tz3 » 6. Feb 2008, 16:11

Oder ext2 bzw. ext3 benutzen und einen Treiber unter Windows installieren.
Mein System: SUSE 11.4, x86_64, KDE 4.6

Mein Jabber: masterunderlined@jabber.ccc.de

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast