Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

grsync Fehlermeldung mit automounter externe HD

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
PowerPaul
Hacker
Hacker
Beiträge: 611
Registriert: 18. Aug 2006, 11:44
Wohnort: SATA Platte hinten rechts

grsync Fehlermeldung mit automounter externe HD

Beitrag von PowerPaul » 3. Feb 2008, 14:09

Hallo Leute!

Leider auch ein kleines Problem mit dem Automounter in openSuse 10.3 für ext. HDs!

Ich benutzt grsync um meine Datenpartition regelmäßig auf eine externe HD zu sichern! Wenn ich suse die HDF mounten lasse, funktioniert es leider nicht! Fehlermeldung:

Code: Alles auswählen

rsync: recv_generator: failed to stat "/media/Sicherung-1/Laufwerk D/Daten/Arbeit & Bewerbung/Bewerbungsdaten/Arbeitsamt/Stellenbeschreibung Parasfür Arbeitsamt 22.01.2006.doc": Invalid or incomplete multibyte or wide character (84)
rsync: recv_generator: failed to stat "/media/Sicherung-1/Laufwerk D/Daten/Arbeit & Bewerbung/Bewerbungsdaten/Arbeitsamt/Werdegang für Arbeitsamt 28.12.2005.doc": Invalid or incomplete multibyte or wide character (84)
Wenn ich jedoch über die Konsole, mit "mount -t ntfs-3g /dev/sdd1 /media/Sicherung -o defaults" mounte (vorher natürlich umount)
klappt alles problemlos!

Merkwürdig ist, das ich, auch wenn der automounter genutzt wird im Konqueror oder Krusader alles löscher, oder kopieren kann?

Woran liegts?!

Hier noch fstab:

Code: Alles auswählen

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc	/proc	proc	defaults	0	0
sysfs	/sys	sysfs	noauto	0	0
usbfs	/proc/bus/usb	usbfs	noauto	0	0
devpts	/dev/pts	devpts	mode=0620,gid=5	0	0
/dev/disk/by-id/scsi-SATA_SAMSUNG_HD161HJS0V3J1SP404853-part2	/	ext3	acl,user_xattr	1	1
#/dev/sdd1	/media/Sicherung	ntfs-3g	defaults,locale=de_DE.UTF-8	0	0
/dev/disk/by-id/scsi-SATA_ExcelStor_Techn_PFD200K201CXWA-part1	/windows/C	ntfs-3g	defaults,users,locale=de_DE.UTF-8	0	0
/dev/disk/by-id/scsi-SATA_SAMSUNG_HD161HJS0V3J1SP404817-part1	/windows/D	ntfs-3g	defaults,users,locale=de_DE.UTF-8	0	0
#/dev/sde1	/media/Sicherung	ntfs-3g	defaults,locale=de_DE.UTF-8	0	0
/dev/disk/by-id/scsi-SATA_SAMSUNG_HD161HJS0V3J1SP404853-part1	swap	swap	defaults	0	0
debugfs	/sys/kernel/debug	debugfs	noauto	0	0
/dev/fd0	/media/floppy	auto	noauto,user,sync	0	0
Paule
Desktop : openSuse 12.2 x32 / Abit KN9 (nForce 4) / 2 GB RAM / AMD x2 4600 Mhz / Aver DVB-T 771 / Radeon HD 5400 1 GM RAM
Notebook: openSuse 12.1 x64 / Aspire 7750G / 8 GB RAM / Core i7 Quad / 120 GB SSD / 750 GB SATA-HD / Radeon HD 6850M 1 GB VRAM

Werbung:
Benutzeravatar
longman
Advanced Hacker
Advanced Hacker
Beiträge: 866
Registriert: 22. Apr 2004, 19:01
Wohnort: zuhause

Beitrag von longman » 3. Feb 2008, 21:18

Ich hätte jetzt vermutet, dass er ein Problem mit den Namenskonventionen hat,
eventuell iocharset=...
Hast Du mal mit verschiedenen mount Paramtern getestet ?
Eventuell einfach mit -auto ?
Tschüss bis neulich,
Gruss Burkhard aka longman
- This System is MS free and works fine -


Linupedia - Wiki des Linux Club | NICHT LESEN! AUF GAR KEINEN FALL! NIEMALS NICHT!

PowerPaul
Hacker
Hacker
Beiträge: 611
Registriert: 18. Aug 2006, 11:44
Wohnort: SATA Platte hinten rechts

Beitrag von PowerPaul » 4. Feb 2008, 17:08

...leider unklar...

In der fstab, hab ich ja die mobilen HDs mit # ausgeklammert...
Wie gesagt, wenn ich "von Hand" mounte mit:

Code: Alles auswählen

mount -t ntfs-3g /dev/sdd1 /media/Sicherung -o defaults
funktion rsync problemlos! Was meinst Du mit "iocharset=... " in die fstab schreiben, oder was??

Schon jetzt danke!!
Desktop : openSuse 12.2 x32 / Abit KN9 (nForce 4) / 2 GB RAM / AMD x2 4600 Mhz / Aver DVB-T 771 / Radeon HD 5400 1 GM RAM
Notebook: openSuse 12.1 x64 / Aspire 7750G / 8 GB RAM / Core i7 Quad / 120 GB SSD / 750 GB SATA-HD / Radeon HD 6850M 1 GB VRAM

Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Beitrag von Gimpel » 4. Feb 2008, 17:14

Mach halt die Option "locale=de_DE.UTF-8" weg in der fstab, wenn es mit defaults funktioniert.
Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild

PowerPaul
Hacker
Hacker
Beiträge: 611
Registriert: 18. Aug 2006, 11:44
Wohnort: SATA Platte hinten rechts

Beitrag von PowerPaul » 4. Feb 2008, 17:30

Der betreffende Eintrag in der fstab.conf sieht jetzt so aus:

Code: Alles auswählen

mount -t ntfs-3g /dev/sdd1 /media/Sicherung -o defaults
Ergebnis: keine Berechtigung

auch ein:

Code: Alles auswählen

mount -t ntfs-3g /dev/sdd1 /media/Sicherung -o defaults, users
brachte das gleiche Ergebnis!

Muß überhaubt was in die fstab? Wenn ich die Zeilen für die mobilen HDs inaktiviere, werden die platten auch im r/w Modus gemounted, ich hab eben nur das Problem mit (g)rsync???
Desktop : openSuse 12.2 x32 / Abit KN9 (nForce 4) / 2 GB RAM / AMD x2 4600 Mhz / Aver DVB-T 771 / Radeon HD 5400 1 GM RAM
Notebook: openSuse 12.1 x64 / Aspire 7750G / 8 GB RAM / Core i7 Quad / 120 GB SSD / 750 GB SATA-HD / Radeon HD 6850M 1 GB VRAM

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast