Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[solved] Ubuntu: Partition einhängen

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
B3cks
Newbie
Newbie
Beiträge: 15
Registriert: 29. Sep 2007, 11:42

[solved] Ubuntu: Partition einhängen

Beitrag von B3cks » 27. Jan 2008, 11:38

Hallo habe auf meinem HP Compaq nx8220 Ubuntu parallel zu Windows XP Prof laufen. Ich habe zum Datenaustausch eine ext3 Partiton angelegt, die ich unter XP über die ext-ifs treiber eingebunden habe.

Unter Ubuntu wird die Partition zwar angezeit beim öffnen werde ich allerdings nach meinem Passwort gefragt und habe nur leserechte. Habe jetzt nun versucht das Einbinden mit read/write Rechten in die fstab zu bringen. Vielleicht kann mir jemand helfen, Die Partition ist "sda7", den Ordner zum Mount Point ist bereits auch erstellt.

Meine fstab:

Code: Alles auswählen

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0

# /dev/sda5
UUID=2c3d2c9e-ef16-46ab-a36a-d4c40e1b067d /               ext3    defaults,errors=remount-ro 0       1

# /dev/sda2
UUID=91e8dfcf-7f5d-49f2-8c17-2d19f4080c8b /boot           ext3    defaults        0       2

# /dev/sda1
UUID=DA80C8D280C8B5F3 /media/Windows        ntfs    defaults,nls=utf8,umask=007,gid=46 0       1

# /dev/sda6
UUID=e069a10d-c1aa-47e3-8e97-74688ccaa4b9 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0

# /dev/sda7 
/dev/sda7 /media/DATA ext3 user,users,noauto,exec 0 0

Werbung:
Benutzeravatar
admine
Administrator
Administrator
Beiträge: 8757
Registriert: 15. Feb 2004, 21:13
Wohnort: Dresden
Kontaktdaten:

Beitrag von admine » 27. Jan 2008, 12:39

Die Rechte musst du auf dem Mount-Punkt vergeben.

Also als root die Partition mounten und dann mit "chown" bzw. "chmod" die Rechte anpassen.
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

B3cks
Newbie
Newbie
Beiträge: 15
Registriert: 29. Sep 2007, 11:42

Beitrag von B3cks » 27. Jan 2008, 12:56

Okay Also über Sudo kann ich mounten

Code: Alles auswählen

 sudo mount /dev/sda7 /media/DATA 
Wie genau ändere ich dann die Rechte ?

Danke für deine Hilfe !

Benutzeravatar
admine
Administrator
Administrator
Beiträge: 8757
Registriert: 15. Feb 2004, 21:13
Wohnort: Dresden
Kontaktdaten:

Beitrag von admine » 27. Jan 2008, 13:06

B3cks hat geschrieben: Danke für deine Hilfe !
Na hab ich dir doch schon geschrieben ... mit "chown" bzw. "chmod"
Näheres zu dem Befehlen erfährst du aus den Man-Pages.

Lies auch mal hier:
http://de.linwiki.org/wiki/Linuxfibel_- ... iffsrechte
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

B3cks
Newbie
Newbie
Beiträge: 15
Registriert: 29. Sep 2007, 11:42

Beitrag von B3cks » 27. Jan 2008, 13:08

Danke werd mich mal belesen ...

//So habe jetzt die Rechte geändert sieht wie folgt aus:

Code: Alles auswählen

drwxrwxr-- 8 fabian fabian  4096 2008-01-27 12:33 DATA
Allerdings ändert es sich nach dem Neustart wieder auf

Code: Alles auswählen

drwxr-xr-x 2 root   root    4096 2007-10-31 10:52 DATA
Will mir irgendwie nicht gelingen ....

B3cks
Newbie
Newbie
Beiträge: 15
Registriert: 29. Sep 2007, 11:42

Beitrag von B3cks » 28. Jan 2008, 19:04

Hat vielleicht noch jemand ein tipp bzw weiß welchen befehl genau ich benutzen muss ... danke

Benutzeravatar
admine
Administrator
Administrator
Beiträge: 8757
Registriert: 15. Feb 2004, 21:13
Wohnort: Dresden
Kontaktdaten:

Beitrag von admine » 28. Jan 2008, 19:29

Wichtig ist, dass du die Rechte nach dem Mounten auf dem Mount-Punkt vergibst.
Ist die Partition nicht gemountet, dann sehen die Rechte wieder anders aus ... aber das soll dich nicht stören.
Partition mounten und die von dir vergebenen Rechte sollten wieder da sein ;)
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

B3cks
Newbie
Newbie
Beiträge: 15
Registriert: 29. Sep 2007, 11:42

Beitrag von B3cks » 28. Jan 2008, 19:33

Ja ich habe die Rechte nach dem Mounten vergeben, sie sind auch wieder nach dem erneuten Mounten nach einem Reboot wieder da. Ich dachte aber die fstab würde die Partition beim Start selbstständig mounten, oder irre ich mich da ? Sie sieht noch so aus wie in meinem ersten Post zu sehen.

Tut mir leid, dass ich dass nicht gleich hinbekomme, arbeite noch nicht sehr lange mit Linux

Danke

Benutzeravatar
admine
Administrator
Administrator
Beiträge: 8757
Registriert: 15. Feb 2004, 21:13
Wohnort: Dresden
Kontaktdaten:

Beitrag von admine » 28. Jan 2008, 19:49

Du hast für /dev/sda7 die Option "noauto" stehen => kein Mounten beim Booten.
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

B3cks
Newbie
Newbie
Beiträge: 15
Registriert: 29. Sep 2007, 11:42

Beitrag von B3cks » 28. Jan 2008, 19:55

Super klappt jetzt, danke für den Tip und deine Hilfe :D :D


Gruß

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste