Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

VirtualBox auf Rechner ohne X-Server

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
Becksta
Hacker
Hacker
Beiträge: 425
Registriert: 6. Jun 2006, 01:25
Wohnort: Westerwald
Kontaktdaten:

VirtualBox auf Rechner ohne X-Server

Beitrag von Becksta » 8. Jan 2008, 17:53

Aloa,

ich versuche gerade, auf meinem "SpielServer" Virtualbox lauffähig zu bekommen. Habe dazu das Paket von der Herstellerseite installiert und nicht das, aus dem Online Repo.
Die Installation war auch soweit kein Problem. Jetzt kommts aber:

Auf dem Rechner ist keine grafische Oberfläche installiert. Allerdings soll es wohl über "VBoxManage" möglich sein, die Konfiguration auch per Konsole zu machen. Mein erster Ansatz war der, einfach eine .vdi Datei, die ich bisher auf einem Client hatte, nach der Installation von Virtualbox, auf den Server zu kopieren um diese dann von dort aus zu starten.
Allerdings muss ich den ausführenden User ja der Gruppe "vboxusers" oder so hinzufüten.
Dazu eine Frage: Ich habe auf dem Server nur einen root User. Der Benutzer unter dem ich Virtualbox ausführen möchte liegt im Ldap und ist eigentlich bereits in dieser Gruppe. Über den Client kann ich auch Virtualbox ausführen. Was muss ich mit dem User eventuell noch anstellen??? Das ganze als root zu machen ist vermutlich keine schlaue Idee, oder??

Ich würde mich freuen, wenn mir zu diesem Thema (Am besten Virtualbox , weil das bereits "bekannt" ist) jemand mal einen kurzen Einstieg liefern könnte. Ich komme damit einfach nicht so recht klar...
Zum Teil scheitere ich schon bei der richtigen "Übersetzung" der Befehle auf mein System....
So habe ich einfach mal mit Befehlen von dieser Seite versucht, meine kopierte .vdi Datei zu starten....

http://www.fedorawiki.de/index.php/Virt ... n_Maschine

Der getestete Befehl lautete:

Code: Alles auswählen

VBoxManage startvm /Pfad/Name.vdi
Darauf kriege ich dann den Hinweis, das mit dem User (Ldap und eingetlich in der Gruppe drin) noch etwas nicht stimmt.

Code: Alles auswählen

becksta@suseserver:~> VBoxManage -startvm Daten/VirtuelleMaschinen/Testsystem.vdi
WARNING: You are not a member of the "vboxusers" group.  Please add yourself
         to this group before starting VirtualBox.

         You will not be able to start VMs until this problem is fixed.
VirtualBox Command Line Management Interface Version 1.5.4
(C) 2005-2007 innotek GmbH
All rights reserved.

Cannot create/open directory '/tmp/.vbox-becksta-ipc/ipcd'
Abnormal termination.
Die Schreibberechtigungen auf /tmp wundert mich auch... Dachte Defaultmäßig haben "alle" User Schreibrechte in /tmp..... ;(

Also irgendwie hakt es noch an allen Ecken und Enden.... Im Netz habe ich dazu auch leider nicht besonders viel gefunden. Dokus gibt es zwar wie Sand am Meer, allerdings nix ohne eine GUI...

Wäre schön, wenn mich jemand anschuppst.... ;)

Greetz
Becksta
Zuletzt geändert von Becksta am 27. Jan 2008, 10:32, insgesamt 3-mal geändert.
Mein System:
Intel Core 2 Duo E6400 2,13 Ghz
Asus P5b
MSI GeForce 7600 Gs
2048MB Arbeitsspeicher

Betriebssysteme:
OpenSuse 11.2 Linux 2.6.31
Gnome
Windows 7 Professional

Werbung:
Benutzeravatar
Becksta
Hacker
Hacker
Beiträge: 425
Registriert: 6. Jun 2006, 01:25
Wohnort: Westerwald
Kontaktdaten:

Beitrag von Becksta » 8. Jan 2008, 21:31

Oh Man,

manchmal bin ich einfach zu trottelig zum Suchen.
Ich sage nur HANDBUCH!!!! ;)

Für alle die es ebenfalls interessiert:

7.4.2 Step by step: creating a virtual machine on a headless
server

im Virtualbox Manual. Habs gerade erst gefunden und werd mich jetzt mal dran machen... Aber das macht einen solide beschrieben Eindruck...
Werde hier mal posten, wie das ganze weitergeht....

Greetz
Becksta
Mein System:
Intel Core 2 Duo E6400 2,13 Ghz
Asus P5b
MSI GeForce 7600 Gs
2048MB Arbeitsspeicher

Betriebssysteme:
OpenSuse 11.2 Linux 2.6.31
Gnome
Windows 7 Professional

Benutzeravatar
Becksta
Hacker
Hacker
Beiträge: 425
Registriert: 6. Jun 2006, 01:25
Wohnort: Westerwald
Kontaktdaten:

Beitrag von Becksta » 8. Jan 2008, 21:51

OK, also weil es wirklich gut erklärt ist, packe ich den Teil mal hier rein...

Code: Alles auswählen

7.4.2 Step by step: creating a virtual machine on a headless
server
The following instructions may give you an idea how to create a virtual machine on a
headless server over a network connection. We will create a virtual machine, establish
a VRDP connection and install a guest operating system – all without having to touch
the headless server. All you need is the following:
1. VirtualBox on a server machine with a supported host operating system (Linux
or Windows); for the following example, we will assume a Linux server;
2. an ISO file on the server, containing the installation data for the guest operating
system to install (we will assume Windows XP in the following example);
3. a terminal connection to that host over which you can access a command line
(e.g. via telnet or ssh);
4. an RDP viewer on the remote client; on a Linux client, you could use rdesktop
to connect; from a Windows machine, you could use the RDP viewer that comes
with Windows (usually found in “Accessories” -> “Communication” -> “Remote
Desktop Connection”).
Note that on the server machine, since we will only use the headless server, neither Qt
nor SDL nor the X Window system will be needed.
1. On the headless server, create a new virtual machine:
VBoxManage createvm -name "Windows XP" -register
Note that if you do not specify -register, you will have to manually use the
registervm command later.
2. Make sure the settings for this VM are appropriate for the guest operating system
that we will install. For example:
VBoxManage modifyvm "Windows XP" -memory "256MB" \
-acpi on -boot1 dvd -nic1 nat
3. Create a virtual hard disk for the VM (in this case, 10GB in size) and register it
with VirtualBox:
VBoxManage createvdi -filename "WinXP.vdi" -size 10000 -register
4. Set this newly created VDI file as the first virtual hard disk of the new VM:
VBoxManage modifyvm "Windows XP" -hda "WinXP.vdi"
5. Register the ISO file that contains the operating system installation that you want
to install later:
VBoxManage registerimage dvd /full/path/to/iso.iso
6. Attach this ISO to the virtual machine, so it can boot from it:
VBoxManage modifyvm "Windows XP" -dvd /full/path/to/iso.iso
(Alternatively, you can use VBoxManage controlvm dvdattach directly,
without having to register the image first; see chapter 8.7, VBoxManage controlvm,
page 92 for details.)
7. Start the virtual machine using VBoxVRDP:
VBoxVRDP -startvm "Windows XP"
If everything worked, you should see a copyright notice. If, instead, you are
returned to the command line, then something went wrong.
8. On the client machine, fire up the RDP viewer and try to connect to the server.
Assuming a Linux client, try the following:
rdesktop -a 16 my.host.address
(With rdesktop, the -a 16 option requests a color depth of 16 bits per pixel, which
we recommend. Also, after installation, you should set the color depth of your
guest operating system to the same value.)
You should now be seeing the installation routine of your guest operating system.
Soweit so gut. Nachdem ich in der Firewall den Port 3389 freigegeben habe, komme ich auch mit rdesktop tatsächlich auf die Kiste drauf.
Beim Versuch OpenXChange zu installieren sagt er mir allerdings, er könne keine Netzwerkkarte finden.... Daran bastel ich mal noch weiter...

EDIT:
Die Netzwerkkarte musste ich in der Config.xml auf TRUE setzen..... weiter gehts....
Ich schließe den Thread dann mal... scheint sich ja erledigt zu haben... hehe

Greetz
Becksta
Mein System:
Intel Core 2 Duo E6400 2,13 Ghz
Asus P5b
MSI GeForce 7600 Gs
2048MB Arbeitsspeicher

Betriebssysteme:
OpenSuse 11.2 Linux 2.6.31
Gnome
Windows 7 Professional

Benutzeravatar
Becksta
Hacker
Hacker
Beiträge: 425
Registriert: 6. Jun 2006, 01:25
Wohnort: Westerwald
Kontaktdaten:

Beitrag von Becksta » 24. Jan 2008, 13:29

Servus,

ich mach den hier noch mal auf, weil ich mich zur Zeit wieder damit beschäftige. Weiter oben habe ich das auf meinem Client ausprobiert und jetzt möchte ich das gerne auf den Server übernehmen.
Bei der Konfiguration der Bridge habe ich aber etwas Bammel, dass ich mir die Netzwerkeinstellungen von eth0 zerschieße....

Hier zunächst noch mal aus dem aktuellen Handbuch der Auszug zum Thema Brdiged Networking unter VirtualBox:

Code: Alles auswählen

6.5.1.2 Bridging on openSUSE hosts
The following instructions explain how to create bridge on openSUSE. Note that bridging
on openSUSE hosts may not work properly if you are using NetworkManager to
manage your network connections. To create a bridge on a recent openSUSE host, you
must first install the bridge utilities (bridge-utils) package. If you are working
from the command line this can be done as follows:
sudo /sbin/yast -i bridge-utils
Then you must create a text file describing the bridge to be created. The name of the
file must correspond to the name of the bridge you wish to create. To create the bridge
br0, you should call the file /etc/sysconfig/network/ifcfg-br0. Below we
have given an example of a file which creates a bridge including the network device
eth0, obtains an IP address by DHCP (through the network device) and is started
automatically when openSUSE starts. You will probably want to adjust this to match
your networking requirements.
65
6 Virtual networking
BOOTPROTO=’dhcp’
NETMASK=’255.255.255.0’
STARTMODE=’auto’
USERCONTROL=’no’
DHCLIENT_TIMEOUT=30
BRIDGE=’yes’
BRIDGE_PORTS=’eth0’
For this example to work, you will also need to change the configuration for
the network interface eth0 to a static IP address of 0.0.0.0, as openSUSE does
not do this automatically when the interface is added to the bridge. You can do
this using the graphical interface or by changing the following settings in the file
/etc/sysconfig/network/ifcfg-eth-xx:xx:xx:xx:xx:xx, where the last
part should be replaced with the hardware address of the network card.
BOOTPROTO=’static’
IPADDR=’0.0.0.0’
You can activate the bridge immediately after creating it with the command:
sudo /sbin/ifdown eth0
sudo /sbin/ifup br0
The bridge will be activated automatically from now on when the host is restarted.
Now, to create a permanent host interface called vbox0 (all host interfaces created
in this way must be called vbox followed by a number) and add it to the network
bridge created above, use the following command (see chapter 6.5.1.5, Host Interface
Networking utilities for Linux, page 68 for more details):
sudo VBoxAddIF vbox0 <user> br0
Replace <user> with the name of the user who is supposed to be able to use the
new interface.
To tell VirtualBox to use this interface (vbox0) for a virtual machine, select the
VM in the main window, configure one of its network adaptors to use Host Interface
Networking (using “Settings”, “Network”, “Attached to”) and enter “vbox0” into the
“Interface name” field.
Alternatively, you can use the VBoxManage command line tool (in this example we
are attaching the interface to the first network card of the virtual machine “My VM”:
VBoxManage modifyvm "My VM" -hostifdev1 vbox0
6.5.1.3 Bridging on Redhat and Fedora hosts
To create a bridge on Redhat and Fedora, you must first install the bridge utilities
(bridge-utils) package. Then you must create a configuration file describing the
bridge you wish to create. The following is the contents of an example configuration
file /etc/sysconfig/network-scripts/ifcfg-br0, which sets the bridge br0
to get its IP address using DHCP and to start automatically when the system is started.
You will probably want to adjust this to match your networking requirements.
66
6 Virtual networking
DEVICE=br0
TYPE=Bridge
BOOTPROTO=dhcp
ONBOOT=yes
To add the network card eth0 to the bridge, add the following line to the end of
the file /etc/sysconfig/network-scripts/ifcfg-eth0:
BRIDGE=br0
You can activate the bridge immediately after creating it with the command:
sudo /sbin/service network restart
The bridge will be activated automatically from now on when the host is restarted.
Now, to create a permanent host interface called vbox0 (all host interfaces created
in this way must be called vbox followed by a number) and add it to the network
bridge created above, use the following command (see chapter 6.5.1.5, Host Interface
Networking utilities for Linux, page 68 for more details):
sudo VBoxAddIF vbox0 <user> br0
Replace <user> with the name of the user who is supposed to be able to use the
new interface.
To tell VirtualBox to use this interface (vbox0) for a virtual machine, select the
VM in the main window, configure one of its network adaptors to use Host Interface
Networking (using “Settings”, “Network”, “Attached to”) and enter “vbox0” into the
“Interface name” field.
Alternatively, you can use the VBoxManage command line tool (in this example we
are attaching the interface to the first network card of the virtual machine “My VM”:
VBoxManage modifyvm "My VM" -hostifdev1 vbox0
Im Verlauf lege ich zunächst eine Config Datei für br0 an....
1. Frage: Kann ich da auch bereits "Bootprotocoll" auf "static" einstellen und eine feste IP vergeben?

Als nächstes muss in der gleichen Datei für eth0 die IP "0.0.0.0" vergeben werden.
2. Frage: Genau das macht mir Angst... Ist der Rechner anschließend noch unter der "gewohnten "Adresse erreichbar, oder macht er danach DHCP vom Router???

Soviel dazu... Um das nochmal deutlich zu machen. Ich möchte gerne, dass der Host seine IP behält und die VM eine separate, aus dem gleichen IP Bereich bekommt...

Greetz
Becksta
Mein System:
Intel Core 2 Duo E6400 2,13 Ghz
Asus P5b
MSI GeForce 7600 Gs
2048MB Arbeitsspeicher

Betriebssysteme:
OpenSuse 11.2 Linux 2.6.31
Gnome
Windows 7 Professional

gameboy
Hacker
Hacker
Beiträge: 794
Registriert: 5. Aug 2005, 10:27
Wohnort: Hessen / MKK

Beitrag von gameboy » 24. Jan 2008, 15:58

Hallo Becksta,
Becksta hat geschrieben:1. Frage: Kann ich da auch bereits "Bootprotocoll" auf "static" einstellen und eine feste IP vergeben?
ja, kannst Du machen. Bei mir sieht die Datei z.B. wie folgt aus:

Code: Alles auswählen

# cat /etc/sysconfig/network/ifcfg-br0

BOOTPROTO='static'
IPADDR='10.10.10.2'
NETMASK='255.255.255.0'
STARTMODE='auto'
USERCONTROL='no'
BRIDGE='yes'
BRIDGE_PORTS='eth0' 
Becksta hat geschrieben:Als nächstes muss in der gleichen Datei für eth0 die IP "0.0.0.0" vergeben werden.
2. Frage: Genau das macht mir Angst... Ist der Rechner anschließend noch unter der "gewohnten "Adresse erreichbar, oder macht er danach DHCP vom Router???
Der Rechner ist in obigem Beispiel unter der IP 10.10.10.2 erreichbar. DHCP kommt dabei nicht zum Einsatz.
Becksta hat geschrieben:Soviel dazu... Um das nochmal deutlich zu machen. Ich möchte gerne, dass der Host seine IP behält und die VM eine separate, aus dem gleichen IP Bereich bekommt...
Die IP der VM kannst Du dann innerhalb des Gast-Betriebssystems konfigurieren.

Viele Grüße,
gameboy.

Benutzeravatar
Becksta
Hacker
Hacker
Beiträge: 425
Registriert: 6. Jun 2006, 01:25
Wohnort: Westerwald
Kontaktdaten:

Beitrag von Becksta » 24. Jan 2008, 19:20

Also das Anlegen der Bridge scheint erfolgreich gewesen zu sein...
Nach dem Neustart des Hostes ist der Rechner nach wie vor über die "alte" IP Adresse erreichbar. Diese habe ich in der ifcfg-br0 entsprechend hinterlegt....
Jetzt geht es daran, den OpenXChange EE dort drauf zu packen....
Wenn ich es richtig verstehe, vergebe ich im Rahmen der Installationsroutine jetzt dem Gast eine IP Adresse aus dem gleichen Adressbereich und der Gast wäre auch zum Beispiel über "arp -a" sichtbar??

Greetz
becksta

EDIT 1:
Also da scheint etwas noch nicht zu klappen.... Habe dem Gast bei der Installation eine IP Adresse zugewiesen. Leider lässt sich der Gast nicht anpingen... Habe die Firewall auf dem Host mal testweise deaktiviert, das hat aber auch nicht gebracht...
Hab ich noch etwas vergessen????

Greetz
Becksta
Mein System:
Intel Core 2 Duo E6400 2,13 Ghz
Asus P5b
MSI GeForce 7600 Gs
2048MB Arbeitsspeicher

Betriebssysteme:
OpenSuse 11.2 Linux 2.6.31
Gnome
Windows 7 Professional

gameboy
Hacker
Hacker
Beiträge: 794
Registriert: 5. Aug 2005, 10:27
Wohnort: Hessen / MKK

Beitrag von gameboy » 24. Jan 2008, 23:24

Becksta hat geschrieben:Wenn ich es richtig verstehe, vergebe ich im Rahmen der Installationsroutine jetzt dem Gast eine IP Adresse aus dem gleichen Adressbereich
Genau. Zudem trägst Du als Default-Gateway sowie als DNS-Server jeweils die IP Deines Routers ein.
Becksta hat geschrieben: und der Gast wäre auch zum Beispiel über "arp -a" sichtbar??
Wenn ich vom Host aus zunächst die IP des Gast-Systems pinge, dann wird der Gast anschließend auch in der Ausgabe von "arp -a" aufgeführt.

Viele Grüße,
gameboy.

Benutzeravatar
Becksta
Hacker
Hacker
Beiträge: 425
Registriert: 6. Jun 2006, 01:25
Wohnort: Westerwald
Kontaktdaten:

Beitrag von Becksta » 25. Jan 2008, 00:16

Hm,

wenn ich per ssh auf dem Host den Gast (Nachdem ich ihn gestartet habe) anpinge, bzw den arp Befehl absetze, dann kommt das folgende:

Code: Alles auswählen

suseserver:/home/becksta # arp -a
? (192.168.178.17) auf <unvollständig> auf br0
noname (192.168.178.23) auf 00:0C:F1:16:56:A5 [ether] auf br0
fritz.fonwlan.box (192.168.178.1) auf 00:1C:4A:85:AB:8F [ether] auf br0
suseserver:/home/becksta # ping 192.168.178.17
PING 192.168.178.17 (192.168.178.17) 56(84) bytes of data.
From 192.168.178.16: icmp_seq=2 Destination Host Unreachable
From 192.168.178.16 icmp_seq=2 Destination Host Unreachable
From 192.168.178.16 icmp_seq=3 Destination Host Unreachable
From 192.168.178.16 icmp_seq=4 Destination Host Unreachable

--- 192.168.178.17 ping statistics ---
5 packets transmitted, 0 received, +4 errors, 100% packet loss, time 4000ms
, pipe 3
Die arp Ausgabe sieht irgendwie unvollständig aus, oder???
Kann es sein, dass ich für die Bridge noch eine MAC Adresse in der IFCFG-br0 vergeben muss??

Greetz
Becksta

Edit 1:

Hier mal noch die ifcfg von br0 und eth0

Code: Alles auswählen

BOOTPROTO='static'
IPADDR='192.168.178.16'
NETMASK='255.255.255.0'
STARTMODE='auto'
USERCONTROL='no'
BRIDGE='yes'
BRIDGE_PORTS='eth0'

Code: Alles auswählen

BOOTPROTO='static'
BROADCAST=''
ETHTOOL_OPTIONS=''
IPADDR='0.0.0.0'
MTU=''
NAME='ASRock In SiS900 PCI Fast Ethernet'
NETWORK=''
REMOTE_IPADDR=''
STARTMODE='auto'
USERCONTROL='no'
Vielleicht lässt sich ja da noch was rauslesen, das fehlt... ;)

Greetz
Becksta
Mein System:
Intel Core 2 Duo E6400 2,13 Ghz
Asus P5b
MSI GeForce 7600 Gs
2048MB Arbeitsspeicher

Betriebssysteme:
OpenSuse 11.2 Linux 2.6.31
Gnome
Windows 7 Professional

jengelh
Guru
Guru
Beiträge: 4039
Registriert: 20. Nov 2004, 17:42
Kontaktdaten:

Beitrag von jengelh » 25. Jan 2008, 12:49

IPADDR=""
mal ohne 0.0.0.0 probiert?

Benutzeravatar
konqui
Hacker
Hacker
Beiträge: 273
Registriert: 13. Okt 2005, 11:14
Wohnort: Frankfurt/M.

Beitrag von konqui » 25. Jan 2008, 13:07

IPADDR='0.0.0.0' ist schon okay.
Meine eth0 sieht so aus:

Code: Alles auswählen

BOOTPROTO='static'
BROADCAST=''
ETHTOOL_OPTIONS=''
IPADDR='0.0.0.0'
MTU=''
NAME='Micro-Star International NetXtreme BCM5788 Gigabit Ethernet'
NETWORK=''
NETMASK='255.255.255.255'
REMOTE_IPADDR=''
STARTMODE='auto'
USERCONTROL='no'

Benutzeravatar
Becksta
Hacker
Hacker
Beiträge: 425
Registriert: 6. Jun 2006, 01:25
Wohnort: Westerwald
Kontaktdaten:

Beitrag von Becksta » 25. Jan 2008, 15:26

Hm....

also ich komme nicht so richtig weiter.... Hab noch mal ein paar Kleinigkeiten in den ifcfg's angepasst. Aber meiner Meinung nach muss ich noch irgendwie die MAC der Bridge angeben, oder nicht???

Zumindest bringt mich diese "arp -a" (auf dem Host) Ausgabe immer wieder auf den Gedanken:

Code: Alles auswählen

suseserver:/home/becksta # arp -a
fritz.fonwlan.box (192.168.178.1) auf 00:1C:4A:85:AB:8F [ether] auf br0
SuseClient (192.168.178.15) auf 00:18:F3:08:2C:DE [ether] auf br0
? (192.168.178.17) auf <unvollständig> auf br0
Allerdings habe ich in keiner ifcfg Datei, auch in der Sample Datei die Angabe einer MAC Adresse gefunden....
Ich weiß im Moment nicht mehr weiter....

Hier mal noch die Ausgabe von ifconfig auf dem Host:

Code: Alles auswählen

suseserver:/home/becksta # ifconfig
br0       Protokoll:Ethernet  Hardware Adresse 00:19:66:0A:00:36
          inet Adresse:192.168.178.16  Bcast:192.168.178.255  Maske:255.255.255.0
          inet6 Adresse: fe80::219:66ff:fe0a:36/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:32956 errors:0 dropped:0 overruns:0 frame:0
          TX packets:57904 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 Sendewarteschlangenlänge:0
          RX bytes:2373318 (2.2 Mb)  TX bytes:75373153 (71.8 Mb)

eth0      Protokoll:Ethernet  Hardware Adresse 00:19:66:0A:00:36
          inet6 Adresse: fe80::219:66ff:fe0a:36/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:32980 errors:0 dropped:0 overruns:0 frame:0
          TX packets:57894 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 Sendewarteschlangenlänge:1000
          RX bytes:2836747 (2.7 Mb)  TX bytes:75372661 (71.8 Mb)
          Interrupt:20 Basisadresse:0xc400

lo        Protokoll:Lokale Schleife
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          inet6 Adresse: ::1/128 Gültigkeitsbereich:Maschine
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1323 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1323 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 Sendewarteschlangenlänge:0
          RX bytes:157082 (153.4 Kb)  TX bytes:157082 (153.4 Kb)
Der Gast lässt sich auch nach wie vor nicht anpingen.

Code: Alles auswählen

suseserver:/home/becksta # ping -c5 192.168.178.17
PING 192.168.178.17 (192.168.178.17) 56(84) bytes of data.
From 192.168.178.16 icmp_seq=1 Destination Host Unreachable
From 192.168.178.16 icmp_seq=2 Destination Host Unreachable
From 192.168.178.16 icmp_seq=3 Destination Host Unreachable
From 192.168.178.16 icmp_seq=4 Destination Host Unreachable
From 192.168.178.16 icmp_seq=5 Destination Host Unreachable

--- 192.168.178.17 ping statistics ---
5 packets transmitted, 0 received, +5 errors, 100% packet loss, time 4002ms
, pipe 4
Müsste ich nicht von einem anderen Rechner auch einen arp Eintrag angezeigt bekommen??? Hier mal die Ausgabe von "arp -a" auf einem Client:

Code: Alles auswählen

SuseClient:/home/becksta # arp -a
fritz.fonwlan.box (192.168.178.1) auf 00:1C:4A:85:AB:8F [ether] auf eth0
Suseserver.Suseserver (192.168.178.16) auf 00:19:66:0A:00:36 [ether] auf eth0
Irgendwie stecke ich fest.... Was ich ebenfalls nicht ganz nachvollziehen kann:
Ich habe in dem Gastsystem bereits ein BS installiert. Über einen Konsolenbefehl lässt sich Virtualbox starten, anschließend greift man mittels "rdesktop" darauf zu. Allerdings komme ich nur auf den "Gast", wenn ich "rdesktop 192.168.178.16" (IP des Hosts) eingebe und nicht etwa, so wie ich das vermuten würde "rdesktop 192.168.178.17" (Das wäre die IP des Gastes"...

Ich hoffe, da kommt noch jemand mit... ;)

Greetz
Becksta
Mein System:
Intel Core 2 Duo E6400 2,13 Ghz
Asus P5b
MSI GeForce 7600 Gs
2048MB Arbeitsspeicher

Betriebssysteme:
OpenSuse 11.2 Linux 2.6.31
Gnome
Windows 7 Professional

Benutzeravatar
Becksta
Hacker
Hacker
Beiträge: 425
Registriert: 6. Jun 2006, 01:25
Wohnort: Westerwald
Kontaktdaten:

Beitrag von Becksta » 25. Jan 2008, 16:28

Scheisse...!!!!

ich glaube, ich habs mal wieder verbockt!!!
Keine Ahnung warum... Aber der Server startet nicht mehr richtig durch....
Er bleibt beim booten bei:

Code: Alles auswählen

Starting INET services. (xinetd)
hängen.... ;(

Ich glaube das letzte, was ich davor gemacht habe war ein manuelles ifdown der bridge....
Wie kann ich das denn jetzt wieder "bereinigen"?????

greetz
Becksta

EDIT 1:
OK, konnte die KUH wieder vom Eis kriegen..... System bootet also wieder, aber ansonsten ist immer noch alles wie vorher... also kein Netzwerk mit dem Gast....
Mein System:
Intel Core 2 Duo E6400 2,13 Ghz
Asus P5b
MSI GeForce 7600 Gs
2048MB Arbeitsspeicher

Betriebssysteme:
OpenSuse 11.2 Linux 2.6.31
Gnome
Windows 7 Professional

gameboy
Hacker
Hacker
Beiträge: 794
Registriert: 5. Aug 2005, 10:27
Wohnort: Hessen / MKK

Beitrag von gameboy » 26. Jan 2008, 02:38

Hallo Becksta,

wenn Du den Abschnitt über bridged networking im Manuel bis zum Ende befolgt hast, sollte ifconfig noch ein Device namens vbox0 aufführen. Dieses Device mußt Du der VM dann außerdem als Netzwerk-Adapter zuweisen.

Viele Grüße,
gameboy.

Benutzeravatar
Becksta
Hacker
Hacker
Beiträge: 425
Registriert: 6. Jun 2006, 01:25
Wohnort: Westerwald
Kontaktdaten:

Beitrag von Becksta » 27. Jan 2008, 10:12

Huhu,

das habe ich auch gemacht. Der Befehl lautet in etwa so, oder??

Code: Alles auswählen

VBoxManage ... Addif vbox0 becksta br0
Hab den Befehl gerade aus dem Kopf repliziert aber ihn beim einrichten aus dem Handbuch übernommen.
Das müsste es doch gewesen sein, oder nicht?
Das Device vbox0 kriege ich unter "ifconfig" auf dem Host auch angezeigt.

Greetz
Becksta
Mein System:
Intel Core 2 Duo E6400 2,13 Ghz
Asus P5b
MSI GeForce 7600 Gs
2048MB Arbeitsspeicher

Betriebssysteme:
OpenSuse 11.2 Linux 2.6.31
Gnome
Windows 7 Professional

gameboy
Hacker
Hacker
Beiträge: 794
Registriert: 5. Aug 2005, 10:27
Wohnort: Hessen / MKK

Beitrag von gameboy » 27. Jan 2008, 14:20

Becksta hat geschrieben:Huhu,

das habe ich auch gemacht. Der Befehl lautet in etwa so, oder??

Code: Alles auswählen

VBoxManage ... Addif vbox0 becksta br0
Ja, sowas in der Art.
Becksta hat geschrieben:Das Device vbox0 kriege ich unter "ifconfig" auf dem Host auch angezeigt.
Jetzt verwirrst Du mich etwas... - Also in Deiner oben geposteten Ausgabe von ifconfig auf dem Host ist vbox0 nicht aufgeführt.

Viele Grüße,
gameboy.

Benutzeravatar
Becksta
Hacker
Hacker
Beiträge: 425
Registriert: 6. Jun 2006, 01:25
Wohnort: Westerwald
Kontaktdaten:

Beitrag von Becksta » 27. Jan 2008, 14:53

Hm,

kann ich mir auch nicht erklären... Vielleiht hab ich den Befehl doch erst nachträglich eingegeben... Hier mal der aktuelle Stand auf dem Host:

Code: Alles auswählen

suseserver:/home/becksta # ifconfig
br0       Protokoll:Ethernet  Hardware Adresse 00:19:66:0A:00:36
          inet Adresse:192.168.178.16  Bcast:192.168.178.255  Maske:255.255.255.0
          inet6 Adresse: fe80::219:66ff:fe0a:36/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:31216100 errors:0 dropped:0 overruns:0 frame:0
          TX packets:41511853 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 Sendewarteschlangenlänge:0
          RX bytes:1297863550 (1237.7 Mb)  TX bytes:2191235006 (2089.7 Mb)

eth0      Protokoll:Ethernet  Hardware Adresse 00:19:66:0A:00:36
          inet6 Adresse: fe80::219:66ff:fe0a:36/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:31217584 errors:0 dropped:0 overruns:0 frame:0
          TX packets:41511852 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 Sendewarteschlangenlänge:1000
          RX bytes:1778890504 (1696.4 Mb)  TX bytes:2191234952 (2089.7 Mb)
          Interrupt:17 Basisadresse:0xc400

lo        Protokoll:Lokale Schleife
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          inet6 Adresse: ::1/128 Gültigkeitsbereich:Maschine
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:97741 errors:0 dropped:0 overruns:0 frame:0
          TX packets:97741 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 Sendewarteschlangenlänge:0
          RX bytes:11124118 (10.6 Mb)  TX bytes:11124118 (10.6 Mb)

vbox0     Protokoll:Ethernet  Hardware Adresse 00:FF:3D:5F:49:F2
          inet6 Adresse: fe80::2ff:3dff:fe5f:49f2/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:78 overruns:0 carrier:0
          collisions:0 Sendewarteschlangenlänge:500
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

Code: Alles auswählen

suseserver:/home/becksta # arp
Address                  HWtype  HWaddress           Flags Mask            Iface
BeckstaDesktop           ether   00:18:F3:08:2C:DE   C                     br0
fritz.fonwlan.box        ether   00:1C:4A:85:AB:8F   C                     br0
Wenn der Gast gestartet ist, steht da noch ein Eintrag, der statt dem Namen, die IP Adresse 192.168.17817 hat.... siehe auch weiter oben...

Noch ne Frage nebenbei:
Ich habe mit dem Befehl "VBoxManage -startvm "Name" &" Meinen Gast gestartet. In diesem Modus kann ich ja nicht per rdesktop darauf zugreifen um die Kiste wieder runterzufahren.
Wie schalte ich den Gast denn wieder ab, bzw. einfach aus???
Sowas wie "VBoxManage -killvm" Gibts ja nicht.... ;)


Greetz
Becksta
Mein System:
Intel Core 2 Duo E6400 2,13 Ghz
Asus P5b
MSI GeForce 7600 Gs
2048MB Arbeitsspeicher

Betriebssysteme:
OpenSuse 11.2 Linux 2.6.31
Gnome
Windows 7 Professional

Benutzeravatar
Becksta
Hacker
Hacker
Beiträge: 425
Registriert: 6. Jun 2006, 01:25
Wohnort: Westerwald
Kontaktdaten:

Beitrag von Becksta » 2. Feb 2008, 10:19

Und wieder einen Schritt weiter...

Ich habe den Fehler gefunden. Musste in der ifcfg-eth0 einfach eine IP Adresse vergeben... Also nicht die "0.0.0.0". Jetzt kann ich die virtuelle Maschine auch anpingen.
Aktuell habe ich da den Collax OpenXChange Server installiert. Der benötigt ja den Zugriff über ein Browserinterface.

Wie muss ich auf dem Host die Firewall anpassen, damit ich durchkomme?
Die Ports 3389 (wird angegeben, wenn ich den Gast über die Konsole starte) und den Port 8001 (Laut Collax Handbuch der Port für den Webserver) habe ich auf dem Host bereits geöffnet. Allerdings bringt mir "https://IPDesGastes:8001 noch einen Fehler!!!

Oder muss ich noch sowas wie ne Weiterleitung anlegen???

Greetz
Becksta
Mein System:
Intel Core 2 Duo E6400 2,13 Ghz
Asus P5b
MSI GeForce 7600 Gs
2048MB Arbeitsspeicher

Betriebssysteme:
OpenSuse 11.2 Linux 2.6.31
Gnome
Windows 7 Professional

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste