Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

aktualisierung von 10.2 auf 10.3/ grub wollte nicht mehr

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
mrehm
Hacker
Hacker
Beiträge: 654
Registriert: 10. Mär 2007, 00:58
Wohnort: Vila do Bispo - Portugal

aktualisierung von 10.2 auf 10.3/ grub wollte nicht mehr

Beitrag von mrehm » 4. Jan 2008, 01:04

hallo!

nach der aktualisierung auf 10.3 - alles gut gelaufen, alle einstellungen beibehalten - stellte ich heute fest, daß beim booten die winxp-partition nich mehr erkannt wurde.
versuche, wie auch hier im forum beschrieben, der systemreparatur mit der install-dvd brachten nix.

so gings dann:

- opensuse 10.3 starten
- yast2
- system - bootloader konfigurieren
- reiter bootloader installation
- übernehmen: 'bootloader grub'
- speicherort: häkchen setzen 'aus bootpartition'

bei mir war häkchen bei 'aus mbrpartition'...

witz am rande:
unter 'benutzerdefinierte bootpartition' stand
- /dev/sda2/

bei mir:
- /dev/sda1/ winxp
- /dev/sda5/ linuxswap
- /dev/sda6/ opensuse 10.3
- /dev/sda7/ home

startmeldungen kommen jetzt in 640x480, aber das stört nicht

gruß

martin

Werbung:
hue
Member
Member
Beiträge: 159
Registriert: 16. Jun 2004, 18:59

Re: aktualisierung von 10.2 auf 10.3/ grub wollte nicht mehr

Beitrag von hue » 4. Jan 2008, 08:30

mrehm hat geschrieben: startmeldungen kommen jetzt in 640x480, aber das stört nicht
und wenn doch, dann liesse sich das wohl durch eine Änderung in der menu.lst beheben. Setzte den Parameter vga= mit dem passenden Wert aus der Tabelle hier ganz am Schluss: http://linuxwiki.de/LutzWillek/Grub-Tricks%20%28de%29

Gruss
hue
AMD 64 X2 4200+, Nvidia GeForce 7300 LE
opensuse 13.1-64 Bit, IceWM

admine
Administrator
Administrator
Beiträge: 8775
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Beitrag von admine » 4. Jan 2008, 08:38

@mrehm

Für Hilfe poste bitte:

Code: Alles auswählen

fdisk -l
cat /etc/fstab
cat /boot/grub/device.map
cat /boot/grub/menu.lst
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

mrehm
Hacker
Hacker
Beiträge: 654
Registriert: 10. Mär 2007, 00:58
Wohnort: Vila do Bispo - Portugal

Beitrag von mrehm » 4. Jan 2008, 19:52

@ admin

wie geschrieben, funktioniert's wieder; der bootloader scheint wohl auf der boot-partition zu liegen und nicht auf der mbr-partition.

ich habe das auch nur gepostet für user mit dem gleichen problem.
liegt es daran, daß ich keine neuinstallation gemacht habe sondern nur eine aktualisierung? das gleiche problem hatte ich bei einer aktualisierung von 10.1 auf 10.2 auch und fand damals keine lösung ausser neu zu installieren.

vielen dank für dein interesse, unten noch die codes

gruß

martin

cat /etc/fstab
/dev/sda6 / ext3 acl,user_xattr 1 1
/dev/sda7 /home ext3 acl,user_xattr 1 2
/dev/sda1 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/sdb1 /windows/D vfat users,gid=users,umask=0002,utf8=true 0 0
/dev/sda5 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0

fdisk -l

Platte /dev/sda: 20.0 GByte, 20003880960 Byte
255 heads, 63 sectors/track, 2432 cylinders
Units = Zylinder of 16065 * 512 = 8225280 bytes
Disk identifier: 0xa20ea20e

Gerät boot. Anfang Ende Blöcke Id System
/dev/sda1 * 1 957 7679070 7 HPFS/NTFS
Partition 1 endet nicht an einer Zylindergrenze.
/dev/sda2 957 2432 11855907+ f W95 Erw. (LBA)
/dev/sda5 957 1020 514017 82 Linux Swap / Solaris
/dev/sda6 1021 1673 5245191 83 Linux
/dev/sda7 1674 2432 6096636 83 Linux

Platte /dev/sdb: 512 MByte, 512753664 Byte
56 heads, 32 sectors/track, 558 cylinders
Units = Zylinder of 1792 * 512 = 917504 bytes
Disk identifier: 0x00000000

Gerät boot. Anfang Ende Blöcke Id System
/dev/sdb1 * 1 559 500592 6 FAT16


cat /boot/grub/device.map
(hd0) /dev/sda
(hd1) /dev/sdb


cat /boot/grub/menu.lst
# Modified by YaST2. Last modification on Do Jan 3 22:56:51 WET 2008
default 0
timeout 8
gfxmenu (hd0,5)/boot/message

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 10.3
root (hd0,5)
kernel /boot/vmlinuz-2.6.22.13-0.3-default root=/dev/sda6 resume=/dev/sda5 splash=silent showopts
initrd /boot/initrd-2.6.22.13-0.3-default

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
rootnoverify (hd0,5)
chainloader (hd0,0)+1

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 10.3
root (hd0,5)
kernel /boot/vmlinuz-2.6.22.13-0.3-default root=/dev/sda6 showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3
initrd /boot/initrd-2.6.22.13-0.3-default

###Don't change this comment - YaST2 identifier: Original name: Kernel-2.6.22.13-0.3-default###
title Kernel-2.6.22.13-0.3-default
root (hd0,5)
kernel /boot/vmlinuz-2.6.22.13-0.3-default root=/dev/sda6 resume=/dev/sda5 splash=silent showopts
initrd /boot/initrd-2.6.22.13-0.3-default

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast