Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

(Gelöst)neue SATA-Platte hängt sich auf

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
schmiha
Newbie
Newbie
Beiträge: 44
Registriert: 26. Mär 2005, 19:33

(Gelöst)neue SATA-Platte hängt sich auf

Beitrag von schmiha » 2. Dez 2007, 11:12

Guten Tag,

habe mir eine neue SATA-Platte eingebaut und als Mountpunkt locale gesetzt. Schreibrechte vergeben. Dateisystem ist ext3. Wenn ich von meinem Homeverzeichnis z. B. einen Film auf diese Platte kopieren will, wird der Kopiervorgang immer langsamer und bleibt dann mit ""verzögert" stehen und die Platte reagiert nicht mehr.

Meine Mtab:
/dev/sdd2 / ext3 rw,acl,user_xattr 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
debugfs /sys/kernel/debug debugfs rw 0 0
udev /dev tmpfs rw 0 0
devpts /dev/pts devpts rw,mode=0620,gid=5 0 0
/dev/sdd3 /home ext3 rw,acl,user_xattr 0 0
/dev/sda1 /windows/C vfat rw,noexec,nosuid,nodev,gid=100,umask=0002,utf8=true 0 0
/dev/sda2 /windows/D fuseblk rw,noexec,nosuid,nodev,noatime,allow_other,default_permissions,blksize=4096 0 0
/dev/sdc1 /windows/E fuseblk rw,noexec,nosuid,nodev,noatime,allow_other,default_permissions,blksize=4096 0 0
/dev/sdb5 /local ext3 rw,acl,user_xattr 0 0
securityfs /sys/kernel/security securityfs rw 0 0

Meine fstab:

/dev/disk/by-id/scsi-SATA_SAMSUNG_SP2004CS07GJ1NL605233-part2 / ext3 acl,user_xattr 1 1
/dev/disk/by-id/scsi-SATA_SAMSUNG_SP2004CS07GJ1NL605233-part3 /home ext3 acl,user_xattr 1 2
/dev/disk/by-id/scsi-SATA_Maxtor_6V200E0_V40431NG-part1 /windows/C vfat users,gid=users,umask=0002,utf8=true 0 0
/dev/disk/by-id/scsi-SATA_Maxtor_6V200E0_V40431NG-part2 /windows/D ntfs-3g users,gid=users,fmask=133,dmask=022,locale=de_DE.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_Maxtor_6L160M0_L40RK9EG-part1 /windows/E ntfs-3g users,gid=users,fmask=133,dmask=022,locale=de_DE.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_SAMSUNG_SP2004CS07GJ1NL605233-part1 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/fd0 /media/floppy auto noauto,user,sync 0 0
/dev/disk/by-id/scsi-SATA_WDC_WD2500JD-00WD-WCAL72507207-part5 /local ext3 acl,rw,user_xattr 1 2

Was ist falsch? Für Hilfe herzlichen Dank.

Mit freundlichen Grüßen

schmiha

NS: Es sieht aus, als wenn er während des Vorgangs kopieren die Schreibrechte verliert
Zuletzt geändert von schmiha am 8. Dez 2007, 16:02, insgesamt 1-mal geändert.
Intel Pentium D820 Dual Core, 2048 MB DDR II NVIDIA Geforce 6200LE 128 MB OpenSuSE 11.1, Kernel 2.6.27.7-9-pae Kabel Highspeed 30000

Werbung:
admine
Administrator
Administrator
Beiträge: 8782
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Beitrag von admine » 7. Dez 2007, 08:46

Wie sieht denn die Ausgabe von "mount" aus?
Und das "rw" in den Optionen muss da nicht rein - ich würde es sogar entfernen.
Schreibrechte für Linux-Partitionen werden auf dem Mount-Punkt vergeben.
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Benutzeravatar
schmiha
Newbie
Newbie
Beiträge: 44
Registriert: 26. Mär 2005, 19:33

Beitrag von schmiha » 7. Dez 2007, 18:07

Guten Abend, Admine

linux-sgfu:~ # mount /local
linux-sgfu:~ #


ohne Fehlermeldung gemountet.

Das rw habe ich aus de fstab und mtab entfernt.


Gruss
schmiha
Intel Pentium D820 Dual Core, 2048 MB DDR II NVIDIA Geforce 6200LE 128 MB OpenSuSE 11.1, Kernel 2.6.27.7-9-pae Kabel Highspeed 30000

admine
Administrator
Administrator
Beiträge: 8782
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Beitrag von admine » 7. Dez 2007, 20:38

Ja und ... gibts Erfolge / Veränderungen?
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Benutzeravatar
schmiha
Newbie
Newbie
Beiträge: 44
Registriert: 26. Mär 2005, 19:33

Beitrag von schmiha » 7. Dez 2007, 23:07

Guten Abend,

nein, leider nicht. Kopiervorgang wird nach ca. 30-40 % langsamer und bleibt dann mit "verzögert" stehen.

Gruss

schmiha
Intel Pentium D820 Dual Core, 2048 MB DDR II NVIDIA Geforce 6200LE 128 MB OpenSuSE 11.1, Kernel 2.6.27.7-9-pae Kabel Highspeed 30000

admine
Administrator
Administrator
Beiträge: 8782
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Beitrag von admine » 7. Dez 2007, 23:09

Und genau in dieser Situation gibst du

Code: Alles auswählen

mount
ein (sonst nichts) und du kannst die momentanen Optionen erkennen.
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Benutzeravatar
schmiha
Newbie
Newbie
Beiträge: 44
Registriert: 26. Mär 2005, 19:33

Beitrag von schmiha » 7. Dez 2007, 23:34

Guten Abend,

nachstehend mount, nachdem es hängen blieb:

hans@linux-sgfu:~> mount
/dev/sdd2 on / type ext3 (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/sdd3 on /home type ext3 (rw,acl,user_xattr)
/dev/sda1 on /windows/C type vfat (rw,noexec,nosuid,nodev,gid=100,umask=0002,utf8=true)
/dev/sda2 on /windows/D type fuseblk (rw,noexec,nosuid,nodev,noatime,allow_other,default_permissions,blksize=4096)
/dev/sdc1 on /windows/E type fuseblk (rw,noexec,nosuid,nodev,noatime,allow_other,default_permissions,blksize=4096)
/dev/sdb5 on /local type ext3 (rw,acl,user_xattr)
securityfs on /sys/kernel/security type securityfs (rw)
hans@linux-sgfu:~>

Seltsam, habe rw aus der fstab und mtab gelöscht und jetzt ist es wieder drin??
Beim herunterfahren kommt auch die Meldung can not create link etc/mtab.

Gruss

schmiha



Gruss

schmiha
Intel Pentium D820 Dual Core, 2048 MB DDR II NVIDIA Geforce 6200LE 128 MB OpenSuSE 11.1, Kernel 2.6.27.7-9-pae Kabel Highspeed 30000

Benutzeravatar
schmiha
Newbie
Newbie
Beiträge: 44
Registriert: 26. Mär 2005, 19:33

Beitrag von schmiha » 7. Dez 2007, 23:44

Guten Abend,

hab mir mal das Systemprotokoll angesehen,

dies könnte was sein:

Dec 7 23:28:34 linux-sgfu kernel: EXT3-fs error (device sdb5): read_block_bitmap: Cannot read block bitmap - block_group = 1023, block_bitmap = 33521664
Dec 7 23:28:34 linux-sgfu kernel: sd 1:0:0:0: [sdb] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK,SUGGEST_OK
Dec 7 23:28:34 linux-sgfu kernel: end_request: I/O error, dev sdb, sector 268077272
Dec 7 23:28:34 linux-sgfu kernel: ext3_abort called.
Dec 7 23:28:34 linux-sgfu kernel: EXT3-fs error (device sdb5): ext3_journal_start_sb: Detected aborted journal
Dec 7 23:28:34 linux-sgfu kernel: Remounting filesystem read-only
Dec 7 23:28:34 linux-sgfu kernel: EXT3-fs error (device sdb5) in ext3_prepare_write: IO failure
Dec 7 23:28:34 linux-sgfu kernel: EXT3-fs error (device sdb5): ext3_find_entry: reading directory #8831809 offset 0
Dec 7 23:28:34 linux-sgfu kernel: __journal_remove_journal_head: freeing b_frozen_data
Dec 7 23:28:34 linux-sgfu kernel: __journal_remove_journal_head: freeing b_committed_data
Dec 7 23:28:34 linux-sgfu kernel: __journal_remove_journal_head: freeing b_frozen_data
Dec 7 23:29:04 linux-sgfu kernel: printk: 23209 messages suppressed.
Dec 7 23:29:04 linux-sgfu kernel: Buffer I/O error on device sdb5, logical block 33456128
Dec 7 23:29:04 linux-sgfu kernel: lost page write due to I/O error on sdb5
Dec 7 23:29:04 linux-sgfu kernel: Buffer I/O error on device sdb5, logical block 33472144
Dec 7 23:29:04 linux-sgfu kernel: lost page write due to I/O error on sdb5
Dec 7 23:29:04 linux-sgfu kernel: Buffer I/O error on device sdb5, logical block 33473169
Dec 7 23:29:04 linux-sgfu kernel: lost page write due to I/O error on sdb5
Dec 7 23:29:04 linux-sgfu kernel: Buffer I/O error on device sdb5, logical block 33474194
Dec 7 23:29:04 linux-sgfu kernel: lost page write due to I/O error on sdb5
Dec 7 23:29:04 linux-sgfu kernel: Buffer I/O error on device sdb5, logical block 33475219
Dec 7 23:29:04 linux-sgfu kernel: lost page write due to I/O error on sdb5
Dec 7 23:29:04 linux-sgfu kernel: Buffer I/O error on device sdb5, logical block 33476244
Dec 7 23:29:04 linux-sgfu kernel: lost page write due to I/O error on sdb5
Dec 7 23:29:09 linux-sgfu kernel: printk: 44 messages suppressed.
Dec 7 23:29:09 linux-sgfu kernel: Buffer I/O error on device sdb5, logical block 8
Dec 7 23:29:09 linux-sgfu kernel: lost page write due to I/O error on sdb5
Dec 7 23:34:03 linux-sgfu gconfd (hans-5415): Der GConf-Server wird nicht verwendet und daher beendet.
Dec 7 23:34:03 linux-sgfu gconfd (hans-5415): Beenden

Gruss

schmiha
Intel Pentium D820 Dual Core, 2048 MB DDR II NVIDIA Geforce 6200LE 128 MB OpenSuSE 11.1, Kernel 2.6.27.7-9-pae Kabel Highspeed 30000

admine
Administrator
Administrator
Beiträge: 8782
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Beitrag von admine » 7. Dez 2007, 23:46

Lass doch mal einen Filesystemcheck über die Partition laufen.
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 8. Dez 2007, 00:29

Code: Alles auswählen

Dec 7 23:28:34 linux-sgfu kernel: EXT3-fs error (device sdb5): ext3_journal_start_sb: Detected aborted journal 
 Dec 7 23:28:34 linux-sgfu kernel: Remounting filesystem read-only 
Eigentlich ganz eindeutige Meldung. Schleunigst das Filesystem checken und auch die Festplatte als solche mal prüfen.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

Benutzeravatar
schmiha
Newbie
Newbie
Beiträge: 44
Registriert: 26. Mär 2005, 19:33

Beitrag von schmiha » 8. Dez 2007, 16:04

Guten Tag

habe mit tune2fs -C 1 /dev/sda5 einen das Dateisystem überprüft und es wurden einige Fehler gefunden. Jetzt klappt es wieder. Habe den Count danach wieder auf 30 gesetzt.

Danke für die Hilfe.

Gruss
schmiha :D
Intel Pentium D820 Dual Core, 2048 MB DDR II NVIDIA Geforce 6200LE 128 MB OpenSuSE 11.1, Kernel 2.6.27.7-9-pae Kabel Highspeed 30000

Antworten