Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

(gelöst) internetverbindung von win-xp guest über NAT??

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
stolley
Hacker
Hacker
Beiträge: 257
Registriert: 30. Jul 2006, 11:29

(gelöst) internetverbindung von win-xp guest über NAT??

Beitrag von stolley » 30. Nov 2007, 16:55

hi leute!

ich habe nun vmware-server zum laufen bekommen (auf suse 10.3).
jetzt möchte ich noch mit meinem guest (win xp) ins internet.

ich habe mich dazu auch eifrig belesen, komme aber dennoch nicht weiter. habe also folgendes gemacht:

die config von vmware über das any-any-update ausgeführt. dort habe ich "NAT" als gewünschte netzwerk-option ausgewählt. als ip habe ich 192.168.1.2 (die ip meines linux-hosts beim router) und als subnet natürlich 255.255.255.0 angegeben. (der router hat die ip 192.168.1.1)

soweit so gut. habe in vmware-server auch den guest auf "NAT" eingestellt. im guest bin ich dann zur konfiguration der lan-verbindung gegangen und habe unter tcp-ip lediglich einen eintrag unter "gateway" gemacht: nämlich 192.168.1.2.

so, aber die lan-verbindung will trotzdem nicht! habe auch keine firewall aktiviert!

ist der weg, den ich beschritten habe, denn überhaupt richtig?

danke schonmal für die vorangegangenen tipps, die mich so weit gebracht haben!

volker
Zuletzt geändert von stolley am 4. Dez 2007, 19:30, insgesamt 1-mal geändert.

Werbung:
Benutzeravatar
longman
Advanced Hacker
Advanced Hacker
Beiträge: 866
Registriert: 22. Apr 2004, 19:01
Wohnort: zuhause

Beitrag von longman » 1. Dez 2007, 01:06

Du kannst der VM doch eine bridged Karte zuweisen und dann den Router als Gateway
(eventuell auch DHCP, falls Du das willst) angeben.

Die bridged Karte liefert dem Router ja auch eine MAC anhand derer Du auch eine statische DHCP IP-Adresse eintragen klannst.
Tschüss bis neulich,
Gruss Burkhard aka longman
- This System is MS free and works fine -


Linupedia - Wiki des Linux Club | NICHT LESEN! AUF GAR KEINEN FALL! NIEMALS NICHT!

Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Re: internetverbindung von win-xp guest über NAT??

Beitrag von Martin Breidenbach » 1. Dez 2007, 15:54

stolley hat geschrieben:dort habe ich "NAT" als gewünschte netzwerk-option ausgewählt. als ip habe ich 192.168.1.2 (die ip meines linux-hosts beim router) und als subnet natürlich 255.255.255.0 angegeben. (der router hat die ip 192.168.1.1)
Nee, das geht etwas anders.

NAT bedeutet daß VMware ein 'internes Netz' anlegt und das nach außen über 192.168.1.2 'geNATtet' wird. In diesem 'internen Netz' gibt es einen DHCP Server. Stell das OS ind er VM mal auf DHCP und schau was er sich da für eine IP Konfiguration 'zieht'. Damit sollte er dann auch ins Internet kommen.

Du könntest auch 'bridged' verwenden und dann dem Rechner z.B. die 192.168.1.3 geben.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !

stolley
Hacker
Hacker
Beiträge: 257
Registriert: 30. Jul 2006, 11:29

Beitrag von stolley » 3. Dez 2007, 14:36

tell das OS ind er VM mal auf DHCP und schau was er sich da für eine IP Konfiguration 'zieht'. Damit sollte er dann auch ins Internet kommen.
das habe ich nun gerade versucht. firewall in Windows ist aus! und er zieht irgendeine ip mit 169..... - also irgendwas für mich fremdartiges.

aber unter gesendete bzw. empfange pakete hat er einiges stehen. er sagt allerdings auch, dass er konnektivitätsprobleme habe: "...weil das netzwerk diesem computer keine netzwerkadresse zugewiesen hat"!

seltsam, oder? wenn ich versuche ins internet zu gehen, tut sich bei den "paketen" was, aber ne verbindung kriegt er nicht zustande.

zur info mal meine vmx:
#!/usr/bin/vmware
config.version = "8"
virtualHW.version = "4"
scsi0.present = "TRUE"
memsize = "128"
ide0:0.present = "TRUE"
ide0:0.fileName = "Windows XP Professional.vmdk"
ide0:0.writeThrough = "TRUE"
ide1:0.present = "TRUE"
ide1:0.fileName = "/dev/scd0"
ide1:0.deviceType = "cdrom-raw"
floppy0.fileName = "/dev/fd0"
Ethernet0.present = "TRUE"
displayName = "Windows XP Professional"
guestOS = "winxppro"
priority.grabbed = "normal"
priority.ungrabbed = "normal"
powerType.powerOff = "hard"
powerType.powerOn = "hard"
powerType.suspend = "hard"
powerType.reset = "hard"

uuid.location = "56 4d e7 67 e3 86 84 34-e9 8f 47 57 f3 d4 9d 11"
uuid.bios = "56 4d e7 67 e3 86 84 34-e9 8f 47 57 f3 d4 9d 11"

ide0:0.redo = ""
ethernet0.addressType = "generated"
ethernet0.generatedAddress = "00:0c:29:d4:9d:11"
ethernet0.generatedAddressOffset = "0"

ide0:1.present = "TRUE"
ide0:1.fileName = "/dev/scd1"
ide0:1.deviceType = "cdrom-raw"

gui.exitAtPowerOff = "FALSE"
gui.fullScreenAtPowerOn = "TRUE"

ide0:1.startConnected = "TRUE"
tools.syncTime = "FALSE"

gui.powerOnAtStartup = "FALSE"

usb.present = "TRUE"
usb.generic.autoconnect = "FALSE"

usb.autoConnect.device0 = ""

Ethernet0.connectionType = "nat"
wäre euch für weitere hilfe echt dankbar!

Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach » 3. Dez 2007, 21:56

stolley hat geschrieben: und er zieht irgendeine ip mit 169..... - also irgendwas für mich fremdartiges.
Das riecht nach APIPA:

http://de.wikipedia.org/wiki/APIPA

Das heißt er kriegt keine IP von irgendeinem DHCP sondern denkt sich selber was aus.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !

stolley
Hacker
Hacker
Beiträge: 257
Registriert: 30. Jul 2006, 11:29

Beitrag von stolley » 3. Dez 2007, 22:03

Das heißt er kriegt keine IP von irgendeinem DHCP sondern denkt sich selber was aus.
ähm, danke für den hinweis.
leider kapier ich das nicht ganz: was kann ich denn jetzt unternehmen? oder soll ich doch lieber auf die bridged-variante zurückgreifen?

stolley
Hacker
Hacker
Beiträge: 257
Registriert: 30. Jul 2006, 11:29

Beitrag von stolley » 3. Dez 2007, 22:06

ah, das hier muss ich machen?
Hier kann man dieses Verhalten in der Registry im Schlüssel HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces abschalten. Dazu muss beim betroffenen Interface ein neuer DWORD-Wert mit dem Namen IPAutoconfigurationEnabled und dem Wert 0 erstellt werden.

stolley
Hacker
Hacker
Beiträge: 257
Registriert: 30. Jul 2006, 11:29

Beitrag von stolley » 4. Dez 2007, 19:30

das problem hat sich dadurch in luft aufgelöst, dass ich auf die bridged-variante umgestiegen bin. damit klappt es problemlos: einfach im guest die lan-verbindung so einrichten, wie gewohnt. als ip muss man allerdings eine neue wählen.

Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach » 4. Dez 2007, 21:10

Sollte mit NAT auch gehen... aber Hauptsache es funktioniert. Offenbar klappt unter NAT der interne DHCP irgendwie nicht. Ich benutze hier eigentlich immer bridged.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast