hylafax + fritzcard will unter suse 9.1 nicht laufen, HILFE

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
kamik-aze
Newbie
Newbie
Beiträge: 7
Registriert: 11. Jun 2004, 16:14
Kontaktdaten:

hylafax + fritzcard will unter suse 9.1 nicht laufen, HILFE

Beitrag von kamik-aze » 11. Jun 2004, 16:54

Hi,

erstmal auch von mir ein lob für die Mühe des Tutorials.

Und nun zu meinem Problem, also ich habe SuSE 9.1 incl. i4l, capisuite und capi4hylafax installiert. Es funktionirt soweit alles bis auf das fax senden und empfanegn, d. h. capisuite scheint zu funktionieren.

Ich habe die Installaionsanweisungen strikt befolgt und es hat alles soweit geklappt bis auf eine Kleinigkeit und zwar bei dem Schritt wo man faxstat aufruft bekomm ich nur folgende ausgabe:

HylaFAX scheduler on localhost: Running

Ansonsten habe ich noch folgende merkwürdigkeiten entdeckt:

1.

beim späteren Schritt wenn ich
sendfax -d horst@942056 /etc/mtab
aufrufe bekomm ich die seltsame meldung wie schon weiter oben beschrieben von kalunke erwähnt ist, nämlich:
request id is 6 (group id 6) for host localhost (1 file)
und es passiert gar nichts.

2.

wenn ich mit einem ISDN-Telefon auf die MSN die das Fax bekommen hat anrufe hör ich das schreckliche Rauschen eines Faxgeräts und K ISDN watch zeigt das eine Leitung belegt ist, d.h. irgedwie tut das Ding ja, aber irgendwie doch nicht richtrig wenn ich nichts senden kann.

3.

wenn ich aus KDE eine Datei über fax drucken möchte (an mich selbs schicke) scheint alles zu funktionieren, zumindest zeigt K ISDN watch an dass die er sich ein und auswählt da beide ISDN Leitungen gleichzeitig belegt sind und wieder frei werden aber in der Datei /var/log/capisuite.log steht folgendes

Fri Jun 11 16:10:21 2004 Pythonscript /usr/lib/capisuite/idle.py,idle,0x818ced0: executing idlescript...
Fri Jun 11 16:10:21 2004 Pythonscript /usr/lib/capisuite/idle.py,idle,0x818ced0: idlescript finished...
Fri Jun 11 16:10:52 2004 Pythonscript /usr/lib/capisuite/idle.py,idle,0x818ced0: executing idlescript...
Fri Jun 11 16:10:52 2004 CapiSuite 0xbffff030: job fax-4.sff from horst to 942056 initiated
Fri Jun 11 16:10:52 2004 Connection 0x81e8cc8: Connection object created for outgoing call from 942056 to 942056 service 1
Fri Jun 11 16:10:52 2004 Connection 0x81e8cc8: using faxStationID 942056 faxHeadline hg CLIR 0
Fri Jun 11 16:10:52 2004 Capi 0x8169680: >CONNECT_REQ: ApplId 0x2, MsgNr 0x13, Controller 0x1 CIPValue 0x11, B1proto 0x4, B2proto 0x4, B3proto 0x5
Fri Jun 11 16:10:52 2004 Capi 0x8169680: info: 0
Fri Jun 11 16:10:52 2004 Capi 0x8169680: *
Fri Jun 11 16:10:52 2004 Capi 0x8169680: <CONNECT_CONF, PLCI: 0x101, Info 0x0
Fri Jun 11 16:10:52 2004 Connection 0x81e8cc8: got PLCI 101
Fri Jun 11 16:10:52 2004 Capi 0x8169680: **
Fri Jun 11 16:10:52 2004 Capi 0x8169680: *
Fri Jun 11 16:10:52 2004 Capi 0x8169680: <INFO_IND: Controller/PLCI 0x101, InfoNumber 800d (ignoring)
Fri Jun 11 16:10:52 2004 Capi 0x8169680: >INFO_RESP ApplId 0x2, MsgNr 0x2e, Address 0x101
Fri Jun 11 16:10:52 2004 Capi 0x8169680: info: 0
Fri Jun 11 16:10:52 2004 Capi 0x8169680: **
Fri Jun 11 16:10:52 2004 Capi 0x8169680: *
Fri Jun 11 16:10:52 2004 Capi 0x8169680: <CONNECT_IND PLCI 0x201 CIP 0x11
Fri Jun 11 16:10:52 2004 Connection 0x81ec560: Connection object created for incoming call PLCI 201 from - to 942056 CIP 0x11
Fri Jun 11 16:10:52 2004 Capi 0x8169680: **
Fri Jun 11 16:10:52 2004 Capi 0x8169680: *
Fri Jun 11 16:10:52 2004 Capi 0x8169680: <DISCONNECT_IND PLCI 0x201 Reason 0x3304
Fri Jun 11 16:10:52 2004 Capi 0x8169680: >DISCONNECT_RESP ApplId 0x2 MsgNum 0x35 PLCI 0x201
Fri Jun 11 16:10:52 2004 Capi 0x8169680: info: 0
Fri Jun 11 16:10:52 2004 Capi 0x8169680: **
Fri Jun 11 16:10:52 2004 Pythonscript /usr/lib/capisuite/incoming.py,callIncoming,0x81de678: PythonScript created.
Fri Jun 11 16:10:52 2004 Pythonscript /usr/lib/capisuite/incoming.py,callIncoming,0x81de678: Connection 0x81ec560 created IncomingScript
Fri Jun 11 16:10:52 2004 Connection 0x81ec560: call from - to 942056 for horst connecting with fax
Fri Jun 11 16:10:52 2004 Connection 0x81ec560: accepting with service 1
Fri Jun 11 16:10:52 2004 Connection 0x81ec560: using faxStationID 942056 faxHeadline hg
Fri Jun 11 16:10:52 2004 Connection 0x81ec560: connection lost with cause 0x3304,0x0
Fri Jun 11 16:10:52 2004 Connection 0x81ec560: Python: deleting connection object
Fri Jun 11 16:10:52 2004 Connection 0x81ec560: stop_file_transmission initiated
Fri Jun 11 16:10:52 2004 Connection 0x81ec560: stop_file_transmission finished
Fri Jun 11 16:10:52 2004 Connection 0x81ec560: stop_file_reception finished
Fri Jun 11 16:10:52 2004 Connection 0x81ec560: Connection object deleted
Fri Jun 11 16:10:52 2004 Pythonscript /usr/lib/capisuite/incoming.py,callIncoming,0x81de678: IncomingScript deleted
Fri Jun 11 16:10:52 2004 Pythonscript /usr/lib/capisuite/incoming.py,callIncoming,0x81de678: PythonScript deleted.
Fri Jun 11 16:10:53 2004 Capi 0x8169680: *
Fri Jun 11 16:10:53 2004 Capi 0x8169680: <INFO_IND: Controller/PLCI 0x101, InfoNumber 8002 (ignoring)
Fri Jun 11 16:10:53 2004 Capi 0x8169680: >INFO_RESP ApplId 0x2, MsgNr 0x36, Address 0x101
Fri Jun 11 16:10:53 2004 Capi 0x8169680: info: 0
Fri Jun 11 16:10:53 2004 Capi 0x8169680: **
Fri Jun 11 16:10:53 2004 Capi 0x8169680: *
Fri Jun 11 16:10:53 2004 Capi 0x8169680: <CONNECT_ACTIVE_IND PLCI 0x101
Fri Jun 11 16:10:53 2004 Capi 0x8169680: >CONNECT_ACTIVE_RESP ApplId 0x2 MsgNum 0x38 PLCI 0x101
Fri Jun 11 16:10:53 2004 Capi 0x8169680: info: 0
Fri Jun 11 16:10:53 2004 Capi 0x8169680: >CONNECT_B3_REQ: ApplId 0x2, MsgNr 0x13, PLCI 0x101
Fri Jun 11 16:10:53 2004 Capi 0x8169680: info: 0
Fri Jun 11 16:10:53 2004 Capi 0x8169680: **
Fri Jun 11 16:10:53 2004 Capi 0x8169680: *
Fri Jun 11 16:10:53 2004 Capi 0x8169680: <CONNECT_B3_CONF, NCCI: 0x10101, Info 0x0
Fri Jun 11 16:10:53 2004 Capi 0x8169680: **
Fri Jun 11 16:11:00 2004 Capi 0x8169680: *
Fri Jun 11 16:11:00 2004 Capi 0x8169680: <CONNECT_B3_ACTIVE_IND NCCI 0x10101
Fri Jun 11 16:11:00 2004 Capi 0x8169680: >CONNECT_B3_ACTIVE_RESP ApplId 0x2 MsgNum 0x39 NCCI 0x10101
Fri Jun 11 16:11:00 2004 Capi 0x8169680: info: 0
Fri Jun 11 16:11:00 2004 Connection 0x81e8cc8: fax connected with rate 64000, lowRes, ID: +49 7663 942056
Fri Jun 11 16:11:00 2004 Capi 0x8169680: **
Fri Jun 11 16:11:00 2004 Connection 0x81e8cc8: start_file_transmission /var/spool/capisuite/users/horst/sendq/fax-4.sff
Fri Jun 11 16:11:00 2004 Capi 0x8169680: >DATA_B3_REQ ApplId 0x2, msgNum 0x14, NCCI 0x10101, DataLen 2048, DataHandle 0, Flags 0x0
Fri Jun 11 16:11:00 2004 Capi 0x8169680: info: 0
Fri Jun 11 16:11:00 2004 Capi 0x8169680: >DATA_B3_REQ ApplId 0x2, msgNum 0x15, NCCI 0x10101, DataLen 2048, DataHandle 1, Flags 0x0
Fri Jun 11 16:11:00 2004 Capi 0x8169680: info: 0
Fri Jun 11 16:11:00 2004 Capi 0x8169680: >DATA_B3_REQ ApplId 0x2, msgNum 0x16, NCCI 0x10101, DataLen 2048, DataHandle 2, Flags 0x0
Fri Jun 11 16:11:00 2004 Capi 0x8169680: info: 0
Fri Jun 11 16:11:00 2004 Capi 0x8169680: >DATA_B3_REQ ApplId 0x2, msgNum 0x17, NCCI 0x10101, DataLen 2048, DataHandle 3, Flags 0x0
Fri Jun 11 16:11:00 2004 Capi 0x8169680: info: 0
Fri Jun 11 16:11:02 2004 Capi 0x8169680: *
Fri Jun 11 16:11:02 2004 Capi 0x8169680: <INFO_IND: Controller/PLCI 0x101, InfoNumber 1e (ignoring)
Fri Jun 11 16:11:02 2004 Capi 0x8169680: >INFO_RESP ApplId 0x2, MsgNr 0x3e, Address 0x101
Fri Jun 11 16:11:02 2004 Capi 0x8169680: info: 0
Fri Jun 11 16:11:02 2004 Capi 0x8169680: **
Fri Jun 11 16:11:02 2004 Capi 0x8169680: *
Fri Jun 11 16:11:02 2004 Capi 0x8169680: <DISCONNECT_B3_IND NCCI 0x10101 Reason 0x3314
Fri Jun 11 16:11:02 2004 Connection 0x81e8cc8: fax finished with rate 64000, hiRes, ID: +49 7663 942056, 0 pages
Fri Jun 11 16:11:02 2004 Connection 0x81e8cc8: stop_file_transmission initiated
Fri Jun 11 16:11:02 2004 Connection 0x81e8cc8: stop_file_transmission finished
Fri Jun 11 16:11:02 2004 Connection 0x81e8cc8: stop_file_reception finished
Fri Jun 11 16:11:02 2004 Capi 0x8169680: >DISCONNECT_B3_RESP ApplId 0x2 MsgNum 0x3f NCCI 0x10101
Fri Jun 11 16:11:02 2004 Capi 0x8169680: info: 0
Fri Jun 11 16:11:02 2004 Capi 0x8169680: **
Fri Jun 11 16:11:02 2004 Connection 0x81e8cc8: disconnect initiated
Fri Jun 11 16:11:02 2004 Capi 0x8169680: >DISCONNECT_REQ ApplId 0x2 MsgNum 0x18 PLCI 0x101
Fri Jun 11 16:11:02 2004 Capi 0x8169680: info: 0
Fri Jun 11 16:11:02 2004 Capi 0x8169680: *
Fri Jun 11 16:11:02 2004 Capi 0x8169680: <DISCONNECT_CONF PLCI 0x101 Info 0x0
Fri Jun 11 16:11:02 2004 Capi 0x8169680: **
Fri Jun 11 16:11:02 2004 Capi 0x8169680: *
Fri Jun 11 16:11:02 2004 Capi 0x8169680: <DISCONNECT_IND PLCI 0x101 Reason 0x3490
Fri Jun 11 16:11:02 2004 Capi 0x8169680: >DISCONNECT_RESP ApplId 0x2 MsgNum 0x40 PLCI 0x101
Fri Jun 11 16:11:02 2004 Capi 0x8169680: info: 0
Fri Jun 11 16:11:02 2004 Capi 0x8169680: **
Fri Jun 11 16:11:03 2004 Connection 0x81e8cc8: Python: deleting connection object
Fri Jun 11 16:11:03 2004 Connection 0x81e8cc8: stop_file_transmission initiated
Fri Jun 11 16:11:03 2004 Connection 0x81e8cc8: stop_file_transmission finished
Fri Jun 11 16:11:03 2004 Connection 0x81e8cc8: stop_file_reception finished
Fri Jun 11 16:11:03 2004 Connection 0x81e8cc8: Connection object deleted
Fri Jun 11 16:11:03 2004 CapiSuite 0xbffff030: job fax-4.sff: result was 3490,3314
Fri Jun 11 16:11:03 2004 CapiSuite 0xbffff030: job fax-4.sff: delayed for 60 seconds
Fri Jun 11 16:11:03 2004 CapiSuite 0xbffff030: job fax-4.sff: failed finally
Fri Jun 11 16:12:03 2004 CapiSuite 0xbffff030: sendmail finished successful
Fri Jun 11 16:12:03 2004 Pythonscript /usr/lib/capisuite/idle.py,idle,0x818ced0: idlescript finished...
Fri Jun 11 16:12:34 2004 Pythonscript /usr/lib/capisuite/idle.py,idle,0x818ced0: executing idlescript...
Fri Jun 11 16:12:34 2004 Pythonscript /usr/lib/capisuite/idle.py,idle,0x818ced0: idlescript finished...
Fri Jun 11 16:13:04 2004 Pythonscript /usr/lib/capisuite/idle.py,idle,0x818ced0: executing idlescript...



Also echt seltsam, ich hoffe ihr könnt mir irgendwie helfen ich hab keine Ahnung wie ich weiter machen soll.

Danke schon mal im Vorraus

Werbung:
Bonsai
Advanced Hacker
Advanced Hacker
Beiträge: 853
Registriert: 10. Mär 2004, 12:54
Wohnort: Rhein - Neckar

Beitrag von Bonsai » 11. Jun 2004, 19:42

Wie Running aber nicht idle????

Was sagt den top? Hat sich der Prozess vielleicht aufgehängt?

Ausserdem, ist denn für den Prozess, der Faxe entgegennehmen soll ein Eintrag in der /etc/inittab? Hmm, müsste eigentlich das Fax brüllt Dir ja ins Ohr. Müsste aber eigentlich auflegen, Du brüllst ja nicht zurück.

Du willst ein Fax an Dich selbst schicken? Hmmm 2 Leitungen auf dem gleichen Endgerät, ob die Telefonanlage das versteht, das das Gerät selbstgespräche führen will? Fax mal an ein Telefon!
Wer ein Problem erkannt hat und nichts dagegen unternimmt, ist ein Teil des Problems (Indianisches Sprichwort)

kamik-aze
Newbie
Newbie
Beiträge: 7
Registriert: 11. Jun 2004, 16:14
Kontaktdaten:

Beitrag von kamik-aze » 12. Jun 2004, 16:12

Hi,

also top sagt: alles OK, prozess läuft,
hab auch mal versucht rauszufaxen, geht auch nicht, genau das selbe wie sonst auch.
Wenn jemand ein Fax am mich schickt dann hebt mein Rechner sogar ab aber er legtr dann nach 6 oder 7 sekunden wieder auf, mit dem selben Fehler wie sonst auch.

In der /var/log/capisuite.log steht immer das gleiche nämlich diese Meldungen:
Capi 0x8169680: <DISCONNECT_IND PLCI 0x201 Reason 0x3304
bzw.
Capi 0x8169680: <DISCONNECT_B3_IND NCCI 0x10101 Reason 0x3314

ansonsten gibt es keine log-files die mir irgendetwas sagen wo das Problem liegen könnte.

Ich weis echt nicht mehr wo ich das anpacken soll, es scheint alles OK zu sein tut aber nichts !!!

Weis irgendjemand von euch wie ich weiter machen kann oder hat jemand schon mal sowas ähnliches gesehen ???

Bonsai
Advanced Hacker
Advanced Hacker
Beiträge: 853
Registriert: 10. Mär 2004, 12:54
Wohnort: Rhein - Neckar

Beitrag von Bonsai » 12. Jun 2004, 23:14

Auch nicht in /var/spool/fax/log :?:
Wer ein Problem erkannt hat und nichts dagegen unternimmt, ist ein Teil des Problems (Indianisches Sprichwort)

kamik-aze
Newbie
Newbie
Beiträge: 7
Registriert: 11. Jun 2004, 16:14
Kontaktdaten:

Beitrag von kamik-aze » 13. Jun 2004, 20:23

nee das verzeichnis ist leer

Bonsai
Advanced Hacker
Advanced Hacker
Beiträge: 853
Registriert: 10. Mär 2004, 12:54
Wohnort: Rhein - Neckar

Beitrag von Bonsai » 13. Jun 2004, 21:10

Installier mal die neueste Version von capi4hylafax!

Kann Dein Kernel ISDN? Hast Du den selber gebaut oder ist das der Standardkernel.


Moment, Du hast eine Passive Karte, oder eine aktive?
Ist genau der Treiber der richtige? Hol Dir den aktuellen von www.avm.de und achte darauf, dass es der richtige für genau die Karte ist!
Wer ein Problem erkannt hat und nichts dagegen unternimmt, ist ein Teil des Problems (Indianisches Sprichwort)

kamik-aze
Newbie
Newbie
Beiträge: 7
Registriert: 11. Jun 2004, 16:14
Kontaktdaten:

Beitrag von kamik-aze » 14. Jun 2004, 13:38

Hi,

also die Karte ist eine stinknormale Fritz PCI DSL Karte mit ISDN, habe früher schon öfters Fritz-Karten (damals nur die classic ISDN) unter SuSE zum laufen gebracht niemals mit irgendwelchen Problemen.

Momentan verwende ich die von SuSE 9.1 mitgelieferten Paketen und den Standardkernel.

Ich hab da mal was gelsen vonwegen dass die avm oder capi Pakete (weis nicht mehr welche genau) probleme mit Multiprozessorsystemen machen, weis aber nicht mehr genau was und wieso, ist schon ne weile her. Und die Kiste ist ein dual-proz system, vielleicht hat das ja was damit zu tun ???


Kann mal die neuesten Pakete ausprobieren werde aber nicht sehr bald dazu kommen, da der server weit weg von mir ist und ich erst in einer oder zwei wochen dort hin fahren werde.

Bonsai
Advanced Hacker
Advanced Hacker
Beiträge: 853
Registriert: 10. Mär 2004, 12:54
Wohnort: Rhein - Neckar

Beitrag von Bonsai » 14. Jun 2004, 15:42

Dann machs doch per ssh :)

Multiproz? Keine Ahnung, aber passive ISDN Karten sind immer haarig.
Wer ein Problem erkannt hat und nichts dagegen unternimmt, ist ein Teil des Problems (Indianisches Sprichwort)

kamik-aze
Newbie
Newbie
Beiträge: 7
Registriert: 11. Jun 2004, 16:14
Kontaktdaten:

Beitrag von kamik-aze » 14. Jun 2004, 18:38

ha,
ssh ist ja schön und gut das Problem ist nur: das ist ne kleine Firma und ich muss die Karte in einem windows client stecken lassen damit die eben faxe empfangen können, und per ssh kann ich leider nicht mal schnell die karte umbauen :-)

Ausserdem habe ich von hier aus wo ich im moment stecke auch kein Internetzugang ausser bei der Arbeit, dann müsste ich es eben von hier aus machen und es müsste mir jemand dor die karte umstecken usw....

Längere kompliziertere Geschickte deswegen mal ne Wocher oder zwei abwarten und dann weitersehen, aber trotzdem Danke erstmal für die schnelle Hilfe, ich melde mich dann sobald ich wieder dort bin und es immer noch nicht tut, keine Sorge :-)

Bonsai
Advanced Hacker
Advanced Hacker
Beiträge: 853
Registriert: 10. Mär 2004, 12:54
Wohnort: Rhein - Neckar

Beitrag von Bonsai » 14. Jun 2004, 20:20

Kannst ja solange noch was darüber Lesen. Mir persönlich hat das viel gebracht.
Wer ein Problem erkannt hat und nichts dagegen unternimmt, ist ein Teil des Problems (Indianisches Sprichwort)

kamik-aze
Newbie
Newbie
Beiträge: 7
Registriert: 11. Jun 2004, 16:14
Kontaktdaten:

funktioniert immer noch nicht aber ich weis woran es liegt

Beitrag von kamik-aze » 26. Jun 2004, 20:03

Hi,

also das Problem ist wirklich der Multiprozessor-Rechner.
Ich habe mal das gleiche auf einem anderen, also ein Single-Prozessor Rechner, gleiches Betriebssytem mit der selben Karte durchgeführt und siehe da es funktionierte auf anhieb.

Habe auch noch mal bei www.avm.de vorbeigeschaut und die sagen auch es geht nicht auf SMP-Rechnern, also die ganze Mühe umsonst.

naja wenigstens weis ich jetz wieso es nicht geht

Bonsai
Advanced Hacker
Advanced Hacker
Beiträge: 853
Registriert: 10. Mär 2004, 12:54
Wohnort: Rhein - Neckar

Beitrag von Bonsai » 2. Jul 2004, 01:37

Gut zu wissen :)
Wer ein Problem erkannt hat und nichts dagegen unternimmt, ist ein Teil des Problems (Indianisches Sprichwort)

kamik-aze
Newbie
Newbie
Beiträge: 7
Registriert: 11. Jun 2004, 16:14
Kontaktdaten:

Lösung

Beitrag von kamik-aze » 6. Jul 2004, 09:18

Hi,

also inzwischen habe ich eine Lösung gefunden die trotz Multipozessor-System funktionieren sollte, und zwar muss man eine Aktive ISDN Karte verwenden z. B. AVM B1, da die ja einen eigenen Prozessor hat (und somit wieder ein normales Uniprozessor-System zumindest für die Software darstellt).
Probiert habe ich es noch nicht weil ich noch nicht dazu gekommen bin aber ich sage bescheid ob es geht sobald ich die Sache getestet hab.

Bonsai
Advanced Hacker
Advanced Hacker
Beiträge: 853
Registriert: 10. Mär 2004, 12:54
Wohnort: Rhein - Neckar

Beitrag von Bonsai » 31. Jul 2004, 00:39

OK Danke!
Wer ein Problem erkannt hat und nichts dagegen unternimmt, ist ein Teil des Problems (Indianisches Sprichwort)

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste