Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] Truecrypt Mount in 10.2, externe Festplatte

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Bruno9999
Newbie
Newbie
Beiträge: 6
Registriert: 13. Okt 2007, 11:20
Wohnort: Baumkirchen in Tirol (Ösi)

[gelöst] Truecrypt Mount in 10.2, externe Festplatte

Beitrag von Bruno9999 » 21. Nov 2007, 14:19

Hallo Leute,

es tut mir leid, aber ich muss nerven. Leider bin ich noch ein Newbie, gebe mir aber alle Mühe. Ich hätte aber trotzdem folgende Frage:

Ich habe eine externe Festplatte mit Truecrypt und als NTFS verschlüsselt, damit ich sie auch unter Windows nutzen kann. Wenn ich richtig liege reden wir dann von einem Device, keinem Container. Soweit alles super. Jetzt wollte ich die Platte in Linux einbinden. Software installiert, viele Themen gelesen. Ich gebe folgenden Befehl in der Konsole ein:

truecrypt -M ntfs /dev/sda1

Danach werde ich nach dem Paßwort gefragt und anschließend finde ich über den Konqueror die Festplatte im Verzeichnis /dev/disk/by-label. Dort heisst sie so wie ich sie in Windows beschrieben habe (EDB_Privat_500_GB_crypted). Woanders finde ich Sie aber nicht.

Für mich heisst das Linux erkennt die Platte.

ABER wie kann ich nun auf die Daten zu greifen. Ich hätte mir einen Ordner dafür angelegt ( /home/Bruno/externe Festplatte/) - aber ich bin zu doof um diesen letzten Schritt noch zu schaffen.

Bitte um eure Hilfe

Danke, Bruno
Zuletzt geändert von Bruno9999 am 22. Nov 2007, 09:16, insgesamt 1-mal geändert.

Werbung:
Thomas4000
Member
Member
Beiträge: 178
Registriert: 8. Aug 2004, 20:20
Wohnort: Bayern

Beitrag von Thomas4000 » 21. Nov 2007, 19:16

Hi,
aus "man truecrypt"

Code: Alles auswählen

truecrypt [OPTIONS] VOLUME_PATH [MOUNT_DIRECTORY]
Also MOUNT_DIRECTORY noch anhängen. (Dei dir dann wohl /home/Bruno/externe Festplatte/ )

Bruno9999
Newbie
Newbie
Beiträge: 6
Registriert: 13. Okt 2007, 11:20
Wohnort: Baumkirchen in Tirol (Ösi)

Beitrag von Bruno9999 » 22. Nov 2007, 09:20

Hi, danke für die Antwort. Leider hat das so nicht funktioniert.

Die Lösung möchte ich hierher schreiben, da es vielleicht auch User gibt denen das selbe passiert:

1) ich habe meinen Mountordner umbenannt in /home/edb (also kürzer und OHNE Leerraum)
2) Der Befehl -M und Ntfs geht gar nicht, mit dem folgenden Befehl kann ich die Platte aber mal als "Read only" einbinden. Das ist zwar noch nicht das gelbe vom Ei, aber es hilft mächtig:

truecrypt -u /dev/sda1 /home/bruno/edb

Daher ist meine Anfrage teilweise gelöst.
Danke für den Hilfeversuch.

Bruno

Martini
Newbie
Newbie
Beiträge: 1
Registriert: 29. Nov 2007, 12:53

Beitrag von Martini » 29. Nov 2007, 13:10

Hallo,
ich schließe mich hier einfach mal an. Ich habe dasselbe Problem (Suse 10.3, externe HD, truecrypt-Container mit ntfs, mounten geht aber nur ohne Schreibrechte). Gibt es dazu eine Lösung? Ich habe mich mittlerweile durch zig Threads in diesem und anderen Foren gelesen aber nichts scheint zu klappen.
Besten Dank im Voraus!

Doc Green
Newbie
Newbie
Beiträge: 7
Registriert: 21. Mai 2006, 16:27

Beitrag von Doc Green » 30. Nov 2007, 13:18

Ich bin mir gerade etwas unsicher, ob mein Kenntnisstand noch aktuell ist, aber afaik wird NTFS vom Linux-Kernel nur experimentell unterstuetzt. Soll heissen es gibt zwar die eben experimentelle Moeglichkeit NTFS rw zu mounten, aber kann zu Fehlern kommen, also Datenverlust. Deswegen wird NTFS in den gaengigen Linux-Distributionen nur read-only gemountet. Vielleicht solltet ihr euch ueberlegen FAT-32 zu benutzen. Das funktioniert nach meiner Erfahrung wirklich ueberall mit Truecrypt.
So long
Doc

Antworten