Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[Erledigt] Virtualbox problem mit vboxdrv

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
lewendi
Hacker
Hacker
Beiträge: 685
Registriert: 27. Dez 2003, 16:11
Wohnort: Rosenheim

[Erledigt] Virtualbox problem mit vboxdrv

Beitrag von lewendi » 18. Nov 2007, 14:41

Servus,
ich habe auf mein Suse 10.3 Virtualbox 1.5.2 aufgesetzt.
Lt. Hinweis hier im Wiki habe ich den Bootloader und die sysconfig angepasst. Leider kommt , wenn ich auf "starten" gehe diese Fehlermeldung -ausgeführt auf der Konsole:

walter@Walter-Desk:~> VirtualBox
WARNING: The vboxdrv kernel module is not loaded. Either there is no module
available for the current kernel (2.6.22.12-0.1-default) or it failed t o
load. Please recompile the kernel module and install it by

sudo /etc/init.d/vboxdrv setup

You will not be able to start VMs until this problem is fixed.
WARNING: The compilation of the vboxdrv.ko kernel module failed during the
installation for some reason. Starting a VM will not be possible.
Please consult the User Manual for build instructions.

Wo liegt der Fehler?

Danke schon mal

lewendi
Zuletzt geändert von lewendi am 18. Nov 2007, 16:37, insgesamt 1-mal geändert.

Werbung:
Benutzeravatar
Becksta
Hacker
Hacker
Beiträge: 425
Registriert: 6. Jun 2006, 01:25
Wohnort: Westerwald
Kontaktdaten:

Beitrag von Becksta » 18. Nov 2007, 14:49

offenbar konnte das Kernel Modul bei der Installation nicht gebaut werden.
Sind bei dir die Kernel-Source und die grundlegenden Entwicklungswerkzeuge installiert??

Wenn ja, dann gib einfach mal den oben angezeigten Befehle als root auf der Konsole ein..

Greetz
Becksta
Mein System:
Intel Core 2 Duo E6400 2,13 Ghz
Asus P5b
MSI GeForce 7600 Gs
2048MB Arbeitsspeicher

Betriebssysteme:
OpenSuse 11.2 Linux 2.6.31
Gnome
Windows 7 Professional

Benutzeravatar
lewendi
Hacker
Hacker
Beiträge: 685
Registriert: 27. Dez 2003, 16:11
Wohnort: Rosenheim

Beitrag von lewendi » 18. Nov 2007, 15:05

Ich habe eine normale Suse installation gemacht. Welche Module sollten da noch installiert werden?

Eingabe als rooot -genau das gleiche!

lewendi

Benutzeravatar
Becksta
Hacker
Hacker
Beiträge: 425
Registriert: 6. Jun 2006, 01:25
Wohnort: Westerwald
Kontaktdaten:

Beitrag von Becksta » 18. Nov 2007, 15:14

Also das Paket "Kernel-Source" auf jeden Fall... und ich denke "gcc" ebenfalls... Aber das weiß ich nicht genau... Wenn du über "Yast" installiert, dann kannst du doch über "Schemata" oder so suchen.
Vielleicht kann das aber jemand anderes hier noch genauer sagen, welche Pakete genau benötigt werden...

Greetz und viel Erfolg

Becksta
Mein System:
Intel Core 2 Duo E6400 2,13 Ghz
Asus P5b
MSI GeForce 7600 Gs
2048MB Arbeitsspeicher

Betriebssysteme:
OpenSuse 11.2 Linux 2.6.31
Gnome
Windows 7 Professional

Benutzeravatar
lewendi
Hacker
Hacker
Beiträge: 685
Registriert: 27. Dez 2003, 16:11
Wohnort: Rosenheim

Beitrag von lewendi » 18. Nov 2007, 15:16

Aber ich habe doch ein *.RPM File installiert, da brauche ich doch die Pakete nicht -oder?

lewendi

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16599
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 18. Nov 2007, 15:19

lewendi hat geschrieben:Aber ich habe doch ein *.RPM File installiert, da brauche ich doch die Pakete nicht -oder?
Sieht aber schon so aus deshalb solltest du dir den gcc Compiler und die Kernelsources nachinstallieren.

stefan.becker
Advanced Hacker
Advanced Hacker
Beiträge: 1140
Registriert: 12. Mär 2006, 17:23

Beitrag von stefan.becker » 18. Nov 2007, 15:47

Klar braucht man die Pakete.

Steht aber auch alles im Handbuch an Systemvoraussetzungen. Einfach mal nachlesen, das Handbuch ist wirklich sehr gut.

Ansonsten mal "kernel-source", "gcc", "make", "automake" und "autoconf" als Minimum installieren.

Benutzeravatar
lewendi
Hacker
Hacker
Beiträge: 685
Registriert: 27. Dez 2003, 16:11
Wohnort: Rosenheim

Beitrag von lewendi » 18. Nov 2007, 15:57

OK habe die Pakete installiert, Von der Konsole als root geht es.
Aber wenn ich als User starte kommt diese Meldung:

walter@Walter-Desk:~> VirtualBox
WARNING: You are not a member of the "vboxusers" group. Please add yourself
to this group before starting VirtualBox.

You will not be able to start VMs until this problem is fixed.
Cannot create/open directory '/tmp/.vbox-walter-ipc/ipcd'
Abnormal termination.


Was ist das denn schon wieder?
Ich weis "Neudeutsch" ist eine Bildungslücke ...aber in meinem Alter!!

Danke

lewendi

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16599
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 18. Nov 2007, 15:59

lewendi hat geschrieben:WARNING: You are not a member of the "vboxusers" group. Please add yourself
Du musst deinen User in der Gruppe vboxusers unterbringen. :wink:
Lies dich bitte mal in den Link ein,dir fehlen einige Grundlagen.
http://www.linuxforen.de/forums/showthread.php?t=236444

stefan.becker
Advanced Hacker
Advanced Hacker
Beiträge: 1140
Registriert: 12. Mär 2006, 17:23

Beitrag von stefan.becker » 18. Nov 2007, 16:35

@Lewendi: Lies doch mal bitte das Handbuch.

Es ist so was von überflüssig, sich von Problem zu Problem zu hangeln.

Benutzeravatar
lewendi
Hacker
Hacker
Beiträge: 685
Registriert: 27. Dez 2003, 16:11
Wohnort: Rosenheim

Beitrag von lewendi » 18. Nov 2007, 16:36

Alles klar, habe bei "vboxusers" ein Häckchen gesetzt und es geht.

DANKE an Euch alle, bis zum nächsten mal.

lewendi

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16599
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 18. Nov 2007, 16:38

lewendi hat geschrieben:DANKE an Euch alle, bis zum nächsten mal.
Bitte editier den Thread noch als [gelöst] dann haben weitere Sucher auch was davon. :wink:
http://www.linux-club.de/ftopic81378.html

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 5 Gäste