Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

home gelöscht ??

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
thio
Hacker
Hacker
Beiträge: 386
Registriert: 13. Jan 2006, 12:14

home gelöscht ??

Beitrag von thio » 12. Nov 2007, 21:30

Hallo Zusammen,
ich verwende openSuse 10.3.
Habe erst vorkurzem eine Festplatte mit frisch installiertem Opensuse in meinen PC (als sda1) eingebaut. (Auf sdb1 läuft Windows XP).

Beim konfigurieren ist dann irgendwann einmal Thunderbird und Firefox abgestürzt und l]schluss endlich irgendwann das ganze System.

Beim reboot hab ich dann die gleiche Fehlermeldung bekommen wie hier:

[url]http:/www.linux-club.de/ftopic87911.html[/url]

Nach verschiedenen Versuchen Update/ Systemreparatur und Dateisystemreparatur mit e2fsk, bekomme ich nun beim Booten die Fehlermeldung "kstartuoconigg kann nicht geladen werden. Please check your installation."
Wenn ich root boote (geht meistens) und dann in Konqueror nach meiner home suche kann ich nicht finden. Und auch in der Konsole bekomme ich die Meldung /home/Benutzername ist kein Verzeichnis.

In irgendeinem LS Mode habe ich meine home einmal als "grün-geschrieben" entdeckt (Verzeichnisse waren in dieser Auflistung blau).

Auch über Total Commander in WIndows kann ich kein home finden.

Kann man die home noch/ wieder retten?
Hat jemand ähnlche Probleme mit openSuse 10.3?
Bruacht ihr weitere Informationen.

Weis jemand Rat- Vielen Dank!

Werbung:
admine
Administrator
Administrator
Beiträge: 8775
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Beitrag von admine » 12. Nov 2007, 21:34

Weißt du denn auf welcher Partition dein /home liegen sollte?
Was sagt "fdisk -l" und die Ausgabe von "mount"?
Evt. fehlt nur der entsprechende Eintrag in der /etc/fstab, um diese Partition zu mounten.
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

thio
Hacker
Hacker
Beiträge: 386
Registriert: 13. Jan 2006, 12:14

Beitrag von thio » 12. Nov 2007, 22:15

home müsste aud sda1 liegen.

fdisk -l
Disk /dev/sda: 82.3 GB, 82348277760 bytes
255 heads, 63 sectors/track, 10011 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0006663b

Device Boot Start End Blocks Id System
/dev/sda1 * 1 3838 30828703+ 83 Linux
/dev/sda2 3839 3902 514080 82 Linux swap / Solaris
/dev/sda3 6374 10011 29222235 f W95 Ext'd (LBA)
/dev/sda4 3903 6373 19848307+ b W95 FAT32
/dev/sda5 6374 10011 29222203+ b W95 FAT32

Partition table entries are not in disk order

Disk /dev/sdb: 60.0 GB, 60060155904 bytes
240 heads, 63 sectors/track, 7758 cylinders
Units = cylinders of 15120 * 512 = 7741440 bytes
Disk identifier: 0xeb8ceb8c

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 4063 30716248+ 7 HPFS/NTFS
/dev/sdb2 4064 7757 27926640 f W95 Ext'd (LBA)
/dev/sdb5 4064 5867 13631121 b W95 FAT32
mount:
/dev/sda1 on / type ext3 (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/sda4 on /windows/E type vfat (rw,noexec,nosuid,nodev,gid=100,umask=0002,utf8=true)
/dev/sda5 on /windows/D type vfat (rw,noexec,nosuid,nodev,gid=100,umask=0002,utf8=true)
/dev/sdb1 on /windows/C type fuseblk (rw,noexec,nosuid,nodev,noatime,allow_other,default_permissions,blksize=4096)
/dev/sdb5 on /windows/F type vfat (rw,noexec,nosuid,nodev,gid=100,umask=0002,utf8=true)
securityfs on /sys/kernel/security type securityfs (rw)

Rain_Maker

Beitrag von Rain_Maker » 12. Nov 2007, 22:24

thio hat geschrieben:home müsste aud sda1 liegen.
Nö, auf sda1 liegt "/".

Ich sehe ausser dieser auch keine weitere Linuxpartition (ausser swap).

War /home überhaupt auf einer eigenen Partition?

thio
Hacker
Hacker
Beiträge: 386
Registriert: 13. Jan 2006, 12:14

Beitrag von thio » 12. Nov 2007, 22:39

War /home überhaupt auf einer eigenen Partition?
Nein glaub ich nicht, sonder wer einfach unter / (ist das möglich?)

Aber wo ist es dann hin?

Die Daten scheinen noch vohanden zu sein (auf der Partition sind 18,9 GB belegt, dass kann doch nicht allein der "nackte" Root-Account sein ??)
Aber ich kann sie nirgends sehen...

admine
Administrator
Administrator
Beiträge: 8775
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Beitrag von admine » 12. Nov 2007, 22:42

Boote doch mal mit einer Live-CD und schau so, ob noch alles da ist.
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

thio
Hacker
Hacker
Beiträge: 386
Registriert: 13. Jan 2006, 12:14

Beitrag von thio » 13. Nov 2007, 21:09

Hmm, Knoppix hat wenn ich auf die Festplatte hda 1 klicke kein /home gefunden....
Auch total Commander findet nichts.
Aber die /home kann doch nicht einfach weg sein? (v. a. im HInblick auf die 16,9 GB belegter Festplattenspeicher..)

Gibt es noch irgendweinen TIpp für mich?
Hab mir auch schon eine Rescue is Possible Live CD runtergeladen, die bootet aber aus irgendeinem Grund nicht vollständig (bleibt bei Raid stehen).

Gibt es noch irgendwelche andere Ideen/ Tipps.

Rain_Maker

Beitrag von Rain_Maker » 13. Nov 2007, 22:16

Code: Alles auswählen

du -h / --max-depth=1
als root!

(Und das wird ein Weilchen dauern, also Geduld)

thio
Hacker
Hacker
Beiträge: 386
Registriert: 13. Jan 2006, 12:14

Beitrag von thio » 15. Nov 2007, 17:49

@rain_maker:

Sorry ein bisserl Schützenhilfe bräucht ich noch..

Wo muss ich:
du -h / --max-depth=1
eingeben?
Einfach in der Konsole des gestarteten Systems?
Beim Rescue System auf der Installations-CD?
Bei der Recovery is Posslble-CD (wenn ja wo genau?)

danke im voraus!

thio
Hacker
Hacker
Beiträge: 386
Registriert: 13. Jan 2006, 12:14

Beitrag von thio » 19. Nov 2007, 19:34

Ich mags immer noch nnciht gsanz glauben, dass die Daten weg sein sollen..

Jedocjh startet meine Recovery is Possible Live_CD nicht sondern bleibt bei:
Detecting ADAPTECH I2O Raid conroller..
stehen.

Auf meinem anderen PC bootet sie problemlos ?

Wei s wer Rat?

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast