Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

splashscreen während des kompletten bootens

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
mulle78
Newbie
Newbie
Beiträge: 41
Registriert: 15. Okt 2007, 23:18

splashscreen während des kompletten bootens

Beitrag von mulle78 » 25. Okt 2007, 23:23

wie bekomme ich den splashscreen, der in grub aktiv ist auch während des bootvorgangs aktiv? auf der suse dvd wird der bootvorgang doch auch über geblendent?!"

Werbung:
Benutzeravatar
Ganymed
Guru
Guru
Beiträge: 1609
Registriert: 15. Mai 2006, 12:58
Wohnort: JETZT ? DIREKT HINTER DIR !!
Kontaktdaten:

Beitrag von Ganymed » 26. Okt 2007, 00:00

YAST > System > Konfiguration des Bootloaders > entprechende Eintrag auswählen > Bearbeiten > optinale Bootparameter > Splash=no in Splash=silent ändern > alles beenden Grub wird neu installiert und beim nächsten Boot erscheint der einzig wirklich ekelige grüne SuSE-Bildschirm. Aber wenn Du es brauchst?!?

Gruß Ganymed
julia ist gut zu vögeln --- Groß- und Kleinschreibung retten die Ehre.
komm wir essen Opa --- Satzzeichen retten sogar das Leben
:)

mulle78
Newbie
Newbie
Beiträge: 41
Registriert: 15. Okt 2007, 23:18

Beitrag von mulle78 » 26. Okt 2007, 08:20

ich habe ja schon andere skins skins und auch die configfiles gefunden, in denen man das theme theoretisch ändert. Nur in grub, mit der option Splash=silent, wird das standard theme nur in grub angezeigt, Nicht jedoch beim laden des Systems. Der Bootvorgang wird auf klassische Art angezeigt, Erst wieder das Anmeldemenü ist "grafisch".

Benutzeravatar
blacklips
Hacker
Hacker
Beiträge: 448
Registriert: 28. Nov 2006, 19:33
Wohnort: gießen, frankfurt

Beitrag von blacklips » 26. Okt 2007, 08:23

Installier dir mal "kbootsplash" dort kannst du alles erforderliche einstellen.

mulle78
Newbie
Newbie
Beiträge: 41
Registriert: 15. Okt 2007, 23:18

Beitrag von mulle78 » 26. Okt 2007, 08:45

hab ich versucht, die erfordert aber eine 32bit umgebung und ich habe 64bit installiert. ferner habe ich mit einer manuellen anleitung vermutlich irgendwas zerschossen. grub sagt mir jetzt immer, invalid file format und dann öffnet es sein menü in text format. die alte menu.lst habe ich mal zurück kopiert um zu sehen, ob es die menu.lst ist, ich vermute aber nein.

mkinitrd -s 1280x1024

ich habe vermutlich mit diesem kommando was zerhauen?


und hier der Origianaltext.

Code: Alles auswählen

To install:

1 extract to /etc/bootsplash/themes/
example: /etc/bootsplash/themes/susegreensplash

2 use Yast bootsplash theme changer-by mouseclicks: Yast>system>/etc/sysconfig Editor>system>boot>theme>type name of theme (susegreensplash)>finish

3 as superuser (root) type in terminal: mkinitrd -s 1024x768

obec
Advanced Hacker
Advanced Hacker
Beiträge: 1193
Registriert: 27. Dez 2005, 21:34
Wohnort: /home/obec

Beitrag von obec » 26. Okt 2007, 13:12

Hi,

schau mal ins Wki. Da gibts nen Artikel dazu.

Gruß

obec
openSuSE 11.0
Mandriva Linux 2008 Spring
Gigabyte P35-DS3
Intel Pentium D Prozessor 3,40GHZ
4096 MB Arbeitsspeicher
Nvidia Geforce 7600GS 512MB

mulle78
Newbie
Newbie
Beiträge: 41
Registriert: 15. Okt 2007, 23:18

Beitrag von mulle78 » 27. Okt 2007, 18:19

könntet ihr mal schauen, ob meine menu.lst villeicht defekt ist und die Fehlermeldung daher kommt.... das wiki hats leider auch nicht gerichtet :O(
ich habe jetzt 1024 oder 1280er auflösung... aber nur text und der bootloader sagt immer

GRUB loading please wait...
(hd0,4)/boot/message:invalid file format

Code: Alles auswählen

# Modified by YaST2. Last modification on Tue Oct 23 23:41:23 CEST 2007
default 4
timeout 8
gfxmenu (hd0,4)/boot/message

###Don't change this comment - YaST2 identifier: Original name: linux-2.6.22.5-31-default###
title openSUSE 10.3 - 2.6.22.5-31
    root (hd0,4)
    kernel /boot/vmlinuz-2.6.22.5-31-default root=/dev/disk/by-id/scsi-SATA_SAMSUNG_HD501LJS0MUJ1KP119904-part5 splash=silent vga=795 showopts
    initrd /boot/initrd-2.6.22.5-31-default

###Don't change this comment - YaST2 identifier: Original name: failsafe-2.6.22.5-31-default###
title Failsafe -- openSUSE 10.3 - 2.6.22.5-31
    root (hd0,4)
    kernel /boot/vmlinuz-2.6.22.5-31-default root=/dev/disk/by-id/scsi-SATA_SAMSUNG_HD501LJS0MUJ1KP119904-part5 showopts ide=nodma apm=off acpi=off noresume edd=off 3
    initrd /boot/initrd-2.6.22.5-31-default

###Don't change this comment - YaST2 identifier: Original name: linux-2.6.22.9-ccj56-default###
title openSUSE 10.3 - 2.6.22.9-ccj56
    root (hd0,4)
    kernel /boot/vmlinuz-2.6.22.9-ccj56-default root=/dev/disk/by-id/scsi-SATA_SAMSUNG_HD501LJS0MUJ1KP119904-part5 splash=silent showopts
    initrd /boot/initrd-2.6.22.9-ccj56-default

###Don't change this comment - YaST2 identifier: Original name: failsafe-2.6.22.9-ccj56-default###
title Failsafe -- openSUSE 10.3 - 2.6.22.9-ccj56
    root (hd0,4)
    kernel /boot/vmlinuz-2.6.22.9-ccj56-default root=/dev/disk/by-id/scsi-SATA_SAMSUNG_HD501LJS0MUJ1KP119904-part5 showopts ide=nodma apm=off acpi=off noresume edd=off 3
    initrd /boot/initrd-2.6.22.9-ccj56-default

###Don't change this comment - YaST2 identifier: Original name: windows 1###
title Windows Vista
    rootnoverify (hd0,4)
    chainloader (hd0,0)+1
ich hatte noch etwas gemacht, was mir noch verdächtiger vorkommt: denn /boot/message hat ja ein invalides file format:
http://www.pro-linux.de/news/2006/10652.html
Über Geschmack lässt sich streiten, manche mögen ihn, manche nicht, den Pingus-Bootsplash, der manchmal bei Suse auftaucht. Um ihn immer zu haben oder endlich loszuwerden, hilft folgender Tipp:

Die Einstellung findet sich in der Datei /boot/message, von der wir zuerst eine Kopie machen. Dann packen wir sie mit

cpio -i < /boot/message

in ein leeres Verzeichnis aus. Mit

echo "penguin=0" > gfxboot.cfg

können wir die Pinguine auf den Südpol schicken oder sie stattdessen mit "100" in unseren Breiten festnageln. Der Wert gibt die Wahrscheinlichkeit des Auftauchens an.

Anschießend mit

find . | cpio -o > /boot/message

das Archiv neu bauen, und die Änderung wird ab dem nächsten Booten wirksam.
wie bekomme ich denn die originale /boot/message wieder her?! bzw wie packe ich sie wieder richtig. sie ist scheinbar ein 7 MB großes textfile

habs hin bekommen:
mit diesen infos: http://www.linuxhilfe.org/partitionen-u ... ndern.html

habe meine vermutlich falsch gepackte message file nach temp kopiert und sie nochmals entpackt. er hat dann nicht mehr ein archiv, sondern viele kleine dateien erstellt. diese dann wieder gepackt (3 MB statt 7 MB)und das archiv message habe ich nach /boot/message kopiert. jetzt geht GRUB mit seinem default bildchen wieder und ich weiss nun auch wie ich das Bild von GRUB ändern kann ,O)
$ cpio -idv < message
$ ls | cpio -ov > ../message
so, werde jetzt noch mal alles in http://wiki.linux-club.de/Splash_Screen durchgehen

mulle78
Newbie
Newbie
Beiträge: 41
Registriert: 15. Okt 2007, 23:18

Beitrag von mulle78 » 27. Okt 2007, 19:19

so klappt nicht, hab jetzt einen konsolenbasierten bootvorgang bei 1200er auflösung, mein GRUB kann die datei /boot/message wieder lesen, aber ein splash screen habe ich nicht. die anleitung bei wiki ist auch ein bischen unverständlich, denn dort wird beschrieben, dass die cfg datei hier liegt:
/etc/bootsplash/themes/bootsplash-1024x768.cfg

aber die bilder dort:
jpeg=/etc/bootsplash/themes/fingerprint-bs/images/bootsplash-1024x768.jpg
silentjpeg=/etc/bootsplash/themes/fingerprint-bs/images/silent-1024x768.jpg

lädt man aber ein archiv von KDE-LOOK, müsste die cfg hier liegen:
/etc/bootsplash/themes/fingerprint-bs/config/bootsplash-1024x768.cfg

was übrigens schon tatsache ist, wenn man den ordner fingerprint-bs nach /etc/bootsplash/themes kopiert
cp -R fingerprint-bs /etc/bootsplash/themes

Wo muss die CFG-File denn nun liegen? und welche Datei genau verweisst darauf? In /etc/sysconfig/bootsplash wird ledigleich auf den Namen des Themes gezeigt, nicht jedoch auf eine Config-File.

auch /sbin/mkinitrd macht was... ich hatte übrigens von anfang an, nach der default installation schon kein splash screen, auch wenn SuSE eingestellt war und es laut /etc/sysconfig/bootsplash aktiv war.

Code: Alles auswählen

19:31 openSUSE:~ # /sbin/mkinitrd

Kernel image:   /boot/vmlinuz-2.6.22.5-31-default
Initrd image:   /boot/initrd-2.6.22.5-31-default
Root device:    /dev/disk/by-id/scsi-SATA_SAMSUNG_HD501LJS0MUJ1KP119904-part5 (/dev/sdb5) (mounted on / as ext3)
Kernel Modules: processor thermal scsi_mod libata pata_amd sata_nv sata_sil24 fan jbd mbcache ext3 edd sd_mod usbcore ohci-hcd uhci-hcd ehci-hcd ff-memless hid usbhid
Features:       block usb resume.userspace resume.kernel
Bootsplash:     disabled for resolution 1280x1024

20375 blocks

Kernel image:   /boot/vmlinuz-2.6.22.9-ccj56-xen
Initrd image:   /boot/initrd-2.6.22.9-ccj56-xen
...
...
...

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast