Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

"error loading operating system"

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Lefti
Newbie
Newbie
Beiträge: 9
Registriert: 4. Jun 2006, 10:31
Kontaktdaten:

"error loading operating system"

Beitrag von Lefti » 11. Okt 2007, 19:49

Moin moin !!!

Mit genau dieser Fehlermeldung begrüßt mich mein Laptop, wenn ich ihn nach erfolgreicher (????; Linux hält ja die Klappe, wenn keine Fehler auftreten) Installation von openSUSE 10.3 hochfahren möchte. Kein Plan, was da schief gelaufen ist. Was ich aber eigenartig finde:

Wenn ich versuche, 10.3 zu aktualisieren, geht das in die Hose. Im nachfolgenden Screen kann ich dann zw. Neustart/Ausschalten, Installation & und Booten auswählen. Wähle ich "Booten", komme ich zur Auswahl der Partition (hier /sda2) und SuSE 10.3 fährt hoch.

Hat irgendwer 'n Plan, wieso ich diesen Umweg gehen muß ???

Danke ...........................................

Werbung:
admine
Administrator
Administrator
Beiträge: 8781
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Beitrag von admine » 11. Okt 2007, 19:52

Poste bitte die Ausgabe von:

Code: Alles auswählen

fdisk -l (kleines L),
cat /etc/fstab
cat /boot/grub/menu.lst
cat /boot/grub/device.map
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

towo
Moderator
Moderator
Beiträge: 3710
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo » 11. Okt 2007, 20:00

admine hat geschrieben:Poste bitte die Ausgabe von:

Code: Alles auswählen

fdisk -l (kleines L),
cat /etc/fstab
cat /boot/grub/menu.lst
cat /boot/grub/device.map
Hey admine, da fehlt vermutlich nur ein Bootflag, da diese Meldung vom BIOS kommt. :D
Signatur nach Diktat spazieren gegangen

Bild

Lefti
Newbie
Newbie
Beiträge: 9
Registriert: 4. Jun 2006, 10:31
Kontaktdaten:

Beitrag von Lefti » 12. Okt 2007, 06:57

admine hat geschrieben:Poste bitte die Ausgabe von:

Code: Alles auswählen

fdisk -l (kleines L),
cat /etc/fstab
cat /boot/grub/menu.lst
cat /boot/grub/device.map
ich hoffe, das hilft was ....

fdisk -l

Platte /dev/sda: 6448 MByte, 6448619520 Byte
15 heads, 63 sectors/track, 13328 cylinders
Units = Zylinder of 945 * 512 = 483840 bytes
Disk identifier: 0x000eff36

Gerät boot. Anfang Ende Blöcke Id System
/dev/sda1 1 945 446481 82 Linux Swap / Solaris
/dev/sda2 * 946 13328 5850967+ 83 Linux


cat /etc/fstab

/dev/disk/by-id/scsi-SATA_HITACHI_DK239A-_918182-part2 / ext3 acl,user_xattr 1 1
/dev/disk/by-id/scsi-SATA_HITACHI_DK239A-_918182-part1 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0


cat /boot/grub/menu.lst

# Modified by YaST2. Last modification on Do Okt 11 18:57:15 CEST 2007
default 0
timeout 8
gfxmenu (hd0,1)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 10.3
root (hd0,1)
kernel /boot/vmlinuz-2.6.22.5-31-default root=/dev/disk/by-id/scsi-SATA_HITACHI_DK239A-_918182-part2 vga=0x317 resume=/dev/sda1 splash=silent showopts
initrd /boot/initrd-2.6.22.5-31-default

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 10.3
root (hd0,1)
kernel /boot/vmlinuz-2.6.22.5-31-default root=/dev/disk/by-id/scsi-SATA_HITACHI_DK239A-_918182-part2 vga=normal showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3
initrd /boot/initrd-2.6.22.5-31-default


cat /boot/grub/device.map

(hd0) /dev/sda
Zuletzt geändert von Lefti am 12. Okt 2007, 07:05, insgesamt 1-mal geändert.

Lefti
Newbie
Newbie
Beiträge: 9
Registriert: 4. Jun 2006, 10:31
Kontaktdaten:

Beitrag von Lefti » 12. Okt 2007, 07:01

towo hat geschrieben: Hey admine, da fehlt vermutlich nur ein Bootflag, da diese Meldung vom BIOS kommt. :D
lt. fdisk -l ist ein bootflag auf /dev/sda2 gesetzt, was ja eigentlich korrekt sein sollte. Wie ich allerdings so ein Flag ins BIOS reinkriege, bleibt mir bei meinem Thinkpad 600E rätselhaft

towo
Moderator
Moderator
Beiträge: 3710
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo » 12. Okt 2007, 07:43

lt. fdisk -l ist ein bootflag auf /dev/sda2 gesetzt,
Und? Den Grub hast Du aber mit Sicherheit in den MBR geschrieben, oder?
Also setze mit cfdisk das Bootflag auf /dev/sda1, oder nehm es ganz weg, das mußt Du testen.
Signatur nach Diktat spazieren gegangen

Bild

Antworten