Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

DPMS bei LTSP4.2 abstellen

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Rolf-Werner
Hacker
Hacker
Beiträge: 346
Registriert: 23. Jan 2004, 09:34

DPMS bei LTSP4.2 abstellen

Beitrag von Rolf-Werner » 8. Okt 2007, 17:58

Das Thema hatte ich selbst hier schon vor langer Zeit mal drin, und es wurde auch gelöst auf dem alten Server von mir, aber das war noch LTSP 3 und jetzt komme ich wieder mal nicht weiter:

Wie stelle ich die Monitorabschaltung (DPMS) ab? Falls es eine Rolle spielt: Ich nehme den KDM.

Im alten Thread steht was von einer rc.setupx, aber die finde ich nirgends, weder auf dem alten noch auf dem neuen Server. Vielleicht ist es aber auch nicht mehr aktuell. Leider hab ich auch keine genaueren Notizen mehr.

In der lts.conf hab ich übrigens X_DPMS = N eingetragen, das scheint mir aber nur zu greifen, wenn man schon eingeloggt ist.

Vielen Dank für alle Tipps!

Rolf
Wissen ist Macht.
Wir wissen nichts.
Macht nichts.

Werbung:
schweer
Hacker
Hacker
Beiträge: 268
Registriert: 2. Jan 2004, 23:40
Wohnort: Bochum

Re: DPMS bei LTSP4.2 abstellen

Beitrag von schweer » 26. Okt 2007, 12:36

Rolf-Werner hat geschrieben:Im alten Thread steht was von einer rc.setupx, aber die finde ich nirgends, weder auf dem alten noch auf dem neuen Server. Vielleicht ist es aber auch nicht mehr aktuell. Leider hab ich auch keine genaueren Notizen mehr.
Theoretisch (ich benutzte Debian und LPSP 5):
Im Skript /opt/ltsp/i386/[etc/?]screen.d/startx die Parameter der Variablen XF_ARGS durch -dpms ergänzen (z.B. nach -fp suchen und davorsetzen).

wolfgang

schweer
Hacker
Hacker
Beiträge: 268
Registriert: 2. Jan 2004, 23:40
Wohnort: Bochum

Re: DPMS bei LTSP4.2 abstellen

Beitrag von schweer » 26. Okt 2007, 12:40

Oder probieren, in lts.conf XF_ARGS="-dpms" zu setzen.

wolfgang

Rolf-Werner
Hacker
Hacker
Beiträge: 346
Registriert: 23. Jan 2004, 09:34

Beitrag von Rolf-Werner » 26. Okt 2007, 14:22

Also, das klappt beides nicht bei mir.

Wenn ich in der startx bei mir aus dem XF_ARGS = "" ein XF_ARGS = "-dpms" mache, kommt kdm gar nicht erst hoch, also X schon, aber dann ist Schluss.

Das XF_ARGS = "-dpms" in der lts.conf wird ignoriert, aber es kann sein, dass das bei 4.2 auch nicht geht. Jedenfalls steht es nicht in der readme.

Vielleicht sollte man über die erste Option nochmal nachdenken, aber ich weiß jetzt auch nicht, wie man es "besser" machen könnte. Zumindest ist da eine Reaktion, das scheint also ein Weg zu sein.

Noch irgendeine Idee?

Rolf
Wissen ist Macht.
Wir wissen nichts.
Macht nichts.

rolle
Guru
Guru
Beiträge: 3724
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle » 26. Okt 2007, 21:46

Ich habe hier in einer alten conf 'X_DPMS = N' stehen. Keine Ahnung, ob das klappt. Versuchs halt einfach mal.
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste