LTSP auf PCMCIA-Notebook booten?

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
moenk
Administrator
Administrator
Beiträge: 1382
Registriert: 15. Aug 2003, 15:36
Wohnort: N52° 27.966' E013° 20.087'
Kontaktdaten:

LTSP auf PCMCIA-Notebook booten?

Beitrag von moenk » 23. Sep 2003, 12:20

Hat irgendwer eine Idee wie ich auf einem alten Notebook eine Terminal booten kann? Ich habe wohl Paket-DOS und Novell-Treiber, also einen Pakettreiber und einen LSL/IPXODI, aber ich finde kein Bootrom für PCMCIA-Karten, dass ich auf eine Diskette spielen könnte. Ich besorge mir gern die passende Karte falls jemand das schon mal gemacht hat. Mir ist auch nicht klar, ob ich für PCMCIA erst etwas laden müsste und das deswgen gar nicht funktionieren kann. Es müsste ja dann aber ein Mini-Linux auf die kleine Platte des Notebooks gehen, der dann den Rest des LTSP nachlädt, aber wie?

Werbung:
Benutzeravatar
Marc
Newbie
Newbie
Beiträge: 28
Registriert: 2. Sep 2003, 12:07
Wohnort: Kleve

Beitrag von Marc » 23. Sep 2003, 19:05

Hi moenk,

das habe ich gerade in der ltsp_wireless Anleitung gefunden.
Vielleicht hilft es dir weiter.
The work that went into making the wireless_ltsp package has a nice
side effect. That is, it works with any pcmcia network card that
is supported by Linux. Both wired and wireless cards should work
just fine.
Gruß
Marc

nils

Beitrag von nils » 27. Nov 2003, 22:18

das laeuft bei mir auf einem ibm thinkpad ohne floppy oder sonstigem bootdevice ausser der festplatte 8)

ich boote ins bereits vorhandene win95 auf der festplatte, lade ueber loadlin den ltsp_wireless kernel (hat die pcmcia unterstuetzung) und hole ueber eine 3com karte den rest.

mit einer pcmcia-wlan-karte hat es auch funktioniert.

bei interesse kann ich die relevanten configs hier posten. :shock:

Benutzeravatar
Marc
Newbie
Newbie
Beiträge: 28
Registriert: 2. Sep 2003, 12:07
Wohnort: Kleve

wlan + ltsp + notebook

Beitrag von Marc » 28. Nov 2003, 18:43

Hi Nils,

bitte poste alle Infos, die du posten kannst.
Auch die Hardwareinfos sind wichtig, also welche PCMCIA.
Hast du die Möglichkeit ein Floppy anzuschließen, um mal via Etherboot und PCMCIA zu booten?

Was sagst die Performance bei WEB- oder sogar OO-Zugriff???

Welche Ausstattungf hat dein Thinkpad? :?:

Gruß

Marc

nils
Newbie
Newbie
Beiträge: 2
Registriert: 27. Nov 2003, 22:20

Beitrag von nils » 1. Dez 2003, 22:37

Hi Marc,

es ist ein IBM Thinkpad EL760 mit einer 3Com Etherlink III LAN PC Card PCMCIA 3C589D. Der Laptop hat kein Floppy-Laufwerk, CD-Laufwerk ist nicht bootable, also musste ich von Festplatte booten.

Also dann: LOADLIN mit dem wireless-Paket (http://prdownloads.sourceforge.net/ltsp ... z?download).

mit Loadlin booten:
config.sys :
---
[menu]
menuitem=ltsp, ltsp
menuitem=Win95, Windows 95
menucolor=15,1
menudefault=ltsp, 3

[ltsp]

[win95]
device=C:\WINDOWS\COMMAND\display.sys con=(ega,,1)
DOS=HIGH,UMB
Country=041,850,C:\WINDOWS\COMMAND\country.sys
---

autoexec.bat :
---
goto %config%

:ltsp
cd \loadlin
call linux.bat
pause

:win95
@ECHO OFF
blablabla
---

die loadlin.bat sieht so aus:
---
c:\loadlin\loadlin c:/loadlin/ltsp/vmlinuz initrd=C:\loadlin\ltsp\initrd.img init=/linuxrc rw root=/dev/ram0 BOOTDEV=hda1
---

c:\loadlin\ltsp sieht so aus:
---
ibm:/windows/loadlin/ltsp # ll
total 2880
drwxr-xr-x 2 root root 32768 Oct 30 13:22 .
drwxr-xr-x 4 root root 32768 Oct 3 14:00 ..
-rwxr-xr-x 1 root root 203 Oct 3 14:04 boot.msg
-rwxr-xr-x 1 root root 29334 Oct 3 14:04 fdisk.exe
-rwxr-xr-x 1 root root 22916 Oct 3 14:04 format.com
-rwxr-xr-x 1 root root 676747 Oct 30 22:27 initrd.img
-rwxr-xr-x 1 root root 676899 Oct 30 14:23 initrd.ng
-rwxr-xr-x 1 root root 676152 Oct 3 14:04 initrd.org
-rwxr-xr-x 1 root root 6192 Oct 3 14:04 ldlinux.sys
-rwxr-xr-x 1 root root 102 Oct 3 14:04 syslinux.cfg
-rwxr-xr-x 1 root root 8484 Oct 3 14:04 syslinux.com
-rwxr-xr-x 1 root root 586760 Oct 3 14:04 vmlinuz
-rwxr-xr-x 1 root root 234 Oct 30 15:38 wireless.cfg
---

Windows startet Loadlin, Loadlin laedt den Kernel und startet . Das ist alles.

Wer sich ueber die modification times wundert, ich habe eine Netgear WLAN-Karte (PCMCIA) damit auch fast zum Fliegen gebracht. Aber das ist eine (laengere) Geschichte. Und in Quintessenz hat es nicht geklappt. Die Netgear und der Access Point (DLink) haben sich nicht verstanden (2-5 Minuten alles OK, dann viel Traffic und tschuess, auch unter Windows).

Die Performance ist seeeehr zufriedenstellend. Was ueber eine 10 MBit-Karte halt geht. Das die eigentliche Musik dann ja eh auf dem Server spielt , ist nach dem "Login" sowieso die Leistungsfaehigkeit des Servers entscheidend. Und die ist ausreichend. :-)

Und Tschuess , Nils

locke_2
Newbie
Newbie
Beiträge: 2
Registriert: 4. Mai 2004, 10:12

WIRELESS Versuch

Beitrag von locke_2 » 20. Okt 2004, 11:13

Hi Nils,
kannst Du mal posten, welche Netgear Karte du benutzt hast, und wie dein Wireless Projekt dann letzt endlich in der Struktur aufgebaut ist oder war?

nils
Newbie
Newbie
Beiträge: 2
Registriert: 27. Nov 2003, 22:20

netear ma401

Beitrag von nils » 20. Okt 2004, 23:41

es war eine netgear ma401 im infrastructure mode. die gleiche karte laeuft gerade hier unter suse linux 9.0 klaglos. ich haette wohl die neueren sourcen der wirelesstools kompilieren muessen, dann haette es wohl geklappt.

gamefreaktegel
Newbie
Newbie
Beiträge: 45
Registriert: 25. Jun 2004, 23:54
Wohnort: Berlin
Kontaktdaten:

Beitrag von gamefreaktegel » 23. Okt 2004, 14:35

Hi Leutz,

da dieser Thread ja in Zeiten von LTSP 3x erstellt wurde, wollte ich mal fragen wie es in Zeiten von LTSP 4.1.x aussieht.

Also ich habe auf meinem Server (SuSE 9.1 Prof.) ein funktionierenden LTSP-Terminal-Server (4.1) am Laufen.
Nun habe ich aber ebenfalls noch einen alten Toshiba Laptop (486er) mit einer PCMCIA-Ethernet-Karte.
Fotos dazu:
Bild
Bild

Ist es möglich über diese PCMCIA-Karte zu booten? PXE oder dergleichen wird nämlich nicht unterstützt...

Treiber für Linux bietet Edimax an: http://www.edimax.com.tw/download/drive ... 101V12.zip
Aber ich wüsste nicht, wie ich daraus eine bootfähige Diskette oder so erstellen soll...

plz help!

locke_2
Newbie
Newbie
Beiträge: 2
Registriert: 4. Mai 2004, 10:12

Selbes Problem

Beitrag von locke_2 » 25. Okt 2004, 18:24

Nochmals zu meinen Problem, Ich möchte mittels aktueller WLAN Hardware mich mit dem Notebook via PCMCIA zu einem LTSP - Server (Suse 9.1 ) verbinden. Leider befürchte ich, das diese Hardware (gibt es Empfehlungen ) nicht von dem Wireless - Paket (www.ltsp.org) unterstützt wird, da dieses paket wohl älteren datums ist. Wenn ich als Newbie die Sache richtig verstanden habe, sollte es doch aber möglich sein sich ein eigenes Kernel-image herzustellen, und dann von der initrd das treibermodul für die hardware zu laden. ich denke mal etwas anderes ist bei dem wirelesspaket auch nicht getan worden, oder liege ich hier komplett falsch. Ansonsten funktioniert die sache, wie sie nils angegeben hat gut. hat jemand erfahrungen mit einem selbstgebauten wirelesskernel ? wo bekommt man tipps, oder sollte ich besser via Xserv oder vns die verbindung zum desktop aufbauen. ich habe ein PII 233 Notebook mit 5 GB Harddisk und WIN98SE am laufen.

gamefreaktegel
Newbie
Newbie
Beiträge: 45
Registriert: 25. Jun 2004, 23:54
Wohnort: Berlin
Kontaktdaten:

Beitrag von gamefreaktegel » 26. Okt 2004, 11:20

ich würde mal bei LTSP.org nachfragen, wann sie ein neues wireless-paket releasen... das gehört ja eigentlich zur 3er Version von ltsp...

Benutzeravatar
Marc
Newbie
Newbie
Beiträge: 28
Registriert: 2. Sep 2003, 12:07
Wohnort: Kleve

PCMCIA an LTSPv.4.1 Etherboot?

Beitrag von Marc » 3. Dez 2004, 10:16

[EDIT] Sorry, hatt nicht gesehen, dass das unmittelbar vorher von jemandem gepostet wurde:
http://www.linux-club.de/viewtopic.php?t=20874
[/EDIT]

Hallo Listige!

Ich habe das gleiche Anliegen wie gamefreaktegel weiter oben.
Die PCMCIA D-Link-Karte DFE650TX soll auf unseren LTS4.1 zugreifen können. Das Ganze soll über Diskette oder auch anders gestartet werden.

Nur wie mache ich das?
Für Hilfe dankbar!

Gruß
Marc

gamefreaktegel
Newbie
Newbie
Beiträge: 45
Registriert: 25. Jun 2004, 23:54
Wohnort: Berlin
Kontaktdaten:

Beitrag von gamefreaktegel » 4. Dez 2004, 11:09

hi!

also ich habe das hinbekommen.... ich hatte mir (soweit ich mich erinnern kann) einfach mittels wireless_paket eine Bootdiskette erstellt und dann gings schon los... ohne Probleme
musste nur die config anpassen... ich hab da so ziemlich "geraten", hat aber funktioniert :D

hab das ganze aber dann fallen lassen, da man mit ner Auflösung von 640x480 doch nicht so viel anfangen kann :D (beim Surfen z.B.)

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast