Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Sound Probleme am Terminal

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
greenscreen
Newbie
Newbie
Beiträge: 8
Registriert: 23. Aug 2007, 09:27

Sound Probleme am Terminal

Beitrag von greenscreen » 5. Sep 2007, 08:04

Hallo an alle,

irgendwie habe ich ein Sound Problem am Terminalserver.

Wenn ich Musik oder Spiele auf dem Terminal Abspiele ertönt die Musik nicht am Terminal sondern am Server.

Irgendwie schaffe ich es nicht die Musik an die Terminals zu bekommen.

Ach so noch zur Info ich verwende den LTSP 4.2 auf XUbunut 7.10

Die Terminals sind Compaq Evo Rechner.

Die lts.conf:

Code: Alles auswählen

[Default]
	SERVER			    = 192.168.100.1
	XSERVER		           = auto
#Grafikeinstellungen:
	X_COLOR_DEPTH	      = 24
	X_HORZSYNC	   	= "50-60"
	X_VERTREFRESH	       = "55-75"
#Mauseinstellungen:
	X_MOUSE_PROTOCOL   = "IMPS/2"
	X_MOUSE_DEVICE        = "/dev/psaux"
	X_MOUSE_RESOLUTION 	= 400
	X_MOUSE_BUTTONS    	= 9
	X_ZAxisMapping	          = "4 5"
#Keyboardeinstellungen:
	XkbSymbols	   	= de(pc105)
	XkbModel	   	  = pc105
	XkbLayout 	   	  = de
	XkbVariant	   	  = nodeadkeys
#Zentrale Zeichenverwaltung per XSERVER, ab 40 Clients problematisch
	USE_XFS            	  = N
#Anwendungen werden lokal und nicht auf Terminalserver ausgeführt, dient Entlastung des Terminal, bei potenten Clients möglich
	X4_MODULE_01	   	= "glx"
	LOCAL_APPS	   	  = N
	SOUND		   	     = Y
	SOUND_DAEMON	      = esd
	VOLUME			     = 99
	MODULE_05		  = snd-intel8x0
       	SCREEN_01    		  = shell
       	SCREEN_02    		  = startx
#Lokale Speichermedien
        MODULE_01		= uhci_hcd 	    
 	MODULE_02		= usblp
 	MODULE_03		= usb-storage
 	MODULE_04       	= usbcore	
 	LOCAL_DEVICE_01		= /dev/hdc:cdrom_lokal
 	LOCAL_DEVICE_02 	= /dev/fd0:floppy_local
 	LOCAL_DEVICE_03 	= /dev/bus/usb/001:usb1_lokal	
 	LOCAL_DEVICE_04 	= /dev/bus/usb/002:usb2_lokal
 	LOCAL_DEVICE_05 	= /dev/bus/usb/003:usb3_lokal
 	LOCAL_DEVICE_06 	= /dev/bus/usb/004:usb4_lokal
 	LOCAL_DEVICE_07 	= /dev/bus/usb/005:usb5_lokal 
 	LOCAL_STORAGE		= Y
	
Beim Booten des Terminals erscheinen folgende Nachrichten:

Code: Alles auswählen

Loading: snd-intel8x0
ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 5
APIC: PCI Interrupt 0000:00:1f.5[B] ->  Link [LNKB] -> GSI 5 (level, low) -> IRQ 5
intel8x0_measure_ac97_clock: measured 53950 usecs
intel8x0: clocking to 48000
Setting uo loopback devices
Seting up /var
Starting syslogd
syslogd: cannot write to remote file handle on 192.168.100.1:514
Running Sound Server
- accepting connection on port 16001
/dev/dsp: No such file or directory
/dev/dsp: No such file or directory
- accepting connection on port 16001
/dev/dsp: No such file or directory
/dev/dsp: No such file or directory
- accepting connection on port 16001
/dev/dsp: No such file or directory
/dev/dsp: No such file or directory
- accepting connection on port 16001
/dev/dsp: No such file or directory
/dev/dsp: No such file or directory
- accepting connection on port 16001
/dev/dsp: No such file or directory
/dev/dsp: No such file or directory
aumix: error opening mixer
Starting lbuscd...

Werbung:
rolle
Guru
Guru
Beiträge: 3724
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle » 5. Sep 2007, 09:18

Ich hatte mal nen Client mit Intelsoundchip. Ich mußte vor snd-intel8x0 noch ein weiteres Modul laden. Das sah dann so aus:

Code: Alles auswählen

MODULE_03 = i810_audio
MODULE_04 = snd-intel8x0
Eventuell könnte ein Blick ins Mailinglistenarchiv und ins Wiki von LTSP weiterhelfen.
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.

greenscreen
Newbie
Newbie
Beiträge: 8
Registriert: 23. Aug 2007, 09:27

Beitrag von greenscreen » 5. Sep 2007, 09:57

Danke für deine Antwort, hat zwar ein par Fehlermeldungen korrigiert jedoch Spielt er die Musik immer am Server ab. Beim Booten erscheint jetzt folgende Meldung.

Code: Alles auswählen

Loading: i810_audio
Intel 810 + AC97 Audio, version 1.01, 22:18:28 Apr 16 2006
ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 5
APIC: PCI Interrupt 0000:00:1f.5[B] ->  Link [LNKB] -> GSI 5 (level, low) -> IRQ 5
i810: Intel ICH4 found at IO =x2400 and 0x2000, MEM 0xfc480400 and 0xfc480600, IRQ 5
i810: Intel ICH4 mmio at 0xd00be400 and 0xd38e0600
i810_audio: Primary codec has ID 0
i810_audio: Audio Controler supports 6 channels
i810_audio: Defaulting to base 2 channel mode.
i810_audio: Resetting connection 0
ac97_codec: AC97 Audio codec, id: ADS114 (Analog Devices AD1981A)
i810_audio: AC'97 codec 0 sipports AMAP, total channels = 2
Loading: snd-intel8x0
Setting uo loopback devices
Seting up /var
Starting syslogd
syslogd: cannot write to remote file handle on 192.168.100.1:514
Running Sound Server
- accepting connection on port 16001
Starting lbuscd... 

rolle
Guru
Guru
Beiträge: 3724
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle » 5. Sep 2007, 10:19

Hm, womit spielst Du die Musik ab und nutzt dieses Programm auch esd als Sounddevice?
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.

greenscreen
Newbie
Newbie
Beiträge: 8
Registriert: 23. Aug 2007, 09:27

Beitrag von greenscreen » 5. Sep 2007, 10:45

mit dem real player (sound am server) mit dem vlc player (sound am server) ein java spiel (garkein sound mehr)

rolle
Guru
Guru
Beiträge: 3724
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle » 5. Sep 2007, 11:51

Hast Du den vlc mal unter Einstellungen-Audio-Ausgabemodule (erweiterte Optionen anhaken) auf esd umgestellt? Beim Real Player gibt es diese Option bestimmt auch irgendwo.
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.

greenscreen
Newbie
Newbie
Beiträge: 8
Registriert: 23. Aug 2007, 09:27

Beitrag von greenscreen » 5. Sep 2007, 12:04

wenn es dort esd geben würde hätte ich das schon gemacht. zur Auswahl steht mir dort nur:

Standard was auch immer das sein mag
Dummy Audioausgabefunktion
Datei-Audioausgabe
Linux OSS Audioausgabe
ALSA Audioausgabe

rolle
Guru
Guru
Beiträge: 3724
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle » 5. Sep 2007, 12:37

Hm, suche dir mal ein einfaches .wav auf der Platte und versuche das per 'esdplay DATEI' auf dem client abzuspielen. Und nur zur Sicherheit: Der esound-Dämon auf dem Server läuft?
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.

greenscreen
Newbie
Newbie
Beiträge: 8
Registriert: 23. Aug 2007, 09:27

Beitrag von greenscreen » 5. Sep 2007, 13:50

hi,

also habe mit esdplay mal eine wave abgespielt und es blieb ruhig, habe ich esdplay --server=termserv etwas abgespielt kamm die Musik aus dem Server. habe ich als Server das terminal angegeben blieb es Ebenfalls ruhig. ich kann leider nicht sicher feststellen ob der esound daemon läuft da ich keine Startdatei für ihn finden kann weder in /etc/init.d noch in /bin/ ich habe ihn aber per apt-get install noch mal neu geladen daher gehe ich aus das er läuft.

rolle
Guru
Guru
Beiträge: 3724
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle » 5. Sep 2007, 13:56

Suche den esd mal per 'ps -aux | grep -i es'. Und noch ne ganz böse Frage: Die Boxen oder Kopfhörer sind auch richtig angeschlossen? Es gab da auch mal einen Bug, bei dem der Sound aus dem Kopfhörereingang kam.
Ich hatte damals zwar etws modernere Hardware, bei mir kam bei diesem Soundchip der Sound aber immer nur aus dem Systemspeaker, wobei ich glaube, daß FSC da was verbogen hatte.
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.

TrialAndError
Member
Member
Beiträge: 145
Registriert: 7. Okt 2005, 12:50

Re: Sound Probleme am Terminal

Beitrag von TrialAndError » 7. Sep 2007, 21:54

Hallo greenscreen!
greenscreen hat geschrieben:Hallo an alle,

irgendwie habe ich ein Sound Problem am Terminalserver.

Wenn ich Musik oder Spiele auf dem Terminal Abspiele ertönt die Musik nicht am Terminal sondern am Server.
Da du dich virtuell auf dem Server befindest, wenn du am Terminal sitzt, ist dieses Verhalten auch zu erwarten. Die einzige Möglichkeit ist, es der Software mitzuteilen, dass sie esd (oder oss) als Soundserver benutzen soll. Diese Option gibt es aber in den vielen Programmen nicht mehr, weil sie die Soundkarte direkt ansprechen.
greenscreen hat geschrieben:Ach so noch zur Info ich verwende den LTSP 4.2 auf XUbunut 7.10
*kopfkratz* Zwar benutze ich auch LTSP 4.2, aber mit Dapper. Ich denke dafür gibt es mit Gutsy keinen Grund mehr. Oliver Grawert und das Ubuntu-LTSP-Team haben irre Arbeit geleistet. Soweit ich gelesen habe, z. B. standardmäßig Sound über Netz mit Flash.

Grüße: TrialAndError

PS: Wenn vlc oss anbietet, dann lohnt sich dies auzuprobieren:
http://wiki.ltsp.org/twiki/bin/view/Lts ... ction_to_E

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste