Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Suse 6.4 - Lilo hängt ?

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
fanal
Newbie
Newbie
Beiträge: 3
Registriert: 3. Sep 2007, 19:50

Suse 6.4 - Lilo hängt ?

Beitrag von fanal » 3. Sep 2007, 19:53

Hallo,

ich habe o.g. Suse auf einem Server installiert und lief bisher ohne Probleme. In letzter Zeit traten auf der Boot Platte aber immer öfter Fehler auf die ich mit fsck beseitigen mußte.

Um Datenverlust zu vermeiden, habe ich die Daten der alten Platte mittels DD auf eine neue Platte kopiert. Das ging auch soweit recht gut.
Die Konfiguration ist folgende:

/dev/sda1 * /boot
/dev/sda2 swap
/dev/sda3 /
etc.

Die Einträge in der fstab sind entsprechend.
Beim Booten allerdings bleibt Lilo bei "LI" hängen.

Wenn ich mit der Suse CD2 boote und über die Konsole das installierte System boote, geht alles problemlos, damit ist auch der Kernel ok.

Mittels YAST ist Lilo richtig konfiguriert:
Bootsektor in Root-Partition "/dev/sda3/"
Kernel "/boot/vmlinuz"

Alles scheint ok, nur tut sich nix.
Auch eine mit YAST erstellte Rettungsdiskette bootet nicht,
vermutlich liegts am gleichen Problem.

Hat jemand eventuell eine Idee was das Problem sein könnte ?

Danke,
fanal

Werbung:
admine
Administrator
Administrator
Beiträge: 8757
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: Suse 6.4 - Lilo hängt ?

Beitrag von admine » 3. Sep 2007, 19:56

fanal hat geschrieben: Wenn ich mit der Suse CD2 boote und über die Konsole das installierte System boote, geht alles problemlos, damit ist auch der Kernel ok.
Nach dem Booten mal als root "lilo" ausführen.
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Benutzeravatar
Anubid
Hacker
Hacker
Beiträge: 281
Registriert: 4. Sep 2004, 14:56
Kontaktdaten:

Beitrag von Anubid » 3. Sep 2007, 20:30

Könnte es auch sein, dass die HD sich dem Ende seiner Lebenszeit nähert?

fanal
Newbie
Newbie
Beiträge: 3
Registriert: 3. Sep 2007, 19:50

Beitrag von fanal » 3. Sep 2007, 20:49

Habe Lilo als root ausgeführt, normale Reaktion:

"Added linux *"

Beim Booten bleibts aber wieder hängen.

Die Platte ist übrigens getauscht, die alte hatte Defekte.

fanal

jengelh
Guru
Guru
Beiträge: 4039
Registriert: 20. Nov 2004, 17:42
Kontaktdaten:

Beitrag von jengelh » 3. Sep 2007, 21:29

Nach dd auch mal fsck gemacht (bzw. automatisch machen lassen)? LBA/1024Zyl kann's ja eigentlich nicht sein wenn du nur ge-dd-t hast.
Schau mal in der LILO-Manpage, was es heißt, wenn er nach LI stehen bleibt.

admine
Administrator
Administrator
Beiträge: 8757
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Beitrag von admine » 3. Sep 2007, 21:33

jengelh hat geschrieben: Schau mal in der LILO-Manpage, was es heißt, wenn er nach LI stehen bleibt.
http://de.opensuse.org/SDB:LILO_startet ... nd_Deutung
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

fanal
Newbie
Newbie
Beiträge: 3
Registriert: 3. Sep 2007, 19:50

Beitrag von fanal » 4. Sep 2007, 14:17

Erstmal Danke für die super Hinweise !

Die Fehlermeldungen von Lilo kannte ich noch nicht, also wieder etwas gelernt :) Das hat mir sehr geholfen !
Laut Definition war der Fehler in der Plattengeometrie oder boot.d zu suchen. boot.d konnte ausgeschlossen werden.

Lange Rede, kurzer Sinn, der MBR war nicht 100% eingerichtet.
Das Booten mit einer DOS-Diskette und "fdisk /mbr" hat geholfen.
Nun läuft alles wieder wie vorher.

Super Forum !! 8)

Beste Grüße,

fanal

admine
Administrator
Administrator
Beiträge: 8757
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Beitrag von admine » 4. Sep 2007, 14:28

fanal hat geschrieben: Nun läuft alles wieder wie vorher.
Das ist ja wirklich toll.
Jedoch solltest du dir evt. schon ernsthaft Gedanken darüber machen, deine SUSE-Version gegen eine neue Version zu tauschen.
Suse 6.4 ist ja nun schon wirklich sehr antiquiert ;)
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast