Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

XkbLayout = de verhindert Login

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
valix
Newbie
Newbie
Beiträge: 8
Registriert: 23. Aug 2007, 12:20

XkbLayout = de verhindert Login

Beitrag von valix » 24. Aug 2007, 11:04

Hallo,

so ganz richtig ist die Überschrif nicht, aber nicht anders kurz zu beschreiben. I

ich habe hier einen LTSP 4.2 auf Xubuntu 7.04 aufgesetzt. Die Doku dazu hatte ich im Januar unter Xubuntu 7.04 alpha erstellt (basiert auf der von PUG). Soweit läuft alles. Doch wenn ich in meiner lts.conf "XkbLayout = de " hinzufüge sehe ich nur noch das Hintergrundbild nach der Anmeldung (kein Desktop, keine Leisten, kein Menü, einfach nur Xubuntu-blau). Während der Anmeldung ist dann immer noch das englische Layout geladen.

Also nicht missverstehen, die Anmeldung funktioniert. Und abgesehen von einem englischen Tastaturlayout klappt auch alles ohne XkbLayout perfekt.

Kann es sein, dass der ltspadmin beim installieren schlichtweg nicht das deutsche Layout installiert hat, oder sowas?

Ich habe USB-Tastatur (FSC Standard 105) und USB-Maus (MS Wheel Mouse Optical.

Variationen mit Groß- und Kleinschreibung, sowie " habe ich schon ausprobiert. Das Problem gilt auch bei anderen Sprachen, wenn ich z.B. Französisch oder Niederländisch als Tastaturlayout wähle geht es auch nicht, aber "us" geht (default).

Hier meine lts.conf:

Code: Alles auswählen

#
[Default]
        SERVER             = 192.168.100.1
        XSERVER            = auto
	X_COLOR_DEPTH	   = 24
	X_HORZSYNC	   = "50-60"
	X_VERTREFRESH	   = "55-75"
	X_MOUSE_PROTOCOL   = "IMPS/2"
	X_MOUSE_DEVICE     = "/dev/psaux"
	X_MOUSE_RESOLUTION = 400
	X_MOUSE_BUTTONS    = 9
	X_ZAxisMapping	   = "4 5"
	XkbSymbols	   = de(pc105)
	XkbModel	   = pc105
	XkbLayout 	   = de
	XkbVariant	   = nodeadkeys
	USE_XFS            = N
        SCREEN_01          = startx
Und schlau werde ich aus der syslog im Debugmode auch nicht, sieht ja auf den ersten Blick ganz ok aus (nur Anmeldevorgang geloggt):

Code: Alles auswählen

Aug 24 10:56:25 termserv gdm[11686]: Sending QUERYLOGIN == <secret> for slave 11686
Aug 24 10:56:25 termserv gdm[5105]: Handling message: 'QUERYLOGIN 11686 benutzername'
Aug 24 10:56:25 termserv gdm[5105]: Got QUERYLOGIN benutzername
Aug 24 10:56:25 termserv gdm[11686]: gdm_slave_wait_for_login: end verify for 'benutzername'
Aug 24 10:56:25 termserv gdm[11686]: gdm_slave_wait_for_login: got_login for 'benutzername'
Aug 24 10:56:25 termserv gdm[11686]: Sending LOGGED_IN == 1 for slave 11686
Aug 24 10:56:25 termserv gdm[5105]: Handling message: 'LOGGED_IN 11686 1'
Aug 24 10:56:25 termserv gdm[5105]: Got logged in == TRUE
Aug 24 10:56:25 termserv gdm[11686]: Sending LOGIN == <secret> for slave 11686
Aug 24 10:56:25 termserv gdm[5105]: Handling message: 'LOGIN 11686 benutzername'
Aug 24 10:56:25 termserv gdm[5105]: Got LOGIN == benutzername
Aug 24 10:56:25 termserv gdm[11686]: gdm_slave_session_start: Attempting session for user 'benutzername'
Aug 24 10:56:25 termserv gdm[11686]: Initial setting: session: 'xfce4' language: 'de_DE.UTF-8@euro' 
Aug 24 10:56:25 termserv gdm[11686]: gdm_slave_session_start: Authentication completed. Whacking greeter
Aug 24 10:56:25 termserv gdm[11686]: slave_waitpid: waiting on 11692
Aug 24 10:56:25 termserv gdm[11686]: slave_waitpid: done_waiting
Aug 24 10:56:25 termserv gdm[11686]: Sending GREETPID == 0 for slave 11686
Aug 24 10:56:25 termserv gdm[5105]: Handling message: 'GREETPID 11686 0'
Aug 24 10:56:25 termserv gdm[5105]: Got GREETPID == 0
Aug 24 10:56:25 termserv gdm[11686]: get_local_auths: Setting up network access
Aug 24 10:56:25 termserv gdm[11686]: get_local_auths: Setting up access for 192.168.100.199:0 - 3 entries
Aug 24 10:56:25 termserv gdm[11686]: gdm_auth_user_add: Adding cookie for 1003
Aug 24 10:56:25 termserv gdm[11686]: gdm_auth_user_add: Using /home/benutzername/.Xauthority for cookies
Aug 24 10:56:25 termserv gdm[11686]: gdm_auth_purge: 192.168.100.199:0
Aug 24 10:56:25 termserv gdm[11686]: gdm_auth_user_add: Done
Aug 24 10:56:25 termserv gdm[11686]: Sending WRITE_X_SERVERS == 0 for slave 11686
Aug 24 10:56:25 termserv gdm[5105]: Handling message: 'WRITE_X_SERVERS 11686 0'
Aug 24 10:56:25 termserv gdm[11686]: Sending SESSPID == 11695 for slave 11686
Aug 24 10:56:25 termserv gdm[5105]: Handling message: 'SESSPID 11686 11695'
Aug 24 10:56:25 termserv gdm[5105]: Got SESSPID == 11695
Aug 24 10:56:25 termserv gdm[11686]: slave_waitpid: waiting on 11695
Aug 24 10:56:25 termserv gdm[5105]: gdm_socket_handler: Accepting new connection fd 8
Aug 24 10:56:25 termserv gdm[5105]: Handling user message: 'VERSION'
Aug 24 10:56:25 termserv gdm[5105]: Handling user message: 'GET_CONFIG greeter/GraphicalThemedColor 192.168.100.199:0'
Aug 24 10:56:25 termserv gdm[5105]: Handling user message: 'CLOSE'
Aug 24 10:56:25 termserv gdm[11695]: Running /etc/gdm/Xsession startxfce4  for benutzername on 192.168.100.199:0
Zuletzt geändert von valix am 24. Aug 2007, 13:11, insgesamt 1-mal geändert.

Werbung:
valix
Newbie
Newbie
Beiträge: 8
Registriert: 23. Aug 2007, 12:20

Beitrag von valix » 24. Aug 2007, 13:10

wenn ich in der /opt/ltsp/i386/etc/build_x4_cfg den Keyboarddriver von "keyboard" auf "kbd" (entspricht der lokalen xorg.conf der Clients) habe ich immerhin im GDM eine deutsches Layout, das war vorher nicht. Aber dafür schmiert nach der Anmeldung der Xserver ab :(

valix
Newbie
Newbie
Beiträge: 8
Registriert: 23. Aug 2007, 12:20

Beitrag von valix » 27. Aug 2007, 20:36

Hallo weiß keiner Rat???? :? :(

greenscreen
Newbie
Newbie
Beiträge: 8
Registriert: 23. Aug 2007, 09:27

Beitrag von greenscreen » 3. Sep 2007, 09:29

Das Problem wurde umgangen indem das Paket xkb-data-legacy installiert wurde. Jetzt funktioniert der Login, jedoch ist die grafische Oberfläche nicht mehr so schön Rund (jetzt ähnlich Win2000). Wenn jemand eine Idee hat wie man es eleganter lösen könnte wären wir dankbar.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste