Thin Client T30 USB Mouse und Tastatur

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Gesperrt
Benutzeravatar
acesofthedeep
Newbie
Newbie
Beiträge: 29
Registriert: 7. Mai 2004, 12:36
Wohnort: Lindenberg
Kontaktdaten:

Thin Client T30 USB Mouse und Tastatur

Beitrag von acesofthedeep » 3. Jun 2004, 09:07

Ich habe einen Terminalserver auf einem Suse 8.2 laufen. Die gesamte Prozedur des Sessionsaufbaues funktioniert.
Nun wollte ich einen Thin Client T30 von Compaq als Terminalclient verwenden der nur über USB Schnittstellen verfügt und bekomme keinen USB Treiber geladen.

Werbung:
schweer
Hacker
Hacker
Beiträge: 268
Registriert: 2. Jan 2004, 23:40
Wohnort: Bochum

Re: Thin Client T30 USB Mouse und Tastatur

Beitrag von schweer » 3. Jun 2004, 21:09

acesofthedeep hat geschrieben:Ich habe einen Terminalserver auf einem Suse 8.2 laufen. Die gesamte Prozedur des Sessionsaufbaues funktioniert.
Nun wollte ich einen Thin Client T30 von Compaq als Terminalclient verwenden der nur über USB Schnittstellen verfügt und bekomme keinen USB Treiber geladen.
Was hast Du denn versucht, um die Module zu laden?

wolfgang

Benutzeravatar
acesofthedeep
Newbie
Newbie
Beiträge: 29
Registriert: 7. Mai 2004, 12:36
Wohnort: Lindenberg
Kontaktdaten:

Module

Beitrag von acesofthedeep » 4. Jun 2004, 09:59

Ich habe die folgende Module für die Maus und Tastatur in der ltsp.conf eingetragen:
MODULE_01 = usb-ohci
MODULE_02 = keybdev
MODULE_03 = usbkdb
MODULE_04 = mousedev
MODULE_05 = usbmouse

Beim laden des Kernel auf dem Thin-Client wird auch der USB-Hub sauber erkannt, die Maus funktioniert auch, sofern ich den usbkdb auskommentiere, nur die Tastatur wird nicht geladen. Der entsprechende Treiber usbkdb ist im Gegensatz zum Treiber usbmouse auch nicht auf dem Rechner auffindbar. Ich habe keine Möglichkeit gefunden wie ich den usbkdb eingebunden bekomme.

schweer
Hacker
Hacker
Beiträge: 268
Registriert: 2. Jan 2004, 23:40
Wohnort: Bochum

Re: Module

Beitrag von schweer » 4. Jun 2004, 10:25

acesofthedeep hat geschrieben:Ich habe die folgende Module für die Maus und Tastatur in der ltsp.conf eingetragen:
MODULE_01 = usb-ohci
MODULE_02 = keybdev
MODULE_03 = usbkdb
MODULE_04 = mousedev
MODULE_05 = usbmouse

Beim laden des Kernel auf dem Thin-Client wird auch der USB-Hub sauber erkannt, die Maus funktioniert auch, sofern ich den usbkdb auskommentiere, nur die Tastatur wird nicht geladen. Der entsprechende Treiber usbkdb ist im Gegensatz zum Treiber usbmouse auch nicht auf dem Rechner auffindbar. Ich habe keine Möglichkeit gefunden wie ich den usbkdb eingebunden bekomme.
Statt usbkbd hid eintragen, eventuell mit der Reihenfolge experimemtieren.

wolfgang

Benutzeravatar
acesofthedeep
Newbie
Newbie
Beiträge: 29
Registriert: 7. Mai 2004, 12:36
Wohnort: Lindenberg
Kontaktdaten:

hid

Beitrag von acesofthedeep » 4. Jun 2004, 14:37

Der Tip war super, vielen vielen Dank es funktioniert!!!!

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste