Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] DHCP-server antwortet, Client hört nicht

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Rolf-Werner
Hacker
Hacker
Beiträge: 346
Registriert: 23. Jan 2004, 09:34

[gelöst] DHCP-server antwortet, Client hört nicht

Beitrag von Rolf-Werner » 13. Jul 2007, 08:46

Dies ist ein neuer Server mit Suse 10.2 und LTSP 4.2. (Auf dem bisherigen Server mit Suse 9.3 und LSTSP 4.2 läuft es problemlos.)

Ich hab alle Tests gemacht, DHCP läuft auch, er "hört" den Client und antwortet mit einer IP, aber der Client wartet sich tot. Er kommt also nicht mal bis tftp. Die dhcpd.conf ist die vom alten Server, nur mit geänderten IPs natürlich.

So sieht das normalerweise aus:

Code: Alles auswählen

Jul 12 12:21:37 server02 dhcpd: DHCPDISCOVER from 00:80:c8:27:25:13 via eth0
Jul 12 12:21:37 server02 dhcpd: DHCPOFFER on 192.168.10.112 to 00:80:c8:27:25:13 via eth0
Jul 12 12:21:37 server02 dhcpd: DHCPREQUEST for 192.168.10.112 (192.168.10.102) from 00:80:c8:27:25:13 via eth0
Jul 12 12:21:37 server02 dhcpd: DHCPACK on 192.168.10.112 to 00:80:c8:27:25:13 via eth0
Und dies passiert auf dem neuen Server:

Code: Alles auswählen

Jul 12 12:21:37 server03 dhcpd: DHCPDISCOVER from 00:80:c8:27:25:13 via eth0
Jul 12 12:21:37 server03 dhcpd: DHCPOFFER on 192.168.10.112 to 00:80:c8:27:25:13 via eth0
und das dann immer wieder.

Die Firewall ist aus, und grundsätzlich komme ich auch an den neuen Server ran. Ich hab ihn als zweite X-Session von meinem Client aus laufen.

Aber es könnte ja sein, dass irgendwo noch Beschränkungen der Firewall drinstehen. Oder wo fange ich an zu suchen?

Danke für alle Tipps!

Rolf
Zuletzt geändert von Rolf-Werner am 17. Jul 2007, 11:25, insgesamt 1-mal geändert.
Wissen ist Macht.
Wir wissen nichts.
Macht nichts.

Werbung:
jengelh
Guru
Guru
Beiträge: 4039
Registriert: 20. Nov 2004, 17:42
Kontaktdaten:

Beitrag von jengelh » 13. Jul 2007, 12:17

dhcp-server-identifier in der dhcpd.conf... ich glaub die solltest du auch anpassen.

Rolf-Werner
Hacker
Hacker
Beiträge: 346
Registriert: 23. Jan 2004, 09:34

Beitrag von Rolf-Werner » 13. Jul 2007, 13:03

Diese Option habe ich nicht in der dhcpd.conf, und ich finde sie auch nicht in der man-page. Die IPs hab ich natürlich geändert...

Mir scheint das auch eher ein Kommunikationsproblem zu sein, so als ob die Antwort des dhcp-Servers an das Terminal blockiert würde.

Rolf
Wissen ist Macht.
Wir wissen nichts.
Macht nichts.

Rolf-Werner
Hacker
Hacker
Beiträge: 346
Registriert: 23. Jan 2004, 09:34

Beitrag von Rolf-Werner » 17. Jul 2007, 11:24

Ich hab die Lösung jetzt :)

In der Mailingliste von LTSP hat mir jemand diesen Tipp gegeben:
In Debian Etch, or anything with dhcp3-server >= 3.0.3,
the next-server statement is needed or Etherboot will walk in
circles saying "No IP address". To activate, uncomment the line:

next-server 192.168.0.254; # <-- Change IP !

in dhcpd.conf file on your server.
Also ab dhcp 3.0.3 muss unter group { die Angabe next-server mit der eigenen IP stehen (ja, in der man-page steht es auch, wenn man's weiß...) Es scheint aber eine Besonderheit in Zusammenarbeit mit etherboot zu sein.

Jetzt läuft es also.

Rolf
Wissen ist Macht.
Wir wissen nichts.
Macht nichts.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste