Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Wine Alsa Treiber für den Sound aktiviere 125er Latenz ???

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
M.Heinze
Newbie
Newbie
Beiträge: 6
Registriert: 23. Dez 2006, 10:47
Kontaktdaten:

Wine Alsa Treiber für den Sound aktiviere 125er Latenz ???

Beitrag von M.Heinze » 11. Jul 2007, 19:58

Hallo,

hatte die ganze Zeit keinen Sound bei CS 1.6 habe bei Wine unter Audio den ALSA-Treiber aktiviert wobei ich zwar Sound bekommen habe aber meine Latenz von normal 59 auf 125 angestiegen ist.

Ruckelt dann wie Sau.

Wenn ich den Treiber weder ausschalte habe ich zwar keinen Sound mehr aber eine Latenz bei 59.

Hier mal ein Bild meiner Einstellung unter "Audio".

http://www.spielen-unter-linux.de/attac ... mentid=794

Hoffe es kann mir jemand weiterhelfen. 8)

Werbung:
derMani
Hacker
Hacker
Beiträge: 661
Registriert: 7. Jun 2004, 22:23
Wohnort: Papenburg
Kontaktdaten:

Beitrag von derMani » 13. Jul 2007, 11:07

Hi, ich kann CS bei mir ebenfalls nicht mit Alsa spielen.


Bei mir reicht es dann, wenn ich den Ton in der winecfg auf OSS setze. Dann sind bild und ton flüssig. Alternativ kannst du auch mal mit den Einstellungen rund um die "Emulation" rumspielen.


Ein weiterer Vorschlag (hab ich in nem anderen Forum aufgeschnappt)

1. Konsole in CS öffnen
2. _snd_mixahead 0.2 eingeben (standart ist 0.1)

Es kann auch ein anderer wert sein als 0.2, mal etwas rumprobieren
Andrew S. Tanenbaum: The nice thing about
standards is that you have so many to choose from.
Furthermore, if you dont’t like any of them, you can
just wait for next year’s model.


Linux-Club Wiki
Howtos, Tipps uvm.
http://wiki.linux-club.de/

M.Heinze
Newbie
Newbie
Beiträge: 6
Registriert: 23. Dez 2006, 10:47
Kontaktdaten:

Beitrag von M.Heinze » 13. Jul 2007, 14:09

Hallo,

habe es probiert nur oss zu aktivieren steht dann aber in der Konsole immer:

Code: Alles auswählen

fixme:wave:ALSA_AddCaptureDevice Add support for DSCapture
ALSA lib seq_hw.c:457:(snd_seq_hw_open) open /dev/snd/seq failed: Datei oder Verzeichnis nicht gefunden
Mario@linux-o9s6:~>
Wenn ich dann nochmal in Wine unter Audio nachsehe ist bei mir unter Audio Treiber nichts aktiviert.

Wenn ich aber Alsa aktivier dann aktiviert sich OSS gleich mit und bleibt dann auch aktiviert.

Aber damit geht die Latenz dann saumäsig nach oben.

Hoffe ihr könnt mir weiterhelfen. :rolleyes:

Gruß Mario :cry:

derMani
Hacker
Hacker
Beiträge: 661
Registriert: 7. Jun 2004, 22:23
Wohnort: Papenburg
Kontaktdaten:

Beitrag von derMani » 17. Jul 2007, 01:26

http://wiki.winehq.org/FAQ#head-6ff921e ... f984179401
I'm using OSS in Wine and I have no sound.

Unless you're using a sound card with an emu10k1/2 chipset (SB Live!/Audigy) or another type of card that supports "Hardware Mixing" then you can only ever have one application using sound at the same time. If you have aRts (KDE sound system), ESD (Gnome sound system) or any music apps open then you simply wont hear anything from Wine. You need to kill or close all these programs before being able to get sound from Wine. To work out if anything has locked your sound-card already you can do "cat /dev/urandom >> /dev/dsp". If you get an error message it means that something is using it. If you get loud static this means that your sound card is clear and ready for use.
Andrew S. Tanenbaum: The nice thing about
standards is that you have so many to choose from.
Furthermore, if you dont’t like any of them, you can
just wait for next year’s model.


Linux-Club Wiki
Howtos, Tipps uvm.
http://wiki.linux-club.de/

M.Heinze
Newbie
Newbie
Beiträge: 6
Registriert: 23. Dez 2006, 10:47
Kontaktdaten:

Beitrag von M.Heinze » 17. Jul 2007, 01:46

PID TTY TIME CMD
1 ? 00:00:01 init
2 ? 00:00:00 migration/0
3 ? 00:00:00 ksoftirqd/0
4 ? 00:00:00 events/0
5 ? 00:00:00 khelper
6 ? 00:00:00 kthread
9 ? 00:00:00 kblockd/0
10 ? 00:00:00 kacpid
11 ? 00:00:00 kacpi_notify
133 ? 00:00:00 cqueue/0
134 ? 00:00:00 kseriod
176 ? 00:00:00 pdflush
177 ? 00:00:00 pdflush
178 ? 00:00:00 kswapd0
179 ? 00:00:00 aio/0
432 ? 00:00:00 kpsmoused
879 ? 00:00:00 kjournald
927 ? 00:00:00 udevd
1351 ? 00:00:00 khubd
1422 ? 00:00:00 kgameportd
1433 ? 00:00:00 khpsbpkt
1884 ? 00:00:00 knodemgrd_0
2338 ? 00:00:00 kjournald
2824 ? 00:00:00 acpid
2840 ? 00:00:00 syslog-ng
2846 ? 00:00:00 klogd
2861 ? 00:00:00 dbus-daemon
2912 ? 00:00:00 resmgrd
2962 ? 00:00:00 polkitd
2969 ? 00:00:01 hald
2972 ? 00:00:00 hald-runner
3308 ? 00:00:00 hald-addon-acpi
3372 ? 00:00:00 hald-addon-keyb
3396 ? 00:00:00 hald-addon-keyb
3491 ? 00:00:00 hald-addon-stor
3495 ? 00:00:00 hald-addon-stor
3558 ? 00:00:00 dhcpcd
3815 ? 00:00:00 portmap
3819 ? 00:00:00 kdm
3823 ? 00:00:00 auditd
3825 ? 00:00:00 kauditd
3911 ? 00:00:00 cupsd
3950 ? 00:00:00 nscd
4011 ? 00:00:01 zmd
4018 ? 00:00:00 powersaved
4046 tty7 00:00:16 Xorg
4088 ? 00:00:00 sshd
4099 ? 00:00:00 master
4118 ? 00:00:00 cron
4124 ? 00:00:00 pickup
4125 ? 00:00:00 qmgr
4127 ? 00:00:00 kdm
4242 tty1 00:00:00 mingetty
4243 tty2 00:00:00 mingetty
4247 tty3 00:00:00 mingetty
4250 tty4 00:00:00 mingetty
4252 tty5 00:00:00 mingetty
4256 tty6 00:00:00 mingetty
4318 ? 00:00:00 kde
4373 ? 00:00:00 gpg-agent
4374 ? 00:00:00 ssh-agent
4378 ? 00:00:00 dbus-daemon
4474 ? 00:00:00 start_kdeinit
4475 ? 00:00:00 kdeinit
4478 ? 00:00:00 dcopserver
4480 ? 00:00:00 klauncher
4482 ? 00:00:01 kded
4487 ? 00:00:00 kwrapper
4489 ? 00:00:00 ksmserver
4490 ? 00:00:01 kwin
4492 ? 00:00:00 kdesktop
4494 ? 00:00:03 kicker
4495 ? 00:00:00 kio_file
4517 ? 00:00:05 kopete
4526 ? 00:00:02 knotify
4530 ? 00:00:02 konqueror
4532 ? 00:00:00 kmix
4533 ? 00:00:00 zen-updater
4535 ? 00:00:00 klipper
4539 ? 00:00:00 kpowersave
4549 ? 00:00:04 beagled
4588 ? 00:00:00 kwalletmanager
4620 ? 00:00:04 beagled-helper
4646 ? 00:00:02 kmail
4768 ? 00:00:00 firefox
4773 ? 00:00:10 firefox-bin
4779 ? 00:00:00 gconfd-2
4786 ? 00:00:00 netstat <defunct>
5075 ? 00:00:00 kio_uiserver
14140 ? 00:00:01 konqueror
14166 ? 00:00:00 mono <defunct>
14171 ? 00:00:00 mono <defunct>
14176 ? 00:00:00 mono <defunct>
14177 ? 00:00:00 mono <defunct>
14191 ? 00:00:00 kio_http
14195 ? 00:00:00 kio_http
14196 ? 00:00:00 kio_http
14203 ? 00:00:00 kio_http
14207 ? 00:00:00 kio_http
14211 ? 00:00:00 kio_http
14212 ? 00:00:00 kio_http
14303 ? 00:00:00 kcontrol
14349 ? 00:00:00 kio_pop3
14366 ? 00:00:00 konsole
14367 pts/1 00:00:00 bash
14377 pts/1 00:00:00 ps
Mario@linux-o9s6:~>

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste