Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] evdev bei SuSE 10.2 - wie laden bzw. installieren?

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
dma67
Hacker
Hacker
Beiträge: 411
Registriert: 27. Jan 2005, 04:11

[gelöst] evdev bei SuSE 10.2 - wie laden bzw. installieren?

Beitrag von dma67 » 7. Jul 2007, 09:33

Hallo Leute,

ich hoffe, ich poste im richtigen Forum.
Mein Problem: wie unter SuSE 10.0 möchte ich meine MX1000 (Laser-Maus von Logitech) bezwingen. Es gibt ein recht gutes HowTo von stulle. Bei SuSE 10.0 funktionierte es wunderbar.
Bei SuSE 10.2 wehrt sich das Vieh. :-)

Nun stellt es sich heraus, dass bei SuSE 10.2 weder das Paket x11-input-evdev vorhanden noch das Modul evdev im Kernel ist.

Das Paket x11-input-evdev-050728-3.i586.rpm hab ich nachinstalliert (SuSE 10.0 Repo - ohne Probleme lässt sich installieren).
Im Verzeichnis
/usr/X11R6/lib/modules/input
landet eine Datei namens evdev_drv.

Jetzt

Code: Alles auswählen

c16: # modprobe evdev
FATAL: Module evdev not found.
c16:/ #
folglich:

Code: Alles auswählen

c16:/ # lsmod | grep evdev
c16:/ #
Bevor ihr losprügelt...
google Suche nach:
- suse 10.2 evdev
- "FATAL: Module evdev not found."
brachte nichts.

Wie lade ich das Modul?

Danke für jeden Hinweis.
Zuletzt geändert von dma67 am 7. Jul 2007, 14:39, insgesamt 1-mal geändert.
Gruß

Darius

Werbung:
b3ll3roph0n
Moderator
Moderator
Beiträge: 3669
Registriert: 4. Dez 2005, 13:17
Kontaktdaten:

Beitrag von b3ll3roph0n » 7. Jul 2007, 09:58

AFAIK brauchst du auch das entsprechende evdev-Kernel-Modul.
D.h. wohl eigenen Kernel mit evdev-Unterstützung bauen oder mal den Kernel von jengelh versuchen, der beinhaltet offensichtlich evdev als Modul.

Zur Einrichtung lesen: http://www.pc-forum24.de/suse-treiber/3 ... 2-x64.html
Gruß b3ll3roph0n
--
Denken hilft!

Ich beantworte keine Support-Anfragen per PN.
Für alle meine Beiträge gelten, außer bei Zitaten, die Creative Commons.

Benutzeravatar
dma67
Hacker
Hacker
Beiträge: 411
Registriert: 27. Jan 2005, 04:11

Beitrag von dma67 » 7. Jul 2007, 14:39

Ja. Lässt sich nicht vermeiden.Das hab ich befürchtet.

Es kam halb so wild.

Per jengelhs-Repo schnell installierbar ohne Frickeleien. :-)

Nur noch:
jengelh hat geschrieben:
Lösche
* /lib/modules/2.6.18.8-ccj45-default/kernel/drivers/usb/input/usbkbd.ko und
* /lib/modules/2.6.18.8-ccj45-default/kernel/drivers/usb/input/usbmouse.ko
diese sind wahrscheinlich Ursache (werde sie für den nächsten Kernel wieder rausnehmen), und mach' dann bitte mal (einfachste Methode) einen ganzen Reboot.
und evdev laden.

Alles funktioniert bestens.

Danke für den Hinweis.
Gruß

Darius

jengelh
Guru
Guru
Beiträge: 4039
Registriert: 20. Nov 2004, 17:42
Kontaktdaten:

Beitrag von jengelh » 8. Jul 2007, 16:34

evdev ist bei SUSE fest einkompiliert.

Benutzeravatar
dma67
Hacker
Hacker
Beiträge: 411
Registriert: 27. Jan 2005, 04:11

Beitrag von dma67 » 13. Jul 2007, 15:52

jengelh hat geschrieben:evdev ist bei SUSE fest einkompiliert.
Tatsächlich.
Korrekt xorg.conf mit Standard-Kernel (korrekt :oops: ) konfiguriert und die Maus läuft mit evdev.
Jengelh's Kernel ade!
Gruß

Darius

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste