Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Kernel 2.6.5 und boot.msg Meldung

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
xunil321
Newbie
Newbie
Beiträge: 19
Registriert: 26. Mai 2004, 09:03

Kernel 2.6.5 und boot.msg Meldung

Beitrag von xunil321 » 2. Jun 2004, 15:55

Hallo Leute!

Wir betreiben einen Rechner unter Suse 8.2 mit einem
frisch compilierten Kernel 2.6.5.
Das System bootet prima hoch und laeuft sehr stabil,
doch finden sich im boot.msg File diese Zeilen:

<5>RAMDISK: Compressed image found at block 0
<4>VFS: Mounted root (ext2 filesystem).
<4>scsi_mod: unsupported module, tainting kernel.
<5>SCSI subsystem initialized
<4>sd_mod: unsupported module, tainting kernel.
<4>reiserfs: unsupported module, tainting kernel.
<4>sym53c8xx: unsupported module, tainting kernel.
<6>sym0: <875> rev 0x4 at pci 0000:01:09.0 irq 11
<4>sym0: No NVRAM, ID 7, Fast-20, SE, parity checking
<5>sym0: SCSI BUS has been reset.
<6>scsi0 : sym-2.1.18i
<6>sym0:0: FAST-20 WIDE SCSI 40.0 MB/s ST (50.0 ns, offset 15)
<6>scsi scan: 255 byte inquiry failed with code 458752. Consider BLIST_INQUIRY_36 for this device
<5> Vendor: COMPAQ Model: WDE4360W Rev: 1.52
<5> Type: Direct-Access ANSI SCSI revision: 02
<6>sym0:0:0: tagged command queuing enabled, command queue depth 16.

Was mich stoert sind diese "unsupported module, tainting kernel" Meldungen
(scsi_mod, sd_mod reiserfs).
Wie gesagt, der Rechner bootet dann ohne weitere Fehler hoch,
erkennt alle H/W und rennt ganz prima!
Wer weiss, was es mit diesen Meldungen auf sich hat?

Danke und mfG

RainerB.

Werbung:
Benutzeravatar
wenf
Hacker
Hacker
Beiträge: 422
Registriert: 8. Mär 2004, 11:23
Wohnort: ÖSI-Land
Kontaktdaten:

Beitrag von wenf » 2. Jun 2004, 16:00

hast du die kernel-module des neuen kernels auch in deine initrd gepackt ?

xunil321
Newbie
Newbie
Beiträge: 19
Registriert: 26. Mai 2004, 09:03

Beitrag von xunil321 » 3. Jun 2004, 08:28

Habe ich mittels

#mkinitrd -m "sym53c8xx reiserfs" -k vmlinuz-2.6.5 -i initrd-2.6.5

getan.
Trotzdem, die (Fehler)meldungen bleiben.

Benutzeravatar
nobbiew
Hacker
Hacker
Beiträge: 497
Registriert: 1. Mär 2004, 23:26

Beitrag von nobbiew » 3. Jun 2004, 09:27

Also soweit ich das erkennen kann, soll die Meldung folgendes Aussagen. Du setzt offensichtlich irgendein modul ein, dass von den original Kernel-Sourcen nicht unterstützt wird. Nun soll diese Meldung nur anzeigen, dass der Kernel evtl. kompimitiert sein könnte.

Gast

Beitrag von Gast » 3. Jun 2004, 09:27

Eigentlich heisst das doch nur, dass der Kernel mit einem 'unpassenden' Modul 'verunreinigt' wurde. Wenn die Module aber laufen, dass ist es doch OK.

Kann es vielleicht damit zu tun haben, dass die falschen Quellen bzw. das falsche Modulverzeichnis verlinkt wurde?

xunil321
Newbie
Newbie
Beiträge: 19
Registriert: 26. Mai 2004, 09:03

Beitrag von xunil321 » 3. Jun 2004, 09:50

@abisko00:

Wo sollte ich da nachschauen?

Gast

Beitrag von Gast » 3. Jun 2004, 11:41

Es gibt ja diesen Link /usr/src/linux, der immer auf die Quellen des aktuellen Kernels verweist. Dieser Link ist wohl obsolet und sollte eigentlich vom Rechner entfernt werden. Ich weiss nicht, ob er in der Version 8.2 noch irgendeine Bedeutung hat, aber du kannst ja mal prüfen ob der eigentlich stimmt.

Gibt es denn auf dem Rechner mehr als ein /lib/modules (sind also noch beide Kernel installiert)? Ich glaube der Link zu den Modulen wird bei make modules_install erzeugt und in der System.map abgelegt. Ich kann jetzt auch nur raten, aber vielleicht hilft dir ja der Abschnitt 'Installation des Kernel' bei Thomas Hertweck weiter.

Ansonsten müssen ja eine ganze Menge Pakete auf den neuesten Stand gebracht werden, um einen 2.6er Kernel mit 8.2 betreiben zu können. Da dein Kernel aber läuft, wird wohl alles OK sein.

Benutzeravatar
nobbiew
Hacker
Hacker
Beiträge: 497
Registriert: 1. Mär 2004, 23:26

Beitrag von nobbiew » 4. Jun 2004, 13:51

Hä, wie bitte, wieso ist der link obsolet?

IMHO ist es richtig, dass der Link im laufenden Betrieb nicht gebraucht wird, aber sobald du selber compilieren willst brauchst du den i.d.R., da dort standarmäßig die Kernelquellen gesucht werden. Aber vielleicht hab ich ja die neueste Entwicklung nicht mitbekommen.

Gast

Beitrag von Gast » 4. Jun 2004, 14:16

Ich beziehe mich auf Thomas Hertweck's Howto:
Immer wieder kommt es zu Missverständnissen, was den Link /usr/src/linux angeht. Prinzipiell muss dieser Link nicht existieren (Linus Torvalds geht sogar soweit zu sagen, der Link sollte nicht existieren). Er ist zum Konfigurieren, Compilieren und Installieren eines neuen Kernels nicht nötig. Existiert dieser Link aber, so sollte er immer auf die Kernel-Quellen des momentan laufenden Kernels zeigen. Der Link wird meist benutzt, wenn externe Kernel-Module compiliert werden; oft wertet das entsprechende Makefile nicht den Link /lib/modules/`uname -r`/build aus (was es eigentlich tun sollte), sondern vertraut darauf, dass /usr/src/linux korrekt gesetzt ist. Nur wenn die korrekten Linux-Header zum Compilieren des Modules eingebunden werden können, wird es auch zum Kernel passen und sich laden lassen. Sofern also beim Installieren von neuen Kernel-Quellen der Link /usr/src/linux existiert und auf ein existierendes Verzeichnis mit (älteren) Kernel-Quellen, die zum momentan laufenden Kernel passen, zeigt, kann er zunächst unberührt bleiben. Erst nachdem ein neuern Kernel compiliert, installiert und erfolgreich gebootet wurde, sollte der Link /usr/src/linux angepasst werden. Installiert man Kernel-Quellen per RPM, so wird u.U. der Link automatisch verändert. Hier sollte man als Anwender ein Auge darauf haben und gegebenenfalls von Hand einschreiten (oder den Link ganz löschen).
Das geht auch noch weiter und erklärt, warum der Link in älteren Distros notwendig war, aber das kann ja jeder selber lesen...

Gast

Nachtrag

Beitrag von Gast » 4. Jun 2004, 14:34

@xunil321:

Zu 'Kernel-tainting' gibt es eine Reihe von Links, die man sich googlen kann (hier ist mal einer):

http://kerneltrap.org/node/view/168

Als Konsequenz stellen sich mir zwei Fragen:

1. verwendest du vielleicht seltsame Quellen/binäre Module (eher unwahrscheinlich)?

2. sind deine modutils vielleicht nicht kompatibel?

Falls #2 zutrifft lässt sich dass ja durch ein Update der modutils feststellen.

Antworten