Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Kein Update von FreeNX 0.5.0-25 auf 0.6.0-28 möglich

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
Ssky
Newbie
Newbie
Beiträge: 2
Registriert: 26. Jun 2007, 17:45

Kein Update von FreeNX 0.5.0-25 auf 0.6.0-28 möglich

Beitrag von Ssky » 26. Jun 2007, 23:42

Habe wegen deutscher Tastatur letzte Woche einen OpenSuse 10.2
von FreeNX 0.5.0.25 auf die Version 0.6.0.25 online upgedatet. Ging ohne Probleme.
Jetzt gibt es die Version 0.6.0-28.1 und beim update kommt die Meldung:

Auflösung der Abhängigkeiten nicht erfolgreich
Unresolved Dependencies:
Updating FreeNX-0.5.0.25.noarch[System packages] to
FreeNX-0.6.0-28.1.noarch[20070626-190213]
There are no installable providers of libc.so.6(GLIBC_2.2.5)(64bit) for
FreeNX-0.6.0-28.1.noarch[20070626-190213]

Und die Softwareaktualisierung macht nicht weiter....
Wo muss ich ansetzen, um das Problem zu lösen?
Never touch a running system and never say uppps in a coputer-room!

Werbung:
the_evil_twin

Kein Update von FreeNX 0.5.0-25 auf 0.6.0-28 möglich

Beitrag von the_evil_twin » 27. Jun 2007, 10:42

Du brauchst das OSS und das NX Repo in deinem Paketmanager. Ich erklärs dir mal am Beispiel von Zypper. Öffne ein Terminal, werde root und tue folgendes:

Code: Alles auswählen

zypper service-add http://download.opensuse.org/distribution/10.2/repo/oss/ OSS

Code: Alles auswählen

zypper service-add --repo http://software.opensuse.org/download/NX/openSUSE_10.2/NX.repo

Code: Alles auswählen

zypper install FreeNX

Code: Alles auswählen

Continue? [y/n]
Mit y bestätigen.

In Zukunft aktualisierst du mit:

Code: Alles auswählen

zypper refresh 

Benutzeravatar
Ssky
Newbie
Newbie
Beiträge: 2
Registriert: 26. Jun 2007, 17:45

Update hat geklappt

Beitrag von Ssky » 27. Jun 2007, 14:48

Danke für die Hilfe. Das erste Kommando musste ich zwar mit CTRL+C abbrechen weil es nach 30 Minunten immer noch hing. Rest hat aber super geklappt. Deutscher zeichensatz funktionier auch wieder...
Werd mir mal das "zypper" genauer ansehen!
Never touch a running system and never say uppps in a coputer-room!

the_evil_twin

Kein Update von FreeNX 0.5.0-25 auf 0.6.0-28

Beitrag von the_evil_twin » 27. Jun 2007, 15:19

Da kann ich nur:

http://de.opensuse.org/Zypper

und

http://de.opensuse.org/Zypper/Anleitung

empfehlen für den Anfang.

rolle
Guru
Guru
Beiträge: 3724
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle » 27. Jun 2007, 16:02

Wobei das noch nicht erklärt, wozu die 64 Bit Bibliothek benötigt wird auf einem 32 Bit System, wie es auch bei mir momentan so ist.
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.

the_evil_twin

Kein Update von FreeNX 0.5.0-25 auf 0.6.0-28

Beitrag von the_evil_twin » 27. Jun 2007, 17:42

rolle hat geschrieben:Wobei das noch nicht erklärt, wozu die 64 Bit Bibliothek benötigt wird auf einem 32 Bit System, wie es auch bei mir momentan so ist.
Welche meinst du?

rolle
Guru
Guru
Beiträge: 3724
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle » 27. Jun 2007, 18:20

Die hier:
18:19 rolle:~ > sudo apt install FreeNX
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
FreeNX: Depends: libc.so.6(GLIBC_2.2.5)(64bit) but it is not installable
Depends: libc.so.6()(64bit) but it is not installable
E: Broken packages
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.

the_evil_twin

Kein Update von FreeNX 0.5.0-25 auf 0.6.0-28

Beitrag von the_evil_twin » 27. Jun 2007, 19:29

Bei mir wird nicht rebelliert, ich hab aber auch ein x86-64er System. Vielleicht solltest du einen Bug Report machen rolle.
Zuletzt geändert von the_evil_twin am 28. Jun 2007, 09:50, insgesamt 1-mal geändert.

rolle
Guru
Guru
Beiträge: 3724
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle » 28. Jun 2007, 07:10

Genau das habe ich gemacht und der nette Packer hat es auch gleich behoben. Aufgrund von Änderungen ist jetzt FreeNX wohl nicht mehr 'noarch' sondern architekturabhängig.
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste