Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Virtual Box - bridged Networking - Probleme mit SUSE Firewal

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
n8liner
Newbie
Newbie
Beiträge: 15
Registriert: 26. Jun 2007, 11:39

Virtual Box - bridged Networking - Probleme mit SUSE Firewal

Beitrag von n8liner » 26. Jun 2007, 12:20

Ich habe VirtualBox 1.4 installiert. Als Gastsystem wird Windows XP betrieben. Die Netzwerkverbindungen zum Gastsystem habe ich bridged network konfiguriert. Das Problem das ich jedoch habe ist, dass die Netzwerkverbindungen im Gastsystem nur dann funktionieren, wenn ich den Firewall stoppe. Dann funktionieren DHCP, Ping, Internetzugriff usw. Sobald ich den Firewall wieder aktiviere ist kein Netzwerkzugriff möglich.

Wie muss der Firewall konfiguriert werden, damit das Gastsystem auch bei aktivem Firewall auf das Netzwerk zugreifen kann?


Danke für die Hilfe

openSUSE 10.2
Kernel: 2.6.18.8-0.3

Netzdefinitionen:
bridge name br0
bridge id 8000.00134639e044
STP enabled no
interfaces eth1 vbox0

Werbung:
n8liner
Newbie
Newbie
Beiträge: 15
Registriert: 26. Jun 2007, 11:39

Beitrag von n8liner » 5. Jul 2007, 21:18

schade, dass keiner einen Tipp zur Firewall-Einstellung hat.
thx
CPU: AMD Athlon 64 X2 6000+
Memory: 4 GB
Mainboard: MSI K9AG Neo2 Digital
Netz: onboard K9AG 1 GB
D-LINK DGE528T
OpenSuse 11.2 x86_64

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16603
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 6. Jul 2007, 06:43

n8liner hat geschrieben:schade, dass keiner einen Tipp zur Firewall-Einstellung hat.
Hi sieh dir doch bitte die Links mal an.
Da ist auch eine Wiki dabei :wink:

http://forums.virtualbox.org/viewtopic. ... 80dfc02310
http://doc.gwos.org/index.php/VirtualBox

cu

n8liner
Newbie
Newbie
Beiträge: 15
Registriert: 26. Jun 2007, 11:39

Beitrag von n8liner » 8. Jul 2007, 19:40

Hi
danke für die Tipps, aber die helfen nicht wirklich weiter.

Wie beschrieben, wenn ich den OpenSuse Firewall in Yast deaktiviere, funktioniert das Netzwerk aus der Virtualbox mit dem Windows XP über die definierte Bridge. Sobald der OpenSuse-Firewall wieder aktiv ist, sind die Verbindungen aus dem XP-Gast tot. D. h. doch dass im Firewall irgendwelche Definitionen vorzunehmen sind, damit der XP-Gast über die Bridge auf's Netzwerk zugreifen kann.

Nochmals Danke -
Falls ich eine Lösung dafür finde, melde ich mich wieder
thx
CPU: AMD Athlon 64 X2 6000+
Memory: 4 GB
Mainboard: MSI K9AG Neo2 Digital
Netz: onboard K9AG 1 GB
D-LINK DGE528T
OpenSuse 11.2 x86_64

b3ll3roph0n
Moderator
Moderator
Beiträge: 3669
Registriert: 4. Dez 2005, 13:17
Kontaktdaten:

Beitrag von b3ll3roph0n » 8. Jul 2007, 19:50

Und wie ist die Firewall konfiguriert?
Welche Schnittstellen sind welchen Zonen zugewiesen?

Poste deine /etc/sysconfig/SuSEfirewall2 (ohne Kommnetare).
Gruß b3ll3roph0n
--
Denken hilft!

Ich beantworte keine Support-Anfragen per PN.
Für alle meine Beiträge gelten, außer bei Zitaten, die Creative Commons.

n8liner
Newbie
Newbie
Beiträge: 15
Registriert: 26. Jun 2007, 11:39

Beitrag von n8liner » 8. Jul 2007, 20:14

Hier meine Firewall-Definitionen

FW_DEV_EXT="any br0 eth-id-00:13:46:39:e0:44 ippp0"

FW_DEV_INT="br1 eth-id-00:13:8f:df:d8:4d"

FW_DEV_DMZ=""

FW_ROUTE="no"

FW_MASQUERADE="no"

FW_MASQ_DEV="$FW_DEV_EXT"

FW_MASQ_NETS="0/0"

FW_PROTECT_FROM_INT="no"

FW_SERVICES_EXT_TCP="10000 11210 115 119 123 1758 2001 2020 2049 20:25 3000 3010 4000 465 5001 57003:57006 5801 5901 6566 69 7402 8000 8001 8010 8080 8081 901 netbios-dgm netbios-ns xdmcp"

FW_SERVICES_EXT_UDP="110 119 2049 5001 514 57006 6566 993 995 bootpc ipp ipsec-nat-t isakmp xdmcp"

FW_SERVICES_EXT_IP="esp"

FW_SERVICES_EXT_RPC="nlockmgr portmap status"

FW_SERVICES_DMZ_TCP=""

FW_SERVICES_DMZ_UDP=""

FW_SERVICES_DMZ_IP=""

FW_SERVICES_DMZ_RPC=""

FW_CONFIGURATIONS_DMZ=""

FW_SERVICES_INT_TCP=""

FW_SERVICES_INT_UDP=""

FW_SERVICES_INT_IP=""

FW_SERVICES_INT_RPC=""

FW_CONFIGURATIONS_INT=""

FW_SERVICES_DROP_EXT=""

FW_SERVICES_REJECT_EXT="0/0,tcp,113"

FW_SERVICES_ACCEPT_EXT=""

FW_TRUSTED_NETS=""

FW_ALLOW_INCOMING_HIGHPORTS_TCP=""

FW_ALLOW_INCOMING_HIGHPORTS_UDP=""

FW_FORWARD=""

FW_FORWARD_MASQ=""

FW_REDIRECT=""

FW_LOG_DROP_CRIT="yes"

FW_LOG_DROP_ALL="no"

FW_LOG_ACCEPT_CRIT="yes"

FW_LOG_ACCEPT_ALL="no"

FW_LOG_LIMIT=""

FW_LOG=""

FW_KERNEL_SECURITY="yes"

FW_STOP_KEEP_ROUTING_STATE="no"

FW_ALLOW_PING_FW="yes"

FW_ALLOW_PING_DMZ="no"

FW_ALLOW_PING_EXT="no"

FW_ALLOW_FW_SOURCEQUENCH=""

FW_ALLOW_FW_BROADCAST_EXT="xdmcp ipp"

FW_ALLOW_FW_BROADCAST_INT="no"

FW_ALLOW_FW_BROADCAST_DMZ="no"

FW_IGNORE_FW_BROADCAST_EXT="yes"
thx
CPU: AMD Athlon 64 X2 6000+
Memory: 4 GB
Mainboard: MSI K9AG Neo2 Digital
Netz: onboard K9AG 1 GB
D-LINK DGE528T
OpenSuse 11.2 x86_64

n8liner
Newbie
Newbie
Beiträge: 15
Registriert: 26. Jun 2007, 11:39

Beitrag von n8liner » 11. Jul 2007, 19:16

Hi,
so, das Problem habe ich jetzt gelöst:

Unter YAST mit Editor für etc/sysconfig Dateien habe ich folgende Einträge geändert:

1. Network -> General:
IP_FORWARD auf yes

2. Unter Network -> Firewall -> SUSEfirewall2
FW_FORWARD_ALWAYS_INOUT_DEV br0 eintragen

br0 ist der Name der Bridge

Damit funktioniert der Durchgriff vom XP-Gast auf das Internet bzw. Heimnetz.
thx
CPU: AMD Athlon 64 X2 6000+
Memory: 4 GB
Mainboard: MSI K9AG Neo2 Digital
Netz: onboard K9AG 1 GB
D-LINK DGE528T
OpenSuse 11.2 x86_64

Rain_Maker

Beitrag von Rain_Maker » 11. Jul 2007, 19:24

Ein ausgezeichnetes und sehr ausführliches HowTo zu VirtualBox findet man übrigens hier:

http://www.linuxforen.de/forums/showthread.php?t=236444

Greetz,

RM

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste