Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

VirtualBox - Host Interface Netzwerk

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
mercedesdriver
Hacker
Hacker
Beiträge: 252
Registriert: 4. Feb 2005, 11:47

VirtualBox - Host Interface Netzwerk

Beitrag von mercedesdriver » 24. Jun 2007, 16:16

Hallo zusammen,

ich versuche jetzt seit Tagen VirtualBox mit Host Interface Netzwerk zum Laufen zu bekommen, um einen Testserver darin laufen zu lassen - leider klappt das bis jetzt nicht ...

Ich habe unter http://forum.ubuntuusers.de/topic/94519/ ein nettes Script gefunden, das ich eingesetzt habe (alle anderen Sachen mit tap/tun (oder wie das heißt) haben noch weniger funktioniert).

Nach eingabe / ausführen von (natürlich entsprechend angepasst):

Code: Alles auswählen

#!/bin/bash
tunctl -t tap0 -u <Benutzername> # Benutzername anpassen
chmod 0666 /dev/net/tun
ip link set tap0 up
ip addr add 192.168.100.200/24 dev tap0 #IP anpassen
parprouted eth0 tap0 # Netzwerkkarte anpassen
echo "tap0 ist set" 
scheint die Schnittstelle auch zu funktionieren (Ausgabe gekürzt) ...

Code: Alles auswählen

$ ip -s link show tap0
5: tap0: <BROADCAST,MULTICAST,UP,10000> mtu 1500 qdisc pfifo_fast qlen 500
    link/ether d2:a9:08:bc:a4:69 brd ff:ff:ff:ff:ff:ff
    RX: bytes  packets  errors  dropped overrun mcast
    2682       13       0       0       0       0
    TX: bytes  packets  errors  dropped carrier collsns
    10710      255      0       580     0       0

Code: Alles auswählen

$ ip -s address show tap0
5: tap0: <BROADCAST,MULTICAST,UP,10000> mtu 1500 qdisc pfifo_fast qlen 500
    link/ether d2:a9:08:bc:a4:69 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.21/24 scope global tap0
    inet6 fe80::d0a9:8ff:febc:a469/64 scope link
       valid_lft forever preferred_lft forever

Code: Alles auswählen

$ ip -s route show
192.168.0.0/24 dev tap0  proto kernel  scope link  src 192.168.0.21
Bei dem Interface-Teil in VirtualBox tap0 eingetragen ... meckert VirtalBox auch nicht mehr und startet ganz normal, will aber trotzdem nicht funktionieren ...
Wüsstet ihr eine Fehlermöglichkeit oder (noch besser) eine Lösung?

MfG. Mercedesdriver :)

Werbung:
gameboy
Hacker
Hacker
Beiträge: 794
Registriert: 5. Aug 2005, 10:27
Wohnort: Hessen / MKK

Beitrag von gameboy » 22. Aug 2007, 01:29

Hallo mercedesdriver,

leider schreibst Du nicht, welche Distribution Du als Hostsystem am Laufen hast. Ich habe kürzlich unter Suse 10.2 mit VirtualBox 1.4.0 host interface networking zum Laufen gebracht. In der Hilfe "UserManual.pdf" ist das sehr gut und in einem eigenen Abschnitt (6.5.1.2) speziell für openSUSE erklärt. Ansonsten kann man im IRC Hilfe bekommen: #vbox auf FreeNode.net

Viele Grüße,
gameboy.

b3ll3roph0n
Moderator
Moderator
Beiträge: 3669
Registriert: 4. Dez 2005, 13:17
Kontaktdaten:

Beitrag von b3ll3roph0n » 22. Aug 2007, 03:54

Außerdem lohnt sich ein Blick in diesem Thread:
Qemu, NAT Networking und unverständliches Wiki
(da habe ich Bridged Networking mal für Qemu erläutert - sollte sich auch auf VBox übertragen lassen)
Gruß b3ll3roph0n
--
Denken hilft!

Ich beantworte keine Support-Anfragen per PN.
Für alle meine Beiträge gelten, außer bei Zitaten, die Creative Commons.

mercedesdriver
Hacker
Hacker
Beiträge: 252
Registriert: 4. Feb 2005, 11:47

Beitrag von mercedesdriver » 22. Aug 2007, 22:35

Hallo zusammen,

da kam ja doch noch nach einiger Zeit eine Antowort ...
Also mein System ist ein nettes Debian mit 2.6.21.

Kann die "Lösung" noch nicht ausprobieren, melde mich aber nochmals bei Problemen.

MfG. Mercedesdriver :)

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast