Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Dringend! Server bootet nicht mehr

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
deletemaster
Newbie
Newbie
Beiträge: 36
Registriert: 29. Mai 2007, 12:58
Wohnort: Berlin

Dringend! Server bootet nicht mehr

Beitrag von deletemaster » 5. Jun 2007, 13:13

Bootet nicht!

nach dem Starten des PC erfolgt folgende Meldung auf blauem Hintergrund:

Broken Raid 1
<Auswahl>
Power off and check the failed drive
Destroy the Mirroring Relationship
Choose replacement drive and rebuild
Continue zo boot

Critical Status
A disk member of a mirroring
arrays has failed or is not responding. The array is stilling functional, but fault tolerance is disabled

Remaining Members of the failed array

Channel Serial_Ch1 Master
Drive Samsung
Name HD080HJ
Array Name Array 0
Mode SATA
Size 74,53
Status Broken


Hört sich nicht gut an?

Kann man da was machen?

Bitte, es ist dringend

Danke

Werbung:
Benutzeravatar
panamajo
Guru
Guru
Beiträge: 2587
Registriert: 12. Feb 2005, 22:45

Re: Dringend! Server bootet nicht mehr

Beitrag von panamajo » 5. Jun 2007, 13:29

deletemaster hat geschrieben:Kann man da was machen?
Steht doch da: die kaputte Platte ersetzen.

deletemaster
Newbie
Newbie
Beiträge: 36
Registriert: 29. Mai 2007, 12:58
Wohnort: Berlin

Beitrag von deletemaster » 5. Jun 2007, 13:43

Der Rechner hat 2 Fächer für SATA Platten, welche Platte muss gewechselt werden?
Sind die Daten nach dem Austausch der defekten Platte alle noch da?
Ich weiß nicht welches Raid eingesetzt ist!

Danke für Deine schnelle Hilfe

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 5. Jun 2007, 14:34

Channel Serial_Ch1 Master
wird angemeckert.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

jengelh
Guru
Guru
Beiträge: 4039
Registriert: 20. Nov 2004, 17:42
Kontaktdaten:

Beitrag von jengelh » 5. Jun 2007, 20:51

Ich weiß nicht welches Raid eingesetzt ist!
Steht doch da: RAID1
Sind die Daten nach dem Austausch der defekten Platte alle noch da?
Die sind jetzt auch noch da...

deletemaster
Newbie
Newbie
Beiträge: 36
Registriert: 29. Mai 2007, 12:58
Wohnort: Berlin

Beitrag von deletemaster » 5. Jun 2007, 21:04

Hallo vielen Dank für die Antworten,

habe mir jetzt eine identische Festplatte gekauft (Samsung 80 GB SATA)
Ich habe Ch_0 als "Source" angebeben und Ch_1 als "Ziel" es hat eine Weile gedauert, bis die Daten kopiert waren.
Leider lies sich der Server immer noch nicht starten:
Es erscheint kurz
Startbildschirm von Suse Normal booten oder Failsafe
Beides probiert, er bleibt beim booten irgendwo stehen
Habe beim Eingabe prompt ldeiglich das $
Es sind 8 Benutzer auf diesem Rechner angelegt.
Es existieren Verzeichnisse dessen Daten ich unbedingt sichern muss:
verwaltung
austausch

software

ich habe jetzt erstmal die "Neue" Platte an meinen Rechner mit einem funktionierenden Linux "angeklemmt"
Wie kann ich jetzt ermitteln ob, und welche Daten auf dieser Platte sind UND wie kann ich sie von dort z.B. auf eine (angeschlossene) externe Festplatte (Fat 32 /vfat) kopieren?

Danke für eure Hilfe

jengelh
Guru
Guru
Beiträge: 4039
Registriert: 20. Nov 2004, 17:42
Kontaktdaten:

Beitrag von jengelh » 5. Jun 2007, 22:37

Na wenn du einen RAID-Controller hast, wird der das doch wohl automatisch machen?

Benutzeravatar
panamajo
Guru
Guru
Beiträge: 2587
Registriert: 12. Feb 2005, 22:45

Beitrag von panamajo » 6. Jun 2007, 01:38

deletemaster hat geschrieben:eine (angeschlossene) externe Festplatte (Fat 32 /vfat) kopieren
Wie schon genannt solltest du das RAID1 wieder in Gang setzen (d.h. die redundante Kopie auf der neuen Platte anschmeißen (da kein Info ob Soft/HW Raid keine konkrete Hilfe möglich)).

Zur Frage: FAT ist nicht POSIX kompatibel, d.h. wichtige Metadaten (Benutzerrechte etc.) würden beim kopieren auf eine solche Partition verloren gehen, deshalb unbedingt ein tar Archiv verwenden.

jengelh
Guru
Guru
Beiträge: 4039
Registriert: 20. Nov 2004, 17:42
Kontaktdaten:

Beitrag von jengelh » 7. Jun 2007, 09:51

Ein TAR-Archiv unterstützt aber auch nicht alles... z.B. ACLs.

deletemaster
Newbie
Newbie
Beiträge: 36
Registriert: 29. Mai 2007, 12:58
Wohnort: Berlin

Beitrag von deletemaster » 7. Jun 2007, 10:14

Das Austauschen und neue spiegeln der Platte war nicht so erfolgreich. Wie sich herausgestellt hat, haben die Einschubrahmen für die Platten Kontaktfehler, also keinen Strom. Dadurch ist wohl die Spiegelung während des Betriebes schon fehlgeschlagen, bzw. fehlen DAten. Jetzt lande ich in einer Shell mit nur einem $ als prompt. es wird versucht, daß Verzeichnis /mapping/devices/ zu finden was wohl fehlt....

Rain_Maker

Beitrag von Rain_Maker » 7. Jun 2007, 13:59

Vielleicht solltest Du mal die _URSACHE_ dieses "Absturzes" nennen.

Ach weisst Du was, ich mach das mal für Dich:

http://www.linux-forum.de/showthread.php?t=5638

Interessantes "Detail", oder?

Lösung:

Server ab sofort gegen Umfallen sichern.

Greetz,

RM

deletemaster
Newbie
Newbie
Beiträge: 36
Registriert: 29. Mai 2007, 12:58
Wohnort: Berlin

Beitrag von deletemaster » 7. Jun 2007, 14:10

Genau, das ist die Lösung (für die Zukunft)
Einige haben "ihren" Server in einer sogenannten Abstellkammer..., Kisten, Kartons, Saecke usw. ringsherum "schützen" den Server.

Das Problem ist:
Der Tower hat 2 Einschubschächte (vorn) für die SATA's.
Diese Aluminiumschächte haben an der hinteren Seite die Anschlüsse für SATA und Power
Hier liegt jetzt eine Spannungsunterbrechung vor, d.h. die Platten werden über diese Schächte nicht mehr mit Energie versorgt.
Wenn man die Platten nun aber "direkt" an Board klemmt werden sie erkannt.
Aber evtl. muss diese Stromversorgung vorher schon während des Betriebes unterbrochen worden sein, da ja auf der Mirror-Platte nicht das komplette Abbild steht.
Ich hatte ja versucht, von der Mirror-Platte auf eine neue Platte zu kopieren (Raid-Menü) Worauf das System nicht wieder gestartet wurde, da einige Verzeichnisse nicht gefunden wurden (../mapping devices/...) not found.

Antworten