Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Strato VRoot Server und SQL Update geht nicht

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
sanftermann
Newbie
Newbie
Beiträge: 2
Registriert: 2. Jun 2007, 14:05

Strato VRoot Server und SQL Update geht nicht

Beitrag von sanftermann » 2. Jun 2007, 14:11

Guten Tag

Ich benötige für eine DB Version 4.1.16 oder 5.0.16. Strato stellt aber nur eien Version h1306481:/ # mysql --version
mysql Ver 14.7 Distrib 4.1.10a, for suse-linux (i686) zu Verfügung
Über Yast gibt es auch nicht. Aufd er Seite

http://dev.mysql.com/downloads/mysql/4.1.html
mit

# Linux x86 generic RPM (statically linked against glibc 2.2.5)
# Linux x86 generic RPM (dynamically linked)

kommt die Meldung

h1306481:/ # rpm -i MySQL-server-4.1.22-0.glibc23.i386.rpm
warning: MySQL-server-4.1.22-0.glibc23.i386.rpm: V3 DSA signature: NOKEY, key ID 5072e1f5
file /usr/bin/perror from install of MySQL-server-4.1.22-0.glibc23 conflicts with file from package mysql-client-4.1.10a-3

Kann mir jemand einen Link sagen wo Ich ein Pack bekomme was läuft als Update?

Mfg

Stefan

Werbung:
Benutzeravatar
nbkr
Guru
Guru
Beiträge: 2857
Registriert: 10. Jul 2004, 15:47

Beitrag von nbkr » 2. Jun 2007, 15:02

Die Fehlermeldung sagt das Du das neue Paket nicht installieren kannst weil es einen Konflikt mit der alten MYSQL Version verursacht. Versuchs mal statt mit rpm -i mit rpm -U. Ansonsten lösch das alte Paket einfach raus (Datensicherung nicht vergessen!) .
Kann gar nicht sein, ich bin gefürchtet Wald aus, Wald ein.

sanftermann
Newbie
Newbie
Beiträge: 2
Registriert: 2. Jun 2007, 14:05

Beitrag von sanftermann » 2. Jun 2007, 15:37

nbkr hat geschrieben:Die Fehlermeldung sagt das Du das neue Paket nicht installieren kannst weil es einen Konflikt mit der alten MYSQL Version verursacht. Versuchs mal statt mit rpm -i mit rpm -U. Ansonsten lösch das alte Paket einfach raus (Datensicherung nicht vergessen!) .
Servus

Leider geht es nicht. Ich kann die Alte nicht löschen weil bei Strato das Plesk mit drinnen sitzt welches Ich aber benötige. Ich bin kein Linux User und wäre nicht in der Lage alles auf der Kommando Zeile zu bearbeiten.

Das System was da läuft ist:

Betriebssystem Linux 2.6.9-023stab039.1-smp
Plesk-Version psa v8.1.1_build81070423.15 os_SuSE 9.3
Hostname h1306481.stratoserver.net

h1306481:/ # rpm -U MySQL-server-4.1.22-0.glibc23.i386.rpm
warning: MySQL-server-4.1.22-0.glibc23.i386.rpm: V3 DSA signature: NOKEY, key ID 5072e1f5
file /usr/bin/perror from install of MySQL-server-4.1.22-0.glibc23 conflicts with file from package mysql-client-4.1.10a-3
file /usr/bin/replace from install of MySQL-server-4.1.22-0.glibc23 conflicts with file from package mysql-client-4.1.10a-3
file /usr/share/man/man1/perror.1.gz from install of MySQL-server-4.1.22-0.glibc23 conflicts with file from package mysql-client-4.1.10a-3
file /usr/share/man/man1/replace.1.gz from install of MySQL-server-4.1.22-0.glibc23 conflicts with file from package mysql-client-4.1.10a-3

Antworten