Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Windwos-Partitionen einbinden fehlgeschlagen

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Sanhey
Newbie
Newbie
Beiträge: 7
Registriert: 26. Mai 2007, 08:55

Windwos-Partitionen einbinden fehlgeschlagen

Beitrag von Sanhey » 26. Mai 2007, 09:39

Hallo Linux-Club!

Auf meinem Laptop habe ich insgesamt drei Betriebssystem am Laufen: Windows XP home (SP2) auf den Partitionen hda1 und hda5, Ubuntu (Version weiß ich jetzt nicht - ist hier aber glaub ich irrelevant) müsste auf der hda2 liegen und die restlichen Partitionen sind von Suse Linux 10.0 belegt. Allerdings benutze ich fast ausschließlich Windwos; Ubuntu gar nicht und Linux nur sehr selten (Notfälle).

Folgendes hat die Konsole nach der Eingabe von fdisk -l ausgespuckt:

Code: Alles auswählen

Platte /dev/hda: 40.0 GByte, 40007761920 Byte
255 Köpfe, 63 Sektoren/Spuren, 4864 Zylinder
Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes

   Gerät  boot.     Anfang        Ende     Blöcke   Id  System
/dev/hda1   *           1        1045     8393931    7  HPFS/NTFS
/dev/hda2            1046        3004    15735667+   f  W95 Erw. (LBA)
/dev/hda3            3005        3054      401625   82  Linux Swap / Solaris
/dev/hda4            3055        4864    14538825   83  Linux
/dev/hda5            1046        2717    13430308+   7  HPFS/NTFS
/dev/hda6   *        2718        2987     2168743+  83  Linux
/dev/hda7            2988        3004      136521   82  Linux Swap / Solaris
Mein Problem ist nun, dass vor ein paar Tagen (vermutlich durch einen Trojaner) mein Windwos plattgemacht wurde :x . Das muss ich wohl neu installieren, möchte davor aber noch gerne soweit wie möglich meine Dateien der Windows-Partitionen (hda1 +5) über Linux retten - das müsste doch gehen, oder?
:?:

Wenn ich aber versucht habe über den Arbeitsplatz auf diese Partionen zuzugreifen, kam stets folgende Fehlmeldung und der Zugriff blieb verwehrt:

Code: Alles auswählen

Laufwerk kann nicht eingebunden werden.
Die Fehlermeldung lautet:
mount: wrong fs type, bad option, bad superblock on /dev/hda1,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so
Wie kann ich an meine Daten auf diesen beiden Partitionen rankommen???

Was auch noch dafür wichtig sein könnte: vor einiger Zeit habe ich meine Windows-Partitionen von FAT auf NTFS umgestellt. In diesem Zusammenhang ist mir aufgefallen, dass zwar bei der Eingabe des Befehls fdisk -l die beiden Partitionen schon als Dateisystem NTFS aufgeführt werden (s.o.); allerdings kommen sie in der Datei /etc/fstab noch als VFAT vor:

Code: Alles auswählen

/dev/hda4            /                    reiserfs   acl,user_xattr        1 1
/dev/hda1            /windows/C           vfat       users,gid=users,umask=0002,utf8=true 0 0
/dev/hda5            /windows/D           vfat       users,gid=users,umask=0002,utf8=true 0 0
/dev/hda3            swap                 swap       defaults              0 0
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
/dev/dvd             /media/dvd           subfs      noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/fd0             /media/floppy        subfs      noauto,fs=floppyfss,procuid,nodev,nosuid,sync 0 0
none                 /subdomain       subdomainfs noauto         0 0
Bitte helft mir; ich bin noch absoluter Linux-Beginner! :shock:

Vielen Dank im Voraus! :)

Werbung:
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 26. Mai 2007, 09:49

Dann ändere doch schon mal den Eintrag in der fstab auf ntfs ab.
Steht doch auch schon in der Meldung:
mount: wrong fs type
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

Sanhey
Newbie
Newbie
Beiträge: 7
Registriert: 26. Mai 2007, 08:55

Beitrag von Sanhey » 26. Mai 2007, 21:52

Hallo Grothesk!

jetzt habe ich es hinbekommen und kann auf beide Partitionen zugreifen! Herzlichen Dank! :D

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 26. Mai 2007, 21:58

Allerdings benutze ich fast ausschließlich Windwos; Ubuntu gar nicht und Linux nur sehr selten (Notfälle).
Könntest du aber wohl ändern. Hast jedenfalls eine exzellente Art und Weise, Fragen zu stellen. In der Frage alles relevante drin und verständlichen Text fabriziert. Damit hast du schon mal prima Voraussetzungen, dich durch die ersten Hindernisse erfolgreich durch zu kämpfen.

Viel Spaß, falls du dich entscheiden solltest, Linux intensiver als bisher einzusetzen.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

Sanhey
Newbie
Newbie
Beiträge: 7
Registriert: 26. Mai 2007, 08:55

Beitrag von Sanhey » 30. Mai 2007, 12:41

Danke für das Kompliment :)
Ja, wenn der Computer (inkl. Programme) gut läuft, dann macht es Spaß, aber sich tagelang durch Probleme durchzuschlagen, bis sie behoben sind, das ätzt ziemlich an.

Viele Grüße, Sanhey :wink:

Antworten

Wer ist online?

Mitglieder in diesem Forum: Google [Bot] und 3 Gäste