Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst]Virtual Box und x86_64 System?

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Plato
Member
Member
Beiträge: 169
Registriert: 5. Mai 2006, 23:39

[gelöst]Virtual Box und x86_64 System?

Beitrag von Plato » 24. Mai 2007, 00:25

Hallo, wollte mal Fragen ob es Probleme gibt VirtualBox auf einem x86_64 Open Suse 10.2 laufen zu lassen?

Gruß Gerd
Zuletzt geändert von Plato am 13. Jun 2007, 23:32, insgesamt 1-mal geändert.

Werbung:
Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16599
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 24. Mai 2007, 08:43

Hi
VirtualBox für Mac OS X und 64-Bit-Systeme befindet sich zur Zeit noch im Betastadium und basiert auf der nächsten Version von VirtualBox (1.4).
http://de.wikipedia.org/wiki/VirtualBox

cu[/quote]

}-Tux-{
Moderator
Moderator
Beiträge: 698
Registriert: 12. Dez 2004, 19:54
Kontaktdaten:

Re: Virtual Box und x86_64 System?

Beitrag von }-Tux-{ » 24. Mai 2007, 14:35

Plato hat geschrieben:Hallo, wollte mal Fragen ob es Probleme gibt VirtualBox auf einem x86_64 Open Suse 10.2 laufen zu lassen?

Gruß Gerd
Benutzt du das RPM aus dem BuildService? Falls ja, musst du mit "nmi_watchdog=0" booten. Ansonsten kannst du das Kernel-Module nicht laden.


}-Tux-{

stefan.becker
Advanced Hacker
Advanced Hacker
Beiträge: 1140
Registriert: 12. Mär 2006, 17:23

Re: Virtual Box und x86_64 System?

Beitrag von stefan.becker » 24. Mai 2007, 17:24

}-Tux-{ hat geschrieben:
Plato hat geschrieben:Hallo, wollte mal Fragen ob es Probleme gibt VirtualBox auf einem x86_64 Open Suse 10.2 laufen zu lassen?

Gruß Gerd
Benutzt du das RPM aus dem BuildService? Falls ja, musst du mit "nmi_watchdog=0" booten. Ansonsten kannst du das Kernel-Module nicht laden.


}-Tux-{
Dann läd das Kernelmodul, und dafür stürzt Virtual Box dann ab.

Solange Version 1.40 nicht offiziell raus ist, würde ich die Finger davon lassen.

Die aktuellen 64 Bit Versionen sind im übrigen die OSE Variante, der wesentliche Features fehlen.

Bei 64 Bit Prozessoren mit Virtualisierungstechnik macht KVM eine gute Figur.

Plato
Member
Member
Beiträge: 169
Registriert: 5. Mai 2006, 23:39

Beitrag von Plato » 6. Jun 2007, 19:30

Hallo, VirtualBox 1.4 für 64 Bit Versionen erschienen. Falls es schon jemand in der Mangel hat, würde mich interessieren, ganz allgemein wie es läuft und im speziellen wie es mit USB klappt.

Gruß Gerd

towo
Moderator
Moderator
Beiträge: 3707
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo » 6. Jun 2007, 19:31

Plato hat geschrieben:Hallo, VirtualBox 1.4 für 64 Bit Versionen erschienen. Falls es schon jemand in der Mangel hat, würde mich interessieren, ganz allgemein wie es läuft und im speziellen wie es mit USB klappt.

Gruß Gerd
Und warum probierst Du es nicht selbst aus?
Signatur nach Diktat spazieren gegangen

Bild

Plato
Member
Member
Beiträge: 169
Registriert: 5. Mai 2006, 23:39

Beitrag von Plato » 10. Jun 2007, 15:38

Hab ich ja gemacht, aber.....

also VirtualBox ist installiert, auf 64 Bit SUSE, konnte auch VirtualBox starten und eine vorhandene VMware Partition einbinden (Windows XP) aber beim Start bekomme ich dieese Meldung "

VirtualBox kernel driver not installed. The vboxdrv kernel module was either not loaded or /dev/vboxdrv was not created for some reason. Re-setup the kernel module by executing '/etc/init.d/vboxdrv setup' as root.
VBox status code: -1908 (VERR_VM_DRIVER_NOT_INSTALLED)."

Schon beim Systemstart bekomme ich die Meldung das die

"Starting VirtualBox kernel module FATAL: Error inserting vboxdrv (/lib/modules/2.6.18.8-0.3-default/misc/vboxdrv.ko): Invalid argument
failed
(modprobe vboxdrv failed)

VBox Module nicht geladen werden.

hat jemand eine Idee?

Grüße Gerd

towo
Moderator
Moderator
Beiträge: 3707
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo » 10. Jun 2007, 16:04

Häng als Bootparameter in der menu.lst nmi_watchdog=0 an, dann klappts auch mit dem Laden des Modules.
Signatur nach Diktat spazieren gegangen

Bild

Plato
Member
Member
Beiträge: 169
Registriert: 5. Mai 2006, 23:39

Beitrag von Plato » 10. Jun 2007, 20:34

Danke für den Hinweis, der war genau richtig. Jetzt läufts bis jetzt, wirklich beeindrucken gut.

Unter SUSE 10.2 habe ich noch folgenden Eintrag in der etc/fstab gemacht:

usbfs /proc/bus/usb usbfs devgid=1000,devmode=666 0 0

Bei 1000 muß statt dessen die gid der Gruppe vboxusers eingetragen werden. Dann kann ich unter Windows XP ohne Probleme auf den USB Stick zugreifen, ebnso wie unter dem Host-Betriebssystem.

Ich glaube VMware muß sich warm anziehen.

Viele Grüße
Gerd
Zuletzt geändert von Plato am 13. Jun 2007, 23:30, insgesamt 1-mal geändert.

stefan.becker
Advanced Hacker
Advanced Hacker
Beiträge: 1140
Registriert: 12. Mär 2006, 17:23

Beitrag von stefan.becker » 10. Jun 2007, 22:03

VirtualBox ist schon ganz OK.

Aber derzeit ist VirtualBox ein Golf GTI und VMWARE ein Formel 1 Ferrari.

Wenn man hinter die Kulissen schaut, dann fehlen VirtualBox noch viele Funktionen. Vor allem die Netzwerkfunktionen von VMWARE findet man so nicht.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste