Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Soft-Raid1 lässt sich nicht mehr einhängen: Device busy

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
daiml
Member
Member
Beiträge: 53
Registriert: 9. Okt 2005, 22:43

Soft-Raid1 lässt sich nicht mehr einhängen: Device busy

Beitrag von daiml » 18. Mai 2007, 00:19

Hallo liebe Foren-Mitglieder,

ich melde mich ´mal wieder mit einer (aus einer ganzen Menge von) Katastrophe(n).':oops:'

Ich betreibe in einem privaten Home-Netz einen Linux-Server.
Vor ca. 4 Wochen hatte ich einen Festplattenschaden und musste die Platte ausbauen. Die wichtigen Verzeichnisse - insbesondere /etc und teilweise /var - waren noch i.O. So habe ich mich dann entschlossen, 2 nagelneue identische Festplatten einzubauen und mittels soft-RAID1 ausfallsicher zu spiegeln. Auf einer 3. Platte (nicht identisch und mit 80 GByte wesentlich kleiner) sollen später - wenn alles läuft - zusätzlich Backups der wichtigen Verzeichnisse abgelegt werden.

Habe also dann das System openSuSe 10.2 neu installiert und anschließend mit rsync das noch intakte Verzeichnis /etc und das, was von /var (die mail-ordner) noch brauchbar war, auf die neue Platte geschaufelt.

Dann habe ich mehrere - insgesamt 5 - SoftRaid-Arrays als RAID1 auf den 2 identischen Festplatten angelegt und bin dabei nach der hier gefundenen Anleitung "NonRaid zu (software)Raid1 SuSE 10.1" vorgegangen. Die gespiegelten Partitionen sind ebenfalls identisch.
/dev/md0 = 15 GByte = hda2, hdb2 = /
/dev/md1 = 100 MB = hda1, hdb1 = /boot
/dev/md2 = 10 GByte = hda3, hdb3 = /var
/dev/md3 = 50 GByte = hda5, hdb5 = /home
/dev/md4 = 157.7 GByte = hda6, hdb6 = /share
Die Ausgabe von

Code: Alles auswählen

dvd-server:~ # sfdisk -l
zeigt:
Disk /dev/sda: 268 cylinders, 255 heads, 63 sectors/track
Units = cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0

Device Boot Start End #cyls #blocks Id System
/dev/sda1 0+ 267 268- 2152678+ 82 Linux swap / Solaris
/dev/sda2 0 - 0 0 0 Empty
/dev/sda3 0 - 0 0 0 Empty
/dev/sda4 0 - 0 0 0 Empty

Disk /dev/hda: 30401 cylinders, 255 heads, 63 sectors/track
Units = cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0

Device Boot Start End #cyls #blocks Id System
/dev/hda1 * 0+ 12 13- 104391 fd Linux raid autodetect
/dev/hda2 13 1971 1959 15735667+ fd Linux raid autodetect
/dev/hda3 1972 3277 1306 10490445 fd Linux raid autodetect
/dev/hda4 3278 30400 27123 217865497+ f W95 Ext'd (LBA)
/dev/hda5 3278+ 9805 6528- 52436128+ fd Linux raid autodetect
/dev/hda6 9806+ 30400 20595- 165429306 fd Linux raid autodetect

Disk /dev/hdb: 30401 cylinders, 255 heads, 63 sectors/track
Units = cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0

Device Boot Start End #cyls #blocks Id System
/dev/hdb1 * 0+ 12 13- 104391 fd Linux raid autodetect
/dev/hdb2 13 1971 1959 15735667+ fd Linux raid autodetect
/dev/hdb3 1972 3277 1306 10490445 fd Linux raid autodetect
/dev/hdb4 3278 30400 27123 217865497+ f W95 Ext'd (LBA)
/dev/hdb5 3278+ 9805 6528- 52436128+ fd Linux raid autodetect
/dev/hdb6 9806+ 30400 20595- 165429306 fd Linux raid autodetect

Disk /dev/hdd: 158816 cylinders, 16 heads, 63 sectors/track
Warning: The partition table looks like it was made
for C/H/S=*/255/63 (instead of 158816/16/63).
For this listing I'll assume that geometry.
Units = cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0

Device Boot Start End #cyls #blocks Id System
/dev/hdd1 0+ 9963 9964- 80035798+ 83 Linux
/dev/hdd2 0 - 0 0 0 Empty
/dev/hdd3 0 - 0 0 0 Empty
/dev/hdd4 0 - 0 0 0 Empty

Disk /dev/md0: 3933888 cylinders, 2 heads, 4 sectors/track

sfdisk: ERROR: sector 0 does not have an msdos signature
/dev/md0: unrecognized partition table type
No partitions found

Disk /dev/md1: 26095 cylinders, 2 heads, 4 sectors/track

sfdisk: ERROR: sector 0 does not have an msdos signature
/dev/md1: unrecognized partition table type
No partitions found

Disk /dev/md2: 2622593 cylinders, 2 heads, 4 sectors/track

sfdisk: ERROR: sector 0 does not have an msdos signature
/dev/md2: unrecognized partition table type
No partitions found

Disk /dev/md3: 13109014 cylinders, 2 heads, 4 sectors/track

sfdisk: ERROR: sector 0 does not have an msdos signature
/dev/md3: unrecognized partition table type
No partitions found

Disk /dev/md4: 41357308 cylinders, 2 heads, 4 sectors/track

sfdisk: ERROR: sector 0 does not have an msdos signature
/dev/md4: unrecognized partition table type
No partitions found
... und von mount:
/dev/md0 on / type ext3 (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/md1 on /boot type ext2 (rw,acl,user_xattr)
/dev/md2 on /var type ext3 (rw,acl,user_xattr)
/dev/md3 on /home type ext3 (rw,acl,user_xattr)
/dev/md4 on /share type ext3 (rw,acl,user_xattr)
/dev/hdd1 on /backup type ext3 (rw,acl,user_xattr)
securityfs on /sys/kernel/security type securityfs (rw)
capifs on /dev/capi type capifs (rw,mode=0666)
nfsd on /proc/fs/nfsd type nfsd (rw)
/dev/sr0 on /media/SU1020.005 type iso9660 (ro,nosuid,nodev,noatime,uid=0,utf8)
Die Raids hatten bis vor 2 Tagen auch einwandfrei funktioniert.
Nun habe ich vorgestern die "Alarm-Mail" erhalten, dass in allen RAID-Arrays md0, md1, md2, md3 u. md4 Fehler aufgetreten sind ... die Ursache ist mir bisher noch nicht bekannt.
Nach einer Überprüfung mit

Code: Alles auswählen

mdadm -D /dev/md0
mdadm -D /dev/md1
mdadm -D /dev/md2
mdadm -D /dev/md3
mdadm -D /dev/md4 
stellte ich fest, dass die in allen RAID-Arrays die betreffende Pertition der 2. Platte /dev/hdb auf removed und faulty spare gesetzt war.
Also habe ich nach den beiden in der Wiki gefundenen Anleitungen angefangen die betreffenden Partitionen wieder in die Raid-Arrays einzuhängen und dabei mit md0 angefangen

Code: Alles auswählen

 mdadm /dev/md0 -a /dev/hdb2 
anschließend hatte ich wieder ein funktionierendes RAID1 auf md0 :D

Code: Alles auswählen

 /dev/md0:
        Version : 00.90.03
  Creation Time : Tue May  1 22:04:12 2007
     Raid Level : raid1
     Array Size : 15735552 (15.01 GiB 16.11 GB)
    Device Size : 15735552 (15.01 GiB 16.11 GB)
   Raid Devices : 2
  Total Devices : 2
Preferred Minor : 0
    Persistence : Superblock is persistent

    Update Time : Thu May 17 19:59:35 2007
          State : clean
 Active Devices : 2
Working Devices : 2
 Failed Devices : 0
  Spare Devices : 0

           UUID : 45b90649:48e79bf2:a577c7b3:112e33a1
         Events : 0.200400

    Number   Major   Minor   RaidDevice State
       0       3        2        0      active sync   /dev/hda2
       1       3       66        1      active sync   /dev/hdb2 
Das Einhängen funktionierte aber nicht bei den übrigen Partitionen.
Also habe ich die betreffenden Partitionen auf hdb zunächst mit

Code: Alles auswählen

dvd-server:~ # mdadm /dev/md2 -r /dev/hdb3
mdadm: hot removed /dev/hdb3
dvd-server:~ # mdadm /dev/md2 -a /dev/hdb3
mdadm: added /dev/hdb3
dvd-server:~ # mdadm --detail /dev/md2 
erhalte dann aber trotzdem diese Statusanzeige:

Code: Alles auswählen

/dev/md2:
        Version : 01.00.03
  Creation Time : Tue May  1 23:38:18 2007
     Raid Level : raid1
     Array Size : 10490372 (10.00 GiB 10.74 GB)
    Device Size : 20980744 (10.00 GiB 10.74 GB)
   Raid Devices : 2
  Total Devices : 2
Preferred Minor : 2
    Persistence : Superblock is persistent

  Intent Bitmap : Internal

    Update Time : Thu May 17 20:07:05 2007
          State : active, degraded
 Active Devices : 1
Working Devices : 1
 Failed Devices : 1
  Spare Devices : 0

           Name : 2
           UUID : 4c11f93d:17bf066d:ff06abd9:6906a379
         Events : 244964

    Number   Major   Minor   RaidDevice State
       2       3        3        0      active sync   /dev/hda3
       1       0        0        1      removed

       1       3       67        -      faulty spare   /dev/hdb3 
Die Partitionen hdb1, hdb3, hdb5 und hdb6 stehen weiterhin auf removed und faulty spare - sie werden nicht mehr synchronisiert...
... und nunmehr kann ich die RAID-Arrays md1 ... md4 auch nicht mehr aushängen.
Während md0 einwandfrei funktioniert, erhalte ich bei md1, md2, md3 und md4 diese Meldung:

Code: Alles auswählen

 dvd-server:~ # mdadm /dev/md1 -r /dev/hdb1
mdadm: hot remove failed for /dev/hdb1: Device or resource busy
dvd-server:~ # mdadm /dev/md1 -a /dev/hdb1
mdadm: Cannot open /dev/hdb1: Device or resource busy 
Nach 2 Tagen erfolglosem Googlen, Lesen und Suchen gebe ich meinen Ehrgeiz, den Fehler selbst finden zu können auf und bitte ich Euch um Hilfe: :oops:

- Wie bekomme ich nun diese -4- Partitionen wieder in´s SoftRaid ?
- Wie kann ich die Platte hdb überprüfen ?


System: openSuSe Linux 10.2

Gruß daiml
Zuletzt geändert von daiml am 13. Jan 2012, 15:16, insgesamt 1-mal geändert.

Werbung:
jengelh
Guru
Guru
Beiträge: 4039
Registriert: 20. Nov 2004, 17:42
Kontaktdaten:

Beitrag von jengelh » 20. Mai 2007, 13:48

Wie haben die überhaupt ihren Weg raus gefunden? Platte kaputt?

Code: Alles auswählen

dvd-server:~ # mdadm /dev/md1 -r /dev/hdb1
mdadm: hot remove failed for /dev/hdb1: Device or resource busy
dvd-server:~ # mdadm /dev/md1 -a /dev/hdb1
mdadm: Cannot open /dev/hdb1: Device or resource busy
also scheint sie jemand anders zu verwenden... `cat /proc/mounts` könnte ein Anfang sein.

daiml
Member
Member
Beiträge: 53
Registriert: 9. Okt 2005, 22:43

Beitrag von daiml » 20. Mai 2007, 14:10

Hallo "jengelh",
jengelh hat geschrieben:Wie haben die überhaupt ihren Weg raus gefunden? Platte kaputt?
das habe ich bisher nicht klären können.
Ich habe eben noch einmal die partition hdb1 ausgehängt

Code: Alles auswählen

dvd-server:~ # mdadm /dev/md1 -r /dev/hdb1
mdadm: hot removed /dev/hdb1
und mit fsck überprüft:

Code: Alles auswählen

dvd-server:~ # fsck.ext3 /dev/hdb1
e2fsck 1.39 (29-May-2006)
/dev/hdb1 was not cleanly unmounted, check forced.
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
/dev/hdb1: 52/26104 files (7.7% non-contiguous), 20665/104380 blocks
:?
also noch einmal überprüft:

Code: Alles auswählen

dvd-server:~ # fsck.ext3 /dev/hdb1
e2fsck 1.39 (29-May-2006)
/dev/hdb1: clean, 52/26104 files, 20665/104380 blocks
na also, hoffentlich lässt sich diese Partition jetzt wieder in´s Raid einhängen

Code: Alles auswählen

dvd-server:~ # mdadm /dev/md1 -a /dev/hdb1
mdadm: added /dev/hdb1
:)
nun noch einmal den Status der Synchronisierung überprüft ...
dvd-server:~ # mdadm --detail /dev/md1
/dev/md1:
Version : 01.00.03
Creation Time : Tue May 1 23:37:39 2007
Raid Level : raid1
Array Size : 104380 (101.95 MiB 106.89 MB)
Device Size : 104380 (101.95 MiB 106.89 MB)
Raid Devices : 2
Total Devices : 2
Preferred Minor : 1
Persistence : Superblock is persistent

Intent Bitmap : Internal

Update Time : Sun May 20 13:49:51 2007
State : active, degraded
Active Devices : 1
Working Devices : 1
Failed Devices : 1
Spare Devices : 0

Name : 1
UUID : 19458359:08d9b62e:1be83101:fc215860
Events : 182

Number Major Minor RaidDevice State
2 3 1 0 active sync /dev/hda1
1 0 0 1 removed

1 3 65 - faulty spare /dev/hdb1
:evil:
WARUM ?????
dvd-server:~ # mdadm /dev/md1 -r /dev/hdb1
mdadm: hot remove failed for /dev/hdb1: Device or resource busy
dvd-server:~ # mdadm /dev/md1 -a /dev/hdb1
mdadm: Cannot open /dev/hdb1: Device or resource busy

also scheint sie jemand anders zu verwenden... `cat /proc/mounts` könnte ein Anfang sein.
hab ich sofort versucht, aber nichts auffälliges entdeckt .. hab ich ´was übersehen ?

Code: Alles auswählen

dvd-server:~ # cat /proc/mounts
rootfs / rootfs rw 0 0
udev /dev tmpfs rw 0 0
/dev/md0 / ext3 rw,data=ordered 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
debugfs /sys/kernel/debug debugfs rw 0 0
devpts /dev/pts devpts rw 0 0
/dev/md1 /boot ext2 rw 0 0
/dev/md2 /var ext3 rw,data=ordered 0 0
/dev/md3 /home ext3 rw,data=ordered 0 0
/dev/md4 /share ext3 rw,data=ordered 0 0
/dev/hdd1 /backup ext3 rw,data=ordered 0 0
securityfs /sys/kernel/security securityfs rw 0 0
capifs /dev/capi capifs rw 0 0
nfsd /proc/fs/nfsd nfsd rw 0 0 
Ein Plattenfehler würde mich schon sehr wundern; schließlich sind diese beiden Platten nagelneu ... obwohl mich in der Geschichte der Server-Installation und -Pflege eingentlich nichts mehr wundern oder schocken dürfte :(

noch irgendeine Idee?

carsten
Guru
Guru
Beiträge: 1632
Registriert: 27. Jan 2004, 13:27
Wohnort: Mittelhessen

Beitrag von carsten » 20. Mai 2007, 14:25

der Parameter -a ist was anderes als das, was du willst. Damit legst du ein neues Device an und deins gibt es schon.
Probiers mal mit --add

Nachtrag: Hmmm, weiter unten stehts mit -a
Wie wärs mit --re-add?

Quelle: man mdadm

Grüße
Intel DB65ALB3, Chipsatz B65, Celeron G540, 4GB, 1x1TB System, 2x 2TB SATA RAID1, SuSE 13.2 (noch)

daiml
Member
Member
Beiträge: 53
Registriert: 9. Okt 2005, 22:43

Beitrag von daiml » 20. Mai 2007, 14:49

carsten hat geschrieben: Wie wärs mit --re-add?

Quelle: man mdadm

Grüße
hallo Carster,

Ich hab´s eben mit --re-add versucht... seht selbst:

Code: Alles auswählen

dvd-server:~ # mdadm --re-add /dev/md1
Der befel wird angenommen, jedoch erfolgt keine keine Ausgabe, ob es denn auch geklappt hat. Also hab ich´s noch einmal überprüft:

Code: Alles auswählen

dvd-server:~ # mdadm --detail /dev/md1
/dev/md1:
        Version : 01.00.03
  Creation Time : Tue May  1 23:37:39 2007
     Raid Level : raid1
     Array Size : 104380 (101.95 MiB 106.89 MB)
    Device Size : 104380 (101.95 MiB 106.89 MB)
   Raid Devices : 2
  Total Devices : 1
Preferred Minor : 1
    Persistence : Superblock is persistent

  Intent Bitmap : Internal

    Update Time : Sun May 20 14:34:21 2007
          State : active, degraded
 Active Devices : 1
Working Devices : 1
 Failed Devices : 0
  Spare Devices : 0

           Name : 1
           UUID : 19458359:08d9b62e:1be83101:fc215860
         Events : 198

    Number   Major   Minor   RaidDevice State
       2       3        1        0      active sync   /dev/hda1
       1       0        0        1      removed
also - es hat nicht geklappt mit dem Einhängen.
Mit -a hingegen wird die Partition ins RAID eingehängt ... jedoch :

Code: Alles auswählen

dvd-server:~ # mdadm /dev/md1 -a /dev/hdb1
mdadm: added /dev/hdb1
dvd-server:~ # mdadm --detail /dev/md1
/dev/md1:
        Version : 01.00.03
  Creation Time : Tue May  1 23:37:39 2007
     Raid Level : raid1
     Array Size : 104380 (101.95 MiB 106.89 MB)
    Device Size : 104380 (101.95 MiB 106.89 MB)
   Raid Devices : 2
  Total Devices : 2
Preferred Minor : 1
    Persistence : Superblock is persistent

  Intent Bitmap : Internal

    Update Time : Sun May 20 14:34:21 2007
          State : active, degraded
 Active Devices : 1
Working Devices : 1
 Failed Devices : 1
  Spare Devices : 0

           Name : 1
           UUID : 19458359:08d9b62e:1be83101:fc215860
         Events : 198

    Number   Major   Minor   RaidDevice State
       2       3        1        0      active sync   /dev/hda1
       1       0        0        1      removed

       1       3       65        -      faulty spare   /dev/hdb1
:twisted:
... wieder mit einem inkonsitenten Raid ... das ist zum K****N :twisted:

Gruß daiml
Zuletzt geändert von daiml am 13. Jan 2012, 15:17, insgesamt 1-mal geändert.

daiml
Member
Member
Beiträge: 53
Registriert: 9. Okt 2005, 22:43

Beitrag von daiml » 20. Mai 2007, 17:08

Hallo liebe Foren-Mitglieder,

auch wenn´s ein ganz schöner Brocken ist, ...
ich habe die Meldung von dmesg gefiltert und stelle hier die Boot-Meldungen ein. Offenbar wird das RAID md0 ordnunggemäß in Betrieb genommen, jedoch werden die RAIDs
- md1
- md2
- md3
- md4
"gekickt" :cry:
Damit diese Ausgabe hier nicht z ulang wird, habe ich m.E. unrelevante Passagen gelöscht und durch 3 Punkt "..." ersetzt.

Code: Alles auswählen

Linux version 2.6.18.8-0.1-default (geeko@buildhost) (gcc version 4.1.2 20061115 (prerelease) (SUSE Linux)) #1 SMP Fri Mar 2 13:51:59 UTC 2007
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
 BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000d2000 - 00000000000d8000 (reserved)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000002fff0000 (usable)
 BIOS-e820: 000000002fff0000 - 000000002fff8000 (ACPI data)
 BIOS-e820: 000000002fff8000 - 0000000030000000 (ACPI NVS)
 BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)
 BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
 BIOS-e820: 00000000fff80000 - 0000000100000000 (reserved)
0MB HIGHMEM available.
767MB LOWMEM available.
On node 0 totalpages: 196592
  DMA zone: 4096 pages, LIFO batch:0
  Normal zone: 192496 pages, LIFO batch:31
DMI 2.3 present.
...
Detected 1447.359 MHz processor.
...
Kernel command line: root=/dev/md0 vga=0x317 resume=/dev/sad1 splash=silent
...
md: md driver 0.90.3 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: bitmap version 4.39
...
SCSI device sda: 4308352 512-byte hdwr sectors (2206 MB)
sda: Write Protect is off
sda: Mode Sense: c8 00 10 08
SCSI device sda: drive cache: write through w/ FUA
SCSI device sda: 4308352 512-byte hdwr sectors (2206 MB)
sda: Write Protect is off
sda: Mode Sense: c8 00 10 08
SCSI device sda: drive cache: write through w/ FUA
 sda: sda1
sd 0:0:1:0: Attached scsi disk sda
sd 0:0:1:0: Attached scsi generic sg0 type 0
  Vendor: TEAC      Model: CD-ROM CD-532S    Rev: 1.0A
  sr0: scsi3-mmc drive: 0x/0x caddy
  Uniform CD-ROM driver Revision: 3.20
  sr 0:0:3:0: Attached scsi CD-ROM sr0
...
VP_IDE: IDE controller at PCI slot 0000:00:11.1
ACPI: Unable to derive IRQ for device 0000:00:11.1
ACPI: PCI Interrupt 0000:00:11.1[A]: no GSI
PCI: VIA IRQ fixup for 0000:00:11.1, from 255 to 15
VP_IDE: chipset revision 6
VP_IDE: not 100% native mode: will probe irqs later
VP_IDE: VIA vt8235 (rev 00) IDE UDMA133 controller on pci0000:00:11.1
    ide0: BM-DMA at 0xfc00-0xfc07, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xfc08-0xfc0f, BIOS settings: hdc:DMA, hdd:DMA
Probing IDE interface ide0...
hda: ST3250623A, ATA DISK drive
hdb: ST3250623A, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hda: max request size: 512KiB
hda: 488397168 sectors (250059 MB) w/16384KiB Cache, CHS=30401/255/63, UDMA(100)
hda: cache flushes supported
 hda: hda1 hda2 hda3 hda4 < hda5 hda6 >
hdb: max request size: 512KiB
hdb: 488397168 sectors (250059 MB) w/16384KiB Cache, CHS=30401/255/63, UDMA(100)
hdb: cache flushes supported
 hdb: hdb1 hdb2 hdb3 hdb4 < hdb5 hdb6 >
Probing IDE interface ide1...
hdc: Hewlett-Packard CD-Writer Plus 9300, ATAPI CD/DVD-ROM drive
hdd: Maxtor 6Y080P0, ATA DISK drive
ide1 at 0x170-0x177,0x376 on irq 15
hdd: max request size: 128KiB
hdd: 160086528 sectors (81964 MB) w/7936KiB Cache, CHS=65535/16/63, UDMA(133)
hdd: cache flushes supported
 hdd: hdd1
BIOS EDD facility v0.16 2004-Jun-25, 4 devices found
md: raid0 personality registered for level 0
md: raid1 personality registered for level 1
...
md: md0 stopped.
md: bind<hdb2>
md: bind<hda2>
raid1: raid set md0 active with 2 out of 2 mirrors
kjournald starting.  Commit interval 5 seconds
EXT3 FS on md0, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
parport: PnPBIOS parport detected.
parport0: PC-style at 0x378 (0x778), irq 7, dma 0 [PCSPP,TRISTATE,COMPAT,EPP,ECP,DMA]
lp0: using parport0 (interrupt-driven).
...
agpgart: Detected VIA KT400/KT400A/KT600 chipset
...
Adding 2152668k swap on /dev/sda1.  Priority:-1 extents:1 across:2152668k
...
md: md1 stopped.
md: bind<hdb1>
md: bind<hda1>
md: kicking non-fresh hdb1 from array!
md: unbind<hdb1>
md: export_rdev(hdb1)
raid1: raid set md1 active with 1 out of 2 mirrors
md1: bitmap initialized from disk: read 1/1 pages, set 1834 bits, status: 0
created bitmap (4 pages) for device md1
md: md2 stopped.
md: bind<hdb3>
md: bind<hda3>
md: kicking non-fresh hdb3 from array!
md: unbind<hdb3>
md: export_rdev(hdb3)
raid1: raid set md2 active with 1 out of 2 mirrors
md2: bitmap initialized from disk: read 1/1 pages, set 875 bits, status: 0
created bitmap (3 pages) for device md2
md: md3 stopped.
md: bind<hdb5>
md: bind<hda5>
md: kicking non-fresh hdb5 from array!
md: unbind<hdb5>
md: export_rdev(hdb5)
raid1: raid set md3 active with 1 out of 2 mirrors
md3: bitmap initialized from disk: read 1/1 pages, set 72 bits, status: 0
created bitmap (4 pages) for device md3
md: md4 stopped.
md: bind<hdb6>
md: bind<hda6>
md: kicking non-fresh hdb6 from array!
md: unbind<hdb6>
md: export_rdev(hdb6)
raid1: raid set md4 active with 1 out of 2 mirrors
md4: bitmap initialized from disk: read 1/1 pages, set 61 bits, status: 0
created bitmap (5 pages) for device md4
loop: loaded (max 8 devices)
kjournald starting.  Commit interval 5 seconds
EXT3 FS on md2, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on md3, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on md4, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on hdd1, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
...
... SFW2- ...
md: unbind<hdb1>
md: export_rdev(hdb1)
... SFW2- ...
md: unbind<hdb1>
md: export_rdev(hdb1)
md: bind<hdb1>
md: unbind<hdb3>
md: export_rdev(hdb3)
md: bind<hdb3>
... SFW2- ...
md: unbind<hdb3>
md: export_rdev(hdb3)
md: bind<hdb3>
... SFW2- ...
md: unbind<hdb5>
md: export_rdev(hdb5)
md: unbind<hdb6>
md: export_rdev(hdb6)
md: bind<hdb5>
md: bind<hdb6>
... SFW2- ...
md: unbind<hdb1>
md: export_rdev(hdb1)
md: unbind<hdb3>
md: export_rdev(hdb3)
... SFW2- ...
md: unbind<hdb5>
md: export_rdev(hdb5)
md: unbind<hdb6>
md: export_rdev(hdb6)
md: bind<hdb1>
md: bind<hdb3>
... SFW2- ...
md: bind<hdb5>
md: bind<hdb6>
... SFW2- ...
md: unbind<hdb6>
md: export_rdev(hdb6)
md: bind<hdb6>
... SFW2- ... 
Bitte ... hilfeeeeeee :cry:

Gruß daiml
Zuletzt geändert von daiml am 13. Jan 2012, 15:17, insgesamt 1-mal geändert.

jengelh
Guru
Guru
Beiträge: 4039
Registriert: 20. Nov 2004, 17:42
Kontaktdaten:

Beitrag von jengelh » 20. Mai 2007, 23:13

hendrix hat geschrieben:Hallo "jengelh",
Wieso stehe ich in Anführungszeichen?
das habe ich bisher nicht klären können.
Das steht normalerweise in `dmesg` bzw. /var/log/messages (abzüglich der md: bind und md: unbind Meldungen).
Ich habe eben noch einmal die partition hdb1 ausgehängt

Code: Alles auswählen

dvd-server:~ # mdadm /dev/md1 -r /dev/hdb1
mdadm: hot removed /dev/hdb1
und mit fsck überprüft:

Code: Alles auswählen

dvd-server:~ # fsck.ext3 /dev/hdb1[/quote]
Das bringt's generell nicht, da hdb1 eine RAID-Partition ist, das Filesystem findest du garantiert nur auf mdX. ("Garantiert" heißt: normalerweise ist der RAID-Superblock am Ende der hdb1-Partition; aber es gibt auch ein Layout wo er am Anfang ist, und dann würde fsck nicht gehen. Daher ist nur auf mdX garantiert, dass das Filesystem bei Position 0 anfängt.)
[quote]e2fsck 1.39 (29-May-2006)
/dev/hdb1 was not cleanly unmounted, check forced.[/quote]
Nein, probier lieber `badblocks -v /dev/hdb1`.
Aber:
[quote][code]
md: kicking non-fresh hdb1 from array!
Is nich frisch! ("Mein Fisch ist frisch!") Was immer das sein mag..
http://lkml.org/lkml/2002/10/11/31
Generell sollte da das erste Device beim Resync als Source herhalten, aber eine Garantie gebe ich bei --force nicht.

daiml
Member
Member
Beiträge: 53
Registriert: 9. Okt 2005, 22:43

Beitrag von daiml » 25. Mai 2007, 13:49

Wieso stehe ich in Anführungszeichen?
Das ist eine Angewohnheit von mir, Synonyme beim Anschreiben besonders hervorzuheben. Und auch wenn "jengelh" mit Deinem Namen zu tun haben möge, dann ist es doch ein Synonym. Vielleicht auch Geschmackssache ...
Nein, probier lieber `badblocks -v /dev/hdb1`.
Habe ich gemacht.
Da ich keine Ahnung hatte, wie gründlich und ausdauernd so eine badblock-Suche auf einer 250-GByte-Platte sein kann, habe ich lange gezögert, den Rechner zu unterbrechen ...
... gestern Abend, als ich von der Arbeit nach Hause kam, hielt ich die verstrichene Zeit von ca. 30 Stunden ohne eine Ausgabe am Prompt dann aber doch für etwas übertrieben und habe diesen Prozess abgebrochen.

Anschließend habe ich dann von einer Knoppix-CD gebootet und nachdem ich festgestellt hatte, dass auf hdb die primäre Partition hdb3 und die logischen Partitionen hdb5 und hdb6 nicht mehr vorhanden waren, meine Datenpartitionen von der 1. Platte (hda) auf einer weiteren Platte gesichert und die die Kiste anschließend gnadenlos geplättet.

Mein geschildertes Problem konnte insofern nicht gelöst werden.
Die Probleme, die ich schon beim ersten Booten nach der Neuinstallation hatte, stelle ich in einem neuen thread ein ...

daiml

M•O•D
Newbie
Newbie
Beiträge: 26
Registriert: 7. Nov 2011, 18:47
Wohnort: Third rock from sun!

[HILFE] Soft-Raid1 2te Pladde lässt sich nicht mehr einhänge

Beitrag von M•O•D » 5. Jul 2013, 05:01

Hi!

Ich habe brandaktuell genau das beschriebene Problem.
Gibt es hierzu neuere Erkenntnisse?


Gruss.

Benutzeravatar
robi
Moderator
Moderator
Beiträge: 3159
Registriert: 25. Aug 2004, 02:13

Re: [HILFE] Soft-Raid1 2te Pladde lässt sich nicht mehr einh

Beitrag von robi » 5. Jul 2013, 10:57

M•O•D hat geschrieben: Ich habe brandaktuell genau das beschriebene Problem.
Gibt es hierzu neuere Erkenntnisse?
Ja : du kannst hier bei einem solchem komplexen Problem nicht einfach behaupten du hast genau das selbe Problem und dafür einen 6 Jahre alten Thread kapern.

Mach einen neuen auf, und liefere dort deine aktuellen Fehler und Konfigurationen.

robi

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast