Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] Steam und Wine: Problem

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
branleb
Newbie
Newbie
Beiträge: 6
Registriert: 26. Mär 2007, 14:51
Kontaktdaten:

[gelöst] Steam und Wine: Problem

Beitrag von branleb » 26. Mär 2007, 15:12

Hi
ich hab ein kleines Problem mit Steam und WINE.
Ich habs nach der Anleitung hier im Forum installiert, aber es will einfach nicht richtig :'( .
Die Installation selbst verlief problemlos, aber wenn ich Steam starte (in einem Virtuellen Desktop)
kommt zwar das Login Fenster aber wenn ich da meinen Namen und mein password eingebe
dann sagt er auch "Logging into Steam..." und dann kommt in der GUI diese Meldung:

Code: Alles auswählen

Steam.exe(main exception): Win32 Structured Exception at65C8EC6A:
Attempt to read from Virtual Adress 0 without appriorate acces rights.
Das ist die Ausgabe in der Konsole:

Code: Alles auswählen

shade37337@localhost:~/.wine/drive_c/Programme/Steam>  wine Steam.exe
fixme:process:IsWow64Process (0xffffffff 0x3c7e4c) stub!
fixme:shdocvw:ViewObject_SetAdvise (0xd818708)->(1 00000002 0x1152b78)
fixme:shdocvw:PersistStreamInit_InitNew (0xd818708)
fixme:shdocvw:WebBrowser_put_RegisterAsBrowser (0xd818708)->(ffffffff)
fixme:shdocvw:WebBrowser_put_RegisterAsDropTarget (0xd818708)->(ffffffff)
err:mshtml:init_nsio Could not get factory: 80040154
Shutting down. . .
300client callback thread error
Mein System:
openSuSE 10.2/KDE mit allen YOU updates
WINE 0.9.33
Steam von heute (26/03/2007), ist inzwischen ein .msi packet.

AMD Athlon64 X2 5000+
2 GB DDR-2 RAM
ATI Radeon X1800GTP mit fglrx driver 8.34.6
ASUS M2N-E

Kann mir jemand helfen bzw. Tipps geben ?
It's not a Bug. It's a Feature!

Werbung:
K4m1K4tz3
Advanced Hacker
Advanced Hacker
Beiträge: 987
Registriert: 19. Jan 2005, 13:54
Kontaktdaten:

Beitrag von K4m1K4tz3 » 26. Mär 2007, 16:42

Bist du dir sicher, dass du/Wine Schreibrechte in dem Steam-Ordner hat, bzw. bei den Dateien?
Mein System: SUSE 11.4, x86_64, KDE 4.6

Mein Jabber: masterunderlined@jabber.ccc.de

branleb
Newbie
Newbie
Beiträge: 6
Registriert: 26. Mär 2007, 14:51
Kontaktdaten:

Beitrag von branleb » 26. Mär 2007, 16:46

wine läuft doch unter meiner UID oder?
und Steam ist in meinem Home... unter .wine/drive_c/ .......
ich hab grad nochmal nachgesehen, aber ich hab rw rechte darauf ...
ich kann das dir-listing posten, aber das mach ich erstmal nicht, wär Viiieel Text, oder will es jemand sehen ?
It's not a Bug. It's a Feature!

Bajer
Newbie
Newbie
Beiträge: 33
Registriert: 16. Jan 2007, 21:18
Kontaktdaten:

Beitrag von Bajer » 13. Apr 2007, 20:42

Hi,
das selbe Problem hatte ich auch mal, ich würde es mit der älteren wineversion 0.9.17 probieren, und schritt für schritt das durcharbeiten, dann dürfte es funktionieren.

part1san
Newbie
Newbie
Beiträge: 17
Registriert: 27. Nov 2006, 14:51

Beitrag von part1san » 14. Apr 2007, 00:00

Ich habe die letzte Wineversion 0.9.34 genommen, Doppelklick auf die setup.exe der DVD und wie bei windows installiert, außer das ich mir diesen
tahoma-font noch raufschmeissen musste.
Ansonsten ließ sich das out of the box installieren.
clan: www.zoffclan.de
System: AMD64 3000+ Clawhammer @2,4 GHZ
Ram 1,5GB, nvidia 7900 GS, ASUS K8N4-E (S.754), SUSE 10.0 OSS

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16599
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 14. Apr 2007, 08:50

Hi

Bajer hat Recht nimm eine ältere Version am besten wie bei Holarse beschrieben. :wink:

cu

K4m1K4tz3
Advanced Hacker
Advanced Hacker
Beiträge: 987
Registriert: 19. Jan 2005, 13:54
Kontaktdaten:

Beitrag von K4m1K4tz3 » 14. Apr 2007, 11:51

Vielleicht auch die Steam-Version von der Homepage von Valve benutzen. Da wird ja immer gern viel verändert.
Mein System: SUSE 11.4, x86_64, KDE 4.6

Mein Jabber: masterunderlined@jabber.ccc.de

branleb
Newbie
Newbie
Beiträge: 6
Registriert: 26. Mär 2007, 14:51
Kontaktdaten:

Re: Steam und Wine: Problem

Beitrag von branleb » 14. Apr 2007, 14:19

shade37337 hat geschrieben: [...]

Code: Alles auswählen

fixme:shdocvw:WebBrowser_put_RegisterAsDropTarget (0xd818708)->(ffffffff)
err:mshtml:init_nsio Could not get factory: 80040154
Shutting down. . .
300client callback thread error
[...]
Ich habs inzwischen gelöst:
Es lag an der HTML kompenente (s.o.) der absturz wurde von nsio hervorgerufen, ns is das std-mozilla-prefix, io = input/output, also die html kompo hatte ein problem: hab sie gelöscht, deregistert, usw und den MSHTML zweig in der registry gelöscht, seit daher lauft steam problemlos, cs kackt manchmal ab, i-wie hat msvc runtime probleme....
It's not a Bug. It's a Feature!

derMani
Hacker
Hacker
Beiträge: 661
Registriert: 7. Jun 2004, 22:23
Wohnort: Papenburg
Kontaktdaten:

Beitrag von derMani » 14. Apr 2007, 15:13

Dann markiere ich das hier mal als gelöst ;-)
Andrew S. Tanenbaum: The nice thing about
standards is that you have so many to choose from.
Furthermore, if you dont’t like any of them, you can
just wait for next year’s model.


Linux-Club Wiki
Howtos, Tipps uvm.
http://wiki.linux-club.de/

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste