Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

ext2 mit exec statt noexec mounten

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
pospiech
Hacker
Hacker
Beiträge: 250
Registriert: 19. Mai 2005, 22:52

ext2 mit exec statt noexec mounten

Beitrag von pospiech » 25. Mär 2007, 20:20

/etc/fstab enthält den Eintrag

/dev/hdb2 /mnt/hdb2 ext3 noauto,exec,user,acl 1 2

gemountet ist jedoch mit

/dev/hdb2 on /mnt/hdb2 type ext3 (rw,noexec,nosuid,nodev,acl,user=matthias)

also mit noexec statt dem angegebenen exec.

Was muss ich ändern um das richtig zu bekommen? System ist 10.2
Matthias

Werbung:
admine
Administrator
Administrator
Beiträge: 8757
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Beitrag von admine » 25. Mär 2007, 20:35

Code: Alles auswählen

mount -o remount /mnt/hdb2
remountet diese Partition mit den Optionen aus der fstab.
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

pospiech
Hacker
Hacker
Beiträge: 250
Registriert: 19. Mai 2005, 22:52

Beitrag von pospiech » 25. Mär 2007, 23:50

admine hat geschrieben:

Code: Alles auswählen

mount -o remount /mnt/hdb2
remountet diese Partition mit den Optionen aus der fstab.
Ich habe das System mit diesen Optionen neu gestartet und das Ergebnis ist das obig geschilderte.

Matthias

b3ll3roph0n
Moderator
Moderator
Beiträge: 3669
Registriert: 4. Dez 2005, 13:17
Kontaktdaten:

Beitrag von b3ll3roph0n » 26. Mär 2007, 02:55

man mount

Code: Alles auswählen

 user   Allow an ordinary user to mount the file system.  The name of the mounting user is written to mtab so that he can unmount  the  file
                     system  again.  This option implies the options noexec, nosuid, and nodev (unless overridden by subsequent options, as in the option
                     line user,exec,dev,suid).
Die Option user beinhaltet noexec - die Option exec muss also in der /etc/fstab hinter user.
Gruß b3ll3roph0n
--
Denken hilft!

Ich beantworte keine Support-Anfragen per PN.
Für alle meine Beiträge gelten, außer bei Zitaten, die Creative Commons.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste