Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst]Bootsplash nicht wie erwartet

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
flying_rio
Member
Member
Beiträge: 57
Registriert: 20. Mai 2006, 08:33
Wohnort: Celle

[gelöst]Bootsplash nicht wie erwartet

Beitrag von flying_rio » 12. Mär 2007, 11:16

Hallo zusammen,

ich bin hier im Forum irgendwie nicht so richtig fündig geworden, deshalb will ich mal mein Problem schildern.

Also,ich habe mir folgenden Bootsplash installiert:
http://www.kde-look.org/content/show.php?content=53507

Leider präsentiert sich Grub immer noch mit seinem blauen Bildschirm.
Erst nach Auswahl von Suse sehe ich beim Bootvorgang im Hintergrund mein Bootsplashmotiv in der korrekten Auflösung (das 2. Bild).

Was muß ich tun, damit sich mein Bootsplash auch im Grub darstellt, oder liege ich da falsch?

Außerdem verstehe ich nicht, warum gleich das 2.Bild erscheint und ich nicht erst ESC drücken muß.

Gruß,
Torsten
Zuletzt geändert von flying_rio am 17. Mär 2007, 21:21, insgesamt 1-mal geändert.
  • Suse 13.1, Kernel 3.11.10-17-desktop, KDE 4.11.5
    NVIDIA GeForce 6150
Wenn einem das Wasser bis zum Hals steht,
sollt man den Kopf nicht hängen lassen.

Werbung:
towo
Moderator
Moderator
Beiträge: 3708
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo » 12. Mär 2007, 12:15

Was muß ich tun, damit sich mein Bootsplash auch im Grub darstellt, oder liege ich da falsch?
Bootsplash != gfx-menu von Grub.
Signatur nach Diktat spazieren gegangen

Bild

Benutzeravatar
flying_rio
Member
Member
Beiträge: 57
Registriert: 20. Mai 2006, 08:33
Wohnort: Celle

Beitrag von flying_rio » 13. Mär 2007, 08:36

Erst mal Danke für die Antwort,

aber ich hab' wohl ein wenig zu viel dranrumgebastelt.
Ich musste mit meinem /boot -Verzeichnis umziehen auf eine andere Platte und naja, jetzt sind meine Probleme ein klein wenig größer geworden. :cry:

Wenn ich das wieder gerade gezogen habe, schau ich mir noch mal die Sache mit dem Grubhintergrund an.

Gruß,
Torsten
  • Suse 13.1, Kernel 3.11.10-17-desktop, KDE 4.11.5
    NVIDIA GeForce 6150
Wenn einem das Wasser bis zum Hals steht,
sollt man den Kopf nicht hängen lassen.

Benutzeravatar
revealed
Guru
Guru
Beiträge: 3016
Registriert: 15. Sep 2006, 12:50

Beitrag von revealed » 13. Mär 2007, 12:48

hast du in der Zeile des Eintrags im Bootloader eventuell "splash=" oder "vga=" nicht angegeben?
splash=silent -> Dieser Parameter schaltet den Bootscreen in den "silent mode".
splash=verbose -> Dieser Parameter steht für den verbose Mode.
splash=0 -> Dieser Parameter schaltet den Bootsplash ab.
Gruss

R
|Nb: T60 2008 43G @oS Leap 42.1 | Pc: @oS TW Core i5 4670k; 8 GB RAM; MSI Z87 G43 Gaming | MSI TF 770 GTX | 840 EVO; SX900 |The reason computer chips are so small is computers don't eat much. | systemd | Mini Tuning guide für openSUSE 13.2 |

Benutzeravatar
flying_rio
Member
Member
Beiträge: 57
Registriert: 20. Mai 2006, 08:33
Wohnort: Celle

Beitrag von flying_rio » 13. Mär 2007, 22:05

Also ich habe folgendes eingestellt:

splash=verbose
vga=0x031a (hatte vorher mit hwinfo --framebuffer nachgeschaut)

Naja, aber im Moment will mein Suse garnicht mehr.

Ich bin mit meinem boot-Verzeichnis umgezogen und nun konnte ich Grub nicht mehr starten. (Weiß der Geier warum nicht)
Also, Suse-CD rein, booten und Rescue gestartet, um dann mit grub-install weiterzukommen - Fehlanzeige.
Irgendwie meldet mir das System einen Fehler mit stage1. :(

Na schön, dann habe ich versucht über die Suse-CD den Grub neu zu installieren. Aber auch das klappt nicht - Fehlermeldung. (hat übrigens auch schon bei der Erstinstallation nicht funktioniert) Aus der Nummer kam ich nur raus, indem ich von der CD aus gesagt habe, daß ich das vorhandene System booten will.
:x :x :x

OK, ich hab erst mal meinen mbr platt gemacht und von Windows aus meinen alten Bootmanager installiert.

Jetzt hau' ich gleich mal mit der Systemreparatur drauf rum.

Gruß,
Torsten
  • Suse 13.1, Kernel 3.11.10-17-desktop, KDE 4.11.5
    NVIDIA GeForce 6150
Wenn einem das Wasser bis zum Hals steht,
sollt man den Kopf nicht hängen lassen.

Benutzeravatar
flying_rio
Member
Member
Beiträge: 57
Registriert: 20. Mai 2006, 08:33
Wohnort: Celle

Beitrag von flying_rio » 17. Mär 2007, 21:04

Hallo zusammen,

also ich hab's geschafft.
Nach Neuinstallation von grub hat sich endlich mein System wieder starten lassen.

Mein Bootsplash macht jetzt auch was er soll.
Das Geheimnis war eigentlich nur, daß ich in der "menu.lst" in /boot/grub lediglich splash=silent einstellen musste.
Somit konnte ich auch das 1. Bild sehen und mit <ESC> schaltet er um in den verbose-Mode.

Im grub hab ich jetzt auch eine schönes Hintergrundbild und das funktioniert recht einfach.
Mir hat diese Anleitung geholfen:
http://de.susewiki.org/index.php?title= ... C3%A4ndern

Gruß,
Torsten
  • Suse 13.1, Kernel 3.11.10-17-desktop, KDE 4.11.5
    NVIDIA GeForce 6150
Wenn einem das Wasser bis zum Hals steht,
sollt man den Kopf nicht hängen lassen.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste