Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

ELSA MicroLink Office Faxspeicher auslesen (hylafax)

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Come2gether
Newbie
Newbie
Beiträge: 24
Registriert: 18. Nov 2005, 19:41
Wohnort: Siegburg

ELSA MicroLink Office Faxspeicher auslesen (hylafax)

Beitrag von Come2gether » 4. Mär 2007, 16:26

Hallo Forum,

ich benutze schon seit längerem mein altes ELSA MicroLink Office Modem, um Faxe über hylafax zu verschicken und zu empfangen (unter openSuSE 10.2).
Um auch Faxe bei ausgeschaltetem PC empfangen zu können, hat das Modem einen kleinen Flashspeicher. Bisher habe ich immer das Programm mlo2hfax dazu benutzt, um den Flashspeicher auszulesen. Seit openSuSE 10.2 funktioniert dies aus irgendeinem Grund aber nicht mehr.

Deswegen hier meine Frage: Kennt jemand eine Möglichkeit, um die in dem Flashspeicher liegenden Faxe auszulesen?

Danke schon mal & Grüße
Benedikt

Werbung:
coogor
Hacker
Hacker
Beiträge: 639
Registriert: 21. Dez 2005, 12:10
Wohnort: Düsseldorf

Beitrag von coogor » 5. Mär 2007, 11:20

Das Problem kommt mir bekannt vor (USR Message Modem).......

Vom Hersteller kannst Du da wenig Support erwarten. Die größten Chancen hast Du, indem Du dem Grund, warum es mlo2hfax nicht mehr tut, auf den Grund gehst: Startet das Programm, gibt es ein Log, etc.
V8: More smile per mile

Favorite Toy: ThinkPad T520, Core i7-2640M, 8G RAM, 1600x900, openSUSE Tumbleweed
Member of openSUSE.org

Come2gether
Newbie
Newbie
Beiträge: 24
Registriert: 18. Nov 2005, 19:41
Wohnort: Siegburg

Beitrag von Come2gether » 5. Mär 2007, 16:25

Hallo coogor,
Vom Hersteller kannst Du da wenig Support erwarten.
Außerdem werden diese Modems meines Wissens eh nicht mehr hergestellt.

Folgende Logs konnte ich ausfindig machen:
Im verbose=3 Modus spuckt mlo2hfax folgendes auf der Kommandozeile aus

Code: Alles auswählen

mlo2hfax: Using device "/dev/ttyS0" with 38400 bps
mlo2hfax: 1 facsimile in modem
mlo2hfax: Loading file 1 of 1: "20070303174103.FAX"
.................
Das hier steht unter /var/spool/fax/log/ (wobei diesem Log nach eigentlich alles OK sein müsste...)

Code: Alles auswählen

Mar 05 15:59:53.31: [23651]: SESSION BEGIN 00000019
Mar 05 15:59:53.57: [23651]: <-- [5:AT&F\r]
Mar 05 15:59:53.59: [23651]: --> [2:OK]
Mar 05 15:59:53.61: [23651]: <-- [5:ATI6\r]
Mar 05 15:59:53.63: [23651]: --> [4:ATI6]
Mar 05 15:59:53.64: [23651]: --> [16:MicroLink Office]
Mar 05 15:59:53.64: [23651]: --> [2:OK]
Mar 05 15:59:53.64: [23651]: <-- [5:AT&F\r]
Mar 05 15:59:53.66: [23651]: --> [4:AT&F]
Mar 05 15:59:53.66: [23651]: --> [2:OK]
Mar 05 15:59:53.66: [23651]: <-- [13:AT$JDIR=,FAX\r]
Mar 05 15:59:53.68: [23651]: --> [12:AT$JDIR=,FAX]
Mar 05 15:59:53.71: [23651]: --> [65:20070303174103.FAX,   T4F,      ,        03.03.2007, 17:41, 17312]
Mar 05 15:59:53.71: [23651]: --> [2:OK]
Mar 05 15:59:53.71: [23651]: <-- [29:AT$JDNL="20070303174103.FAX"\r]
Mar 05 15:59:53.81: [23651]: XMODEM download: 20070303174103.FAX
Mar 05 16:00:01.48: [23651]: --> [2:OK]
Mar 05 16:00:01.48: [23651]: SESSION END
Das wars aber auch schon, viel weiter komme ich damit auch nicht. Das Logfile wird ja ohne Probleme geschrieben, nur das Fax wird nicht im recvq-Ordner abgelegt.

Benedikt

coogor
Hacker
Hacker
Beiträge: 639
Registriert: 21. Dez 2005, 12:10
Wohnort: Düsseldorf

Beitrag von coogor » 5. Mär 2007, 18:51

Dumme Frage, aber: Hast Du mal in einem anderen Directory nach dem Fax gesucht?
Zuletzt geändert von coogor am 5. Mär 2007, 19:42, insgesamt 1-mal geändert.
V8: More smile per mile

Favorite Toy: ThinkPad T520, Core i7-2640M, 8G RAM, 1600x900, openSUSE Tumbleweed
Member of openSUSE.org

Come2gether
Newbie
Newbie
Beiträge: 24
Registriert: 18. Nov 2005, 19:41
Wohnort: Siegburg

Beitrag von Come2gether » 5. Mär 2007, 19:20

Ja, die Idee ist mir auch schon gekommen, aber in welchem Ordner? Habe gerade mal die gesamte Systempartition durchsucht (die Faxe müssten einen Dateinamen nach dem Muster
fax000000001.tif haben) -> es wurde natürlich nichts gefunden.

coogor
Hacker
Hacker
Beiträge: 639
Registriert: 21. Dez 2005, 12:10
Wohnort: Düsseldorf

Beitrag von coogor » 5. Mär 2007, 19:44

Come2gether hat geschrieben:(die Faxe müssten einen Dateinamen nach dem Muster fax000000001.tif haben)
Sicher? In Deinem Log steht 0070303174103.FAX
V8: More smile per mile

Favorite Toy: ThinkPad T520, Core i7-2640M, 8G RAM, 1600x900, openSUSE Tumbleweed
Member of openSUSE.org

Come2gether
Newbie
Newbie
Beiträge: 24
Registriert: 18. Nov 2005, 19:41
Wohnort: Siegburg

Beitrag von Come2gether » 5. Mär 2007, 20:36

Sicher? In Deinem Log steht 0070303174103.FAX
Relativ :wink:
Auch eine Suche nach dem anderen Dateinamen hat nichts ergeben. Ich glaube, dass der Dateiname in dem Log nur das Fax im Modemspeicher identifiziert und der Name letztendlich auf dem PC hylafax-konform umgewandelt wird (zumindest arbeitet mlo2hfax ähnlich wie faxgetty).

Aber 100%ig sicher bin ich mir nicht!

coogor
Hacker
Hacker
Beiträge: 639
Registriert: 21. Dez 2005, 12:10
Wohnort: Düsseldorf

Beitrag von coogor » 6. Mär 2007, 08:38

War fast zu vermuten. Aus dem Stehgreif bin ich mit meinem Latein etwas am Ende, man müßte sich die Applikation mal näher ansehen. Auf der Homepage ist auf KMLOfax verwiesen, hast Du es mal damit versucht?
Dann wäre noch zu klären:
SuSE schiebt hylafax in /var/spoll/fax, die Projekte (also hylafax.org und hylafax.sourceforge.net) selber in /var/spool/hylafax. Welches hylafax nutzt Du? Evtl. mußt Du den Pfad neu setzen?
V8: More smile per mile

Favorite Toy: ThinkPad T520, Core i7-2640M, 8G RAM, 1600x900, openSUSE Tumbleweed
Member of openSUSE.org

Come2gether
Newbie
Newbie
Beiträge: 24
Registriert: 18. Nov 2005, 19:41
Wohnort: Siegburg

Beitrag von Come2gether » 6. Mär 2007, 16:41

Ich bin mir fast sicher, dass das Problem an dem Programm mlo2hfax selber liegt. Schließlich ist die letzte Version auch schon etwas älter (Anfang 2003). KMLOfax habe ich nicht kompiliert bekommen, da es nicht mit der aktuellen Version von KDE (und was es sonst noch so benötigt) kompatibel ist. Und um Änderungen an mlo2hfax oder KMLOfax vornehmen zu können, müsste ich mich mit C oder C++ auskennen - was leider nicht der Fall ist.

Ich habe mir jetzt so geholfen, dass ich den Faxempfang über Arcor umleite und die Mails mit dem Fax im Anhang an meine E-Mail Adresse weiterleite. Das hat sogar den Vorteil, dass ich Faxe auch von anderswo als zuhause abrufen kann. Und Dank Telefonflatrate kostet die Weiterleitung auch nix.

horribiliscribrifax
Newbie
Newbie
Beiträge: 1
Registriert: 28. Mär 2007, 12:38

Beitrag von horribiliscribrifax » 28. Mär 2007, 13:25

Schön, dass es noch andere Benutzer dieser Meisterwerke deutscher Ingenieurskunst gibt :D !

Nur zur letzten Nachricht (für das ursprüngliche Problem habe ich keine Lösung, da ich die ISDN-Variante benutze, für die mlo2hfax, mlo2mgetty und kmlovoice leider gar nicht funktionieren).

Ich wollte nur kurz berichten, dass ich kmlofax unter SuSE 10.2 erfolgreich kompilieren konnte (und verwende :wink:), indem ich den mail-Dialog auskommentiert habe, da die benötigten KDE-SMTP-Klassen offenbar nicht mehr vorhanden sind (ich habe von KDE-Programmierung leider keine Ahnung, vielleicht stecken sie nur wo anders bzw. die entsprechenden Pakete fehlen in SuSE 10.2 ).

Außerdem habe ich noch für USB folgendes geändert in
modem.cpp: /dev/usb/ttyACMx -> /dev/ttyACMx

Bei Bedarf verschicke ich auch gerne die geänderten files.

Ich hätte nach wie vor Interesse an KMLOVoice und MLO2mgetty für das ELSA Microlink ISDN Office, aber leider auch irgendwie keine Muße, da selbst Hand anzulegen (die Protokolle für die Dateiübertragung sind unterschiedlich bei der ISDN- und der nicht-ISDN-Variante, aber da müsste man bei kmlofax abschauen können).

Übrigens habe ich noch ein reproduzierbares Problem mit dem Abholen größerer Faxe (mehr als ca. 80 Kilobytes) über die serielle Schnittstelle, scheint ein timing-oder buffering-Problem, evtl. im Zusammenhang mit Kernels 2.6.x (x \in {13,18}) zu sein, aber es ist unabhängig von der eingestellten Schnittstellengeschwindigkeit. Das Problem tauchte zum ersten Mal nach einer Komplettaktualisierung von SuSE 10.0 im Februar 2007 auf (never change a running system - ich könnte mir in den A. beißen), auch ein Neuinstallieren (SuSE 10.2) brachte keine Verbesserung. Mit USB keine Probleme. Hardware ist ein Pentium III mit 866 MHz, der auch (außer KDE...) sonst nichts Wesentliches zu tun hat, also schnell genug. Any hints welcome.

Come2gether
Newbie
Newbie
Beiträge: 24
Registriert: 18. Nov 2005, 19:41
Wohnort: Siegburg

Beitrag von Come2gether » 28. Mär 2007, 13:48

Hi horribiliscribr…,

ich kann dir bei deiner Problematik mit dem ELSA Microlink ISDN Office leider nicht weiterhelfen, wäre aber sehr interessiert an den geänderten Dateien für kmlofax. Bei mir spuckt der Compiler immer schon eine Fehlermeldung bzgl. der Datei senderaliases.h aus.

Code: Alles auswählen

senderaliases.h:62: Fehler: zusätzliches »;«
senderaliases.h:66: Fehler: zusätzliches »;«
senderaliases.h:70: Fehler: zusätzliches »;«
senderaliases.h:74: Fehler: zusätzliches »;«
Mit meinen eher bescheidenen Programmierkenntnissen schaffe ich es aber nicht, den Fehler zu beheben. Deswegen bin ich sehr gespannt auf deine Dateien :D

Grüße Benedikt

P.S.: Kann man Dateien per PN verschicken? Ansonsten schicke ich dir meine Mail Adresse bei PN.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast