Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Typo3: 123Go-Installationsproblem

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Alarich
Newbie
Newbie
Beiträge: 33
Registriert: 19. Jul 2006, 16:51

Typo3: 123Go-Installationsproblem

Beitrag von Alarich » 3. Mär 2007, 14:16

Hallo zusammen,

ich habe folgendes Problem: Ich möchte Typo3 lokal auf meinem System, SuSE 10.2 x86_64, aufsetzen. Dabei bin ich nach der Anleitung im Buch von Joscha Feth vorgegangen:
- Apache installiert und gestartet
- MySQL installiert und gestartet
- php installiert

Die beiden Dateien (Source und Dummy-Paket) habe ich im Verzeichnis /srv/www/htdocs entpackt. Eigentümer der beiden Ordner ist wwwrun, Gruppe ist www. Apache meldet: "It works!"

Wenn ich nun im Browser auf http:/localhost/t3site eintippe, erhalte ich folgende Fehlermeldung: "Zugriff verweigert! Error 403"

Was mache ich falsch? Vielleicht kann einer von Euch mir hier helfen... Danke schon mal im voraus...

:( Alarich

Werbung:
Klaus-D. Wenger
Hacker
Hacker
Beiträge: 271
Registriert: 24. Dez 2004, 12:03
Wohnort: Bremen
Kontaktdaten:

Re: Typo3: 123Go-Installationsproblem

Beitrag von Klaus-D. Wenger » 4. Mär 2007, 07:43

Alarich hat geschrieben: "Zugriff verweigert! Error 403"
a.)Bin zwar keine Typo-Heini ;-) aber rein grundsätzlich wenn da eine .htaccess liegt muss die von Typo3 beschreibbar sein
b.)schaue mal in die http,.conf welcher User denn Zugriff auf www. hat?

Einfacher Weg: Du packst das alles unter den ~user in Public_html
und rufst dann http://localhost/~user auf
OpenSUSE 11.2
- Eine einfache Lösung aus de.comp.lang.php.misc Date: Tue, 07 Oct 2003 20:03:32:
>> Wenn ihr PHP zu Dokumentationszwecken ausdrucken müsst, was verwendet
>> ihr dann?

Einen Drucker?

tomte
Hacker
Hacker
Beiträge: 798
Registriert: 15. Nov 2003, 13:40
Wohnort: 16°08'12"E / 56°34'08"N

Beitrag von tomte » 4. Mär 2007, 08:45

Liegt das install tool nicht in ..../sitename/install/ ???
Nothing is easier than being busy - and nothing more difficult than being effective.

HomerNarr
Newbie
Newbie
Beiträge: 1
Registriert: 11. Okt 2006, 18:09

Beitrag von HomerNarr » 7. Mär 2007, 13:49

So wie ich das sehe, hast du Apache installiert, aber noch nicht für den Zugriff auf Typo3 eingerichtet.

Du schrubst nämlich nix darüber.
Die anderen Dinge sind, das du auch noch einmal einen chown bzw eine chgrp machen musst, sobal du Typo3 bzw dummy entpackt hast.

Der Pfad müsste lauten:

http://host/sitename/install/index.php

Hättest du Apache korrekt eingerichtet, käme bei
'http://host/sitename'
Typo3 und würde dir von der fehlenden Frontend erzählen.

Alarich
Newbie
Newbie
Beiträge: 33
Registriert: 19. Jul 2006, 16:51

Beitrag von Alarich » 7. Mär 2007, 15:45

Hallo,

ich habe sowohl den Ordner dummy als auch den Ordner mit dem Source-Code von Typo3 dem Benutzer wwwrun per chown zugewiesen, und als Gruppe mit chgrp der Gruppe www

Mein User-Account ist in der Gruppe www Mitglied. wwwrun ist ebenfalls Mitglied der Gruppe www.

Der Pfad heißt so, wie Du sagst.

oerm
Newbie
Newbie
Beiträge: 11
Registriert: 14. Feb 2005, 15:44
Kontaktdaten:

Beitrag von oerm » 27. Mär 2007, 16:43

Hallo,

überprüfe einmal Deine Apache Konfiguration, für das typo3 Verzeichnis sollte diese etwas so aussehen:

Code: Alles auswählen

<Directory "/var/www/webx/html">
AllowOverride All
Options +FollowSymLinks
PHP_ADMIN_FLAG safe_mode off
PHP_ADMIN_VALUE open_basedir /
PHP_ADMIN_VALUE safe_mode_exec_dir /
</Directory>

Wichtig ist das Pluszeichen vor FollowSymlinks, da typo3_src usw. nur symbolische Links auf den Source sind. (damit ist das Update ein Kindespiel)
Ach so, wenn kein php Script mehr läuft einfach mal die Zeile mit open_basedir auskommentieren.
Ubuntu 6.10 auf AMD 64 Workstation,
Ubuntu 6.10 auf Intel Celeron Laptop
(SERVER) mehre SLES 10 und Debian 3.1.

Darth
Newbie
Newbie
Beiträge: 3
Registriert: 13. Dez 2006, 22:21

Beitrag von Darth » 14. Jul 2007, 00:31

@ Alarich:

oerm hat recht. Allerdings sieht es bei SuSE etwas anders aus. Wenn Du im dummy Paket, wie im INSTALL.txt von typo3 beschrieben, die Verzeichnisse fileadmin typo3conf typo3temp uploads der Gruppe des Webservers zuordnest (bei mir www) und der Gruppe Schreibrechte gibts, dann fehlt nur noch der Eintrag FollowSymLinks in der Apache Confing. Bei SuSE ist es unter /etc/apache2 die Datei default-server.conf und bei <Directory "/srv/www/htdocs"> mußt Du das Options None durch ein Options FollowSymLinks ändern. Funktioniert bei mir mit SuSE 10.0 und 10.1.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast