Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Kein screen als user unter OpenVZ

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
ceegee
Hacker
Hacker
Beiträge: 281
Registriert: 20. Okt 2005, 07:34

Kein screen als user unter OpenVZ

Beitrag von ceegee » 28. Feb 2007, 09:27

Hallo,

ich habe unter Debian Etch als Hostsystem OpenVZ installiert. Als Gast läuft ein Debian Sarge. Ich habe das Problem, dass ich als user kein screen starten kann. Es kommt diese Meldung:

Cannot open your terminal '/dev/pts/0' - please check.

Manchmal steht dort /dev/pts/0, manchmal /dev/pts/1. Muss man erst mit vzctl die virtuellen Konsolen "freischalten"?

Google habe ich schon befragt, brachte mich aber nicht weiter.

Gruß,

Christian
Gestern war heute noch morgen!

Werbung:
Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16603
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 28. Feb 2007, 13:17

Hi

Sieh dir mal die Rechte an

Code: Alles auswählen

ls -l /dev/pts/0
Ich schätze die musst du ändern.

cu

Benutzeravatar
ceegee
Hacker
Hacker
Beiträge: 281
Registriert: 20. Okt 2005, 07:34

Beitrag von ceegee » 28. Feb 2007, 13:38

Hi,

das hatte ich gestern mal ausprobiert. Hat auch für den Moment funktioniert. Aber wenn ich den VPS runterfahre und wieder hochfahre ist die Änderung wieder weg.

Ich suche einen Weg der das ganze permanent einrichtet.

Gruß,

Christian
Gestern war heute noch morgen!

jengelh
Guru
Guru
Beiträge: 4039
Registriert: 20. Nov 2004, 17:42
Kontaktdaten:

Beitrag von jengelh » 28. Feb 2007, 22:23

In der devpts-Zeile in /etc/fstab

Code: Alles auswählen

mode=0666
(oder 0660 - je nachdem) als Option mitgeben.

Benutzeravatar
ceegee
Hacker
Hacker
Beiträge: 281
Registriert: 20. Okt 2005, 07:34

Beitrag von ceegee » 1. Mär 2007, 12:59

Ich sehe den Thread als gelöst an. Wie ich erfahren habe, gehört unter OpenVZ /dev/pts/0 immer dem Benutzer der sich einloggt. Da ich den VPS mit

Code: Alles auswählen

 vzctl enter 101 
betreten habe, bin ich natürlich root. Wechsle ich dann mit su - zu einem anderen Benutzer, gehört /dev/pts/0 trotzdem root und der Benutzer hat keinen Zugriff. Das ist wohl gewollt wie man mir sagte.

Ich löse das Problem so, indem ich mich per SSH direkt als der gewünschte Benutzer anmelde.

Gruß,

Christian
Gestern war heute noch morgen!

Antworten