Nach Kernel-Update schwarzer Bildschirm beim Booten !

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
McFock
Newbie
Newbie
Beiträge: 3
Registriert: 11. Mai 2004, 21:40
Wohnort: Kelheim(Bayern)/Deutschland
Kontaktdaten:

Nach Kernel-Update schwarzer Bildschirm beim Booten !

Beitrag von McFock » 23. Mai 2004, 20:42

Tag !
Ich hab SuSE 9.0 und Kernel 2.4, da hab ich beschlossen ein Kernel-Update auf 2.6.6 zu machen; den Kernel hab ich konfiguriert und dann kompiliert und dann ins Grub-Menü einen neuen Eintrag Kernel 2.6.6 gemacht (für alle Fälle, damit ich eventuell den alten Kernel laden kann);
wenn ich über Kernel 2.6.6 booten will, bleibt der Bildschirm einfach schwarz, Festplattenzugriff findet auch keiner statt, jedoch kann ich nach wie vor mit meinem alten Kernel 2.4 booten. Was ist bei mir schiefgelaufen ???
mfg McFock

Werbung:
Ghoul
Member
Member
Beiträge: 176
Registriert: 28. Mär 2004, 17:52
Wohnort: Niemandsland bei Bremen

Beitrag von Ghoul » 23. Mai 2004, 21:25

ab wann bleibt der Bildschirm Schwarz?
funktioniert die Konsole?

Versuch mal mit der Bootoption dir Hier erklärt ist:
Der Parameter »vga=«
Man beachte, daß es sich hierbei nicht um einen wirklichen Bootparameter handelt. Es ist vielmehr eine Option, die von LILO interpretiert wird und nicht vom Kernel wie all die anderen Bootparameter. Sie wird jedoch so häufig verwendet, daß sie an dieser Stelle eine Erwähnung verdient. Sie kann auch durch die Verwendung von rdev -v festgelegt werden und ebenso durch vidmode auf der Datei vmlinuz. Dieses ermöglicht dem Setup-Code die Benutzung des Video-BIOS zur Änderung des Standard-Anzeige-Modus vor dem tatsächlichen Booten des Linux-Kernels. Typische Modi sind 80x50, 132x44 usw. Man verwendet diese Option am besten, indem man mit vga=ask beginnt, worauf man eine Liste verschiedener Modi erhält, die man mit dem Grafik-Adapter benutzen kann, bevor man den Kernel bootet. Hat man einmal eine Nummer aus obiger Liste gewählt, kann man sie später anstelle von ask setzen. Weitere Informationen findet man in der Datei linux/Documentation/svga.txt, die mit allen neueren Kernel-Versionen ausgeliefert wird.
mfg
Ghoul
-------------------------------------
Pinguinfreund aber kein Fensterfeind

Gast

Beitrag von Gast » 24. Mai 2004, 10:15

Möglicherweise hast du auch vergessen beim Kernel die Framebufferconsole zu konfigurieren (das war mein Fehler beim Update auf 2.6.6)

CONFIG_FB=y
CONFIG_FB_I810=y (natürlich musst du hier den passenden Treiber wählen)
CONFIG_FRAMEBUFFER_CONSOLE=y

Du kannst auch den Framebuffertreiber auch als Modul erstellen und in die ramdisk laden, dann wird der Bildschirm allerdings etwas später erst 'erhellt'.

Wenn allerdings die Festplatte auch keinen Mucks mehr von sich gibt, dann sind sicher noch andere Probleme am Start. Denn wenn es nur der Framebuffer ist, dann sollte irgendwann KDE aus dem Nichts erscheinen. Bist du sicher die 'menu.lst' richtig geändert zu haben(kein Tippfehler beim Verweis auf den Kernel bzw. initrd)?

McFock
Newbie
Newbie
Beiträge: 3
Registriert: 11. Mai 2004, 21:40
Wohnort: Kelheim(Bayern)/Deutschland
Kontaktdaten:

Beitrag von McFock » 24. Mai 2004, 16:31

Also ich komm gar nicht in die Konsole rein, der Bildschirm wird sofort schwarz, sobald ich auf Starteintrag "Kernel 2.6.6" wähle.
Wo müsste ich das mit dem Framebuffer hinschreiben ?
mfg McFock

Gast

Beitrag von Gast » 24. Mai 2004, 17:04

Du brauchst natürlich erstmal ein laufendes System (in deinem Fall der alte Kernel).
Die Änderungen am Framebuffer-device betreffen den Kernel selbst, falls die Einstellungen bei dir fehlen, musst du wohl oder übel neu compilieren.

Wenn du den Framebuffer als Modul hast (z.B. 'fbdev' in /lib/modules/<version>/kernel/drivers/video/ oder so ähnlich), dann kannst du eine neue ramdisk erstellen:

Code: Alles auswählen

mkinitrd -k vmlinux-2.6.6-bla -i initrd-2.6.6-bla -m fbdev
oder 'fbdev' in die Datei /etc/sysconfig/kernel in der Zeile

Code: Alles auswählen

INITRD_MODULES=""
eintragen (da steht bei dir wahrscheinlich schon reiserfs) und dann mkinitrd aufrufen.

Was die Tips von Ghoul angeht, kannst du die Parameter vor der Auswahl des Bootkernels unten in die Zeile reinschreiben (z.B. video=fbdev vga=ask)

Aber wie gesagt: wenn dein System überhaupt nicht bootet, d.h. die Festplatte nix tut, dann ist was ganz anderes mit dem neuen Kernel nicht in Ordung.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 5 Gäste