Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Hylafax Fehlermeldung

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
hebbes
Newbie
Newbie
Beiträge: 8
Registriert: 22. Aug 2006, 11:27

Hylafax Fehlermeldung

Beitrag von hebbes » 27. Jan 2007, 01:32

Hi Forum,

hab Hylafax mit 2 Modems an 2 seriellen Schnittstellen installiert. Testfaxe kamen auch korrekt an, Versand klappte zumindest schonmal über die eine Leitung.

Eben kam aber folgendes:

Code: Alles auswählen

An attempt to receive facsimile on ttyS0 failed because: 

ECM page received containing no image data. 

---- Transcript of session follows ---- 

Jan 27 00:26:04.93: [ 4586]: SESSION BEGIN 000000024 XXXXX 
Jan 27 00:26:04.93: [ 4586]: HylaFAX (tm) Version 4.3.0 
Jan 27 00:26:04.93: [ 4586]: MODEM set XON/XOFF/FLUSH: input ignored, output disabled 
Jan 27 00:26:04.93: [ 4586]: <-- [4:ATA\r] 
Jan 27 00:26:11.61: [ 4586]: --> [7:CONNECT] 
Jan 27 00:26:11.61: [ 4586]: ANSWER: FAX CONNECTION DEVICE '/dev/ttyS0' 
Jan 27 00:26:11.61: [ 4586]: RECV FAX: begin 
Jan 27 00:26:12.86: [ 4586]: --> [7:CONNECT] 
Jan 27 00:26:13.88: [ 4586]: --> [7:CONNECT] 
Jan 27 00:26:14.37: [ 4586]: --> [2:OK] 
Jan 27 00:26:14.37: [ 4586]: <-- [9:AT+FRH=3\r] 
Jan 27 00:26:14.83: [ 4586]: --> [7:CONNECT] 
Jan 27 00:26:16.22: [ 4586]: --> [2:OK] 
Jan 27 00:26:16.22: [ 4586]: REMOTE TSI "XXXXX" 
Jan 27 00:26:16.22: [ 4586]: <-- [9:AT+FRH=3\r] 
Jan 27 00:26:16.26: [ 4586]: --> [7:CONNECT] 
Jan 27 00:26:16.49: [ 4586]: --> [2:OK] 
Jan 27 00:26:16.49: [ 4586]: RECV training at v.17 14400 bit/s 
Jan 27 00:26:16.49: [ 4586]: MODEM set XON/XOFF/DRAIN: input ignored, output generated 
Jan 27 00:26:16.49: [ 4586]: <-- [11:AT+FRM=145\r] 
Jan 27 00:26:18.24: [ 4586]: --> [7:CONNECT] 
Jan 27 00:26:19.73: [ 4586]: MODEM set XON/XOFF/DRAIN: input ignored, output disabled 
Jan 27 00:26:19.73: [ 4586]: RECV: TCF 2723 bytes, 2% non-zero, 2596 zero-run 
Jan 27 00:26:19.74: [ 4586]: --> [10:NO CARRIER] 
Jan 27 00:26:19.74: [ 4586]: <-- [9:AT+FRS=7\r] 
Jan 27 00:26:19.83: [ 4586]: --> [2:OK] 
Jan 27 00:26:19.83: [ 4586]: TRAINING succeeded 
Jan 27 00:26:19.83: [ 4586]: <-- [9:AT+FTH=3\r] 
Jan 27 00:26:20.97: [ 4586]: --> [7:CONNECT] 
Jan 27 00:26:21.19: [ 4586]: --> [2:OK] 
Jan 27 00:26:21.19: [ 4586]: <-- [11:AT+FRM=146\r] 
Jan 27 00:26:21.72: [ 4586]: --> [7:CONNECT] 
Jan 27 00:26:21.72: [ 4586]: MODEM input buffering enabled 
Jan 27 00:26:21.72: [ 4586]: MODEM set XON/XOFF/FLUSH: input ignored, output generated 
Jan 27 00:26:21.79: [ 4586]: HDLC frame not byte-oriented. Trailing byte: 0xfc 
Jan 27 00:26:22.13: [ 4586]: RECV received frame number 0 
Jan 27 00:26:22.26: [ 4586]: RECV received frame number 1 
Jan 27 00:26:22.40: [ 4586]: RECV received frame number 2 
Jan 27 00:26:22.55: [ 4586]: RECV received frame number 3 
Jan 27 00:26:22.69: [ 4586]: RECV received frame number 4 
Jan 27 00:26:22.90: [ 4586]: RECV received frame number 5 
Jan 27 00:26:23.04: [ 4586]: RECV received frame number 6 
Jan 27 00:26:23.18: [ 4586]: RECV received frame number 7 
Jan 27 00:26:23.33: [ 4586]: RECV received frame number 8 
Jan 27 00:26:23.47: [ 4586]: RECV received frame number 9 
Jan 27 00:26:23.61: [ 4586]: RECV received frame number 10 
Jan 27 00:26:23.75: [ 4586]: RECV received frame number 11 
Jan 27 00:26:23.96: [ 4586]: RECV received frame number 12 
Jan 27 00:26:24.11: [ 4586]: RECV received frame number 13 
Jan 27 00:26:24.25: [ 4586]: RECV received frame number 14 
Jan 27 00:26:24.39: [ 4586]: RECV received frame number 15 
Jan 27 00:26:24.53: [ 4586]: RECV received frame number 16 
Jan 27 00:26:24.53: [ 4586]: RECV received RCP frame 
Jan 27 00:26:24.53: [ 4586]: MODEM set XON/XOFF/DRAIN: input ignored, output disabled 
Jan 27 00:26:24.53: [ 4586]: MODEM input buffering disabled 
Jan 27 00:26:24.57: [ 4586]: --> [10:NO CARRIER] 
Jan 27 00:26:24.57: [ 4586]: <-- [9:AT+FRH=3\r] 
Jan 27 00:26:24.92: [ 4586]: --> [7:CONNECT] 
Jan 27 00:26:25.89: [ 4586]: --> [2:OK] 
Jan 27 00:26:25.89: [ 4586]: RECV recv PPS (partial page signal) 
Jan 27 00:26:25.89: [ 4586]: RECV recv EOP (no more pages or documents) 
Jan 27 00:26:25.89: [ 4586]: RECV received 17 frames of block 1 of page 1 
Jan 27 00:26:25.89: [ 4586]: RECV: 4098 bytes of data, 0 total lines 
Jan 27 00:26:25.89: [ 4586]: MODEM set XON/XOFF/DRAIN: input ignored, output disabled 
Jan 27 00:26:25.89: [ 4586]: RECV FAX: ECM page received containing no image data. 
Jan 27 00:26:25.89: [ 4586]: <-- [9:AT+FTH=3\r] 
Jan 27 00:26:25.89: [ 4586]: RECV FAX (000000024): recvq/fax000000008.tif from XXXXXX, route to <unspecified>, 0 pages in 0:14 
Jan 27 00:26:26.93: [ 4586]: --> [7:CONNECT] 
Jan 27 00:26:27.15: [ 4586]: --> [2:OK] 
Jan 27 00:26:27.15: [ 4586]: MODEM input buffering enabled 
Jan 27 00:26:27.15: [ 4586]: RECV FAX (000000024): session with XXXXXX terminated abnormally: ECM page received containing no image data. 
Jan 27 00:26:27.15: [ 4586]: RECV FAX: bin/faxrcvd "recvq/fax000000008.tif" "ttyS0" "000000024" "ECM page received containing no image data." 
Jan 27 00:26:27.15: [ 4586]: RECV FAX: end 
Jan 27 00:26:27.15: [ 4586]: SESSION END [code]

Code: Alles auswählen

[list]
[/list][/code]

Das Modem auf dieser Schnittstelle wurde bei der Einrichtung von Hylafax (4.3) auch nicht so ganz erkannt (anders als das auf ttyS1), ich hatte da einfach mal die Vorgaben des scripts übernommen. Andere Faxe kamen wie gesagt aber an, der Versand klappte aber nicht.

Ist das eher ein Konfigurationsfehler, ist das Modem nicht so optimal oder wie habe ich diese Meldung zu bewerten? Habe suchtechnisch leider keinerlei Hinweis zu dem Fehler gefunden.

Danke und Gruß

Werbung:
coogor
Hacker
Hacker
Beiträge: 639
Registriert: 21. Dez 2005, 12:10
Wohnort: Düsseldorf

Beitrag von coogor » 28. Jan 2007, 11:15

Könnte ein Problem im Sender/receiver handshake sein

Code: Alles auswählen

RECV recv PPS (partial page signal)
hab ich auch öfter mal bei meinem USR Message Modem, dann ist das empfangene Fax leer oder es hat 255 Seiten. Sende mir per PM mal Deine Faxnr, wenns nicht gerade in Australien ist schick ich Dir mal ein Fax.

Andererseits: Was spricht dagegen das andere Modem zum Empfang zu nehmen, wenn Du schon ein Problem damit vermutest?
V8: More smile per mile

Favorite Toy: ThinkPad T520, Core i7-2640M, 8G RAM, 1600x900, openSUSE Tumbleweed
Member of openSUSE.org

hebbes
Newbie
Newbie
Beiträge: 8
Registriert: 22. Aug 2006, 11:27

Beitrag von hebbes » 29. Jan 2007, 13:24

Hi,

Es spricht nichts dagegen, das andere Modem zu verwenden. Wollte nur beide zugleich benutzen ;)

Ich hatte das problematische Modem schonmal an einem anderen Server in Benutzung. Darauf habe ich noch die Konfig gefunden und mal rüberkopiert. Jetzt läuft das Dingens auch wieder im Empfang (war wohl die falsche Klasse...)

Gruß

coogor
Hacker
Hacker
Beiträge: 639
Registriert: 21. Dez 2005, 12:10
Wohnort: Düsseldorf

Beitrag von coogor » 29. Jan 2007, 15:37

hebbes hat geschrieben: (war wohl die falsche Klasse...)
Ja, auch wenn Class-2 draufsteht ist Class-1 meist die bessere Wahl......
V8: More smile per mile

Favorite Toy: ThinkPad T520, Core i7-2640M, 8G RAM, 1600x900, openSUSE Tumbleweed
Member of openSUSE.org

hebbes
Newbie
Newbie
Beiträge: 8
Registriert: 22. Aug 2006, 11:27

Beitrag von hebbes » 29. Jan 2007, 20:41

Hi,

ich hatte bei der Installation auch class1 ausgewählt (das script weist ja auch darauf hin). Jetzt läuft es im Empfang (erstmal receive only) halt mit class2.

Gruß

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast