Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[hylfax] c2faxsend funktioniert -- sendfax nicht kein versan

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
djrace
Newbie
Newbie
Beiträge: 16
Registriert: 5. Apr 2005, 15:02

[hylfax] c2faxsend funktioniert -- sendfax nicht kein versan

Beitrag von djrace » 18. Jan 2007, 10:21

Hallo,

ich habe hylafax soweit am laufen auf debian.

Faxe werden empfangen per Email als pdf weitergeleitet usw.

Ein Problem habe ich allerdings mit sendfax. Ich mache
sendfax -n -d xxxxx ./test.tif

Das Fax wird in die Queue Warteschlange geschreiben und nichts passiert weiter.

Wenn ich ein tif file fax mit c2faxsend verschicke geht das einwandfrei. Das fax geht raus und kommt auch entsprechend an.

In der Hylafax "config" Datei habe ich diese Zeile hinzugeüfgt
SendFaxCmd: /usr/bin/c2faxsend

Die Datei liegt ja auch da. Aber sendfax will immer noch nicht.

Wenn ich diese Zeile aus der config Datei entferne und mit sendfax senden will schreibt das fax in die queue liste. Dann initialisiert sich er der server und dann steht ununterbrochen da. Waiting for Modem to come ready.

Ich nehme mal an die zeile in der config datei ist soweit richtig nur irgendwie macht sendfax noch was falsch.

Bin für jeden Rat dankbar.

Mfg.
BjT

Werbung:
djrace
Newbie
Newbie
Beiträge: 16
Registriert: 5. Apr 2005, 15:02

Beitrag von djrace » 18. Jan 2007, 12:20

bin ein schritt weiter.

ich weiß jetzt das sendfax das fax zwar an hylafax übergibt und es dort auch in queue geschrieben wird aber dann nicht der c2faxsend aufgerufen wird um es zu verschicken.

ABER WIESO NICHT. Habe doch den **** befehl in der config datei drin stehen wieso läuft das dann nciht

?????

BITTE HELFT MIR

djrace
Newbie
Newbie
Beiträge: 16
Registriert: 5. Apr 2005, 15:02

Beitrag von djrace » 19. Jan 2007, 10:54

so bin wieder ein schritt weiter ich hoffe das mir nun einer helfen kann also bitte helf mir:

Hi,

ich habe mein hylafax soweit eingerichtet das es wunderbar empfängt und auch die faxe per mail weiterleitet usw.

Aber ein Problem habe ich noch das senden.

c2faxsend macht folgendes

Code: Alles auswählen

c2faxsend -f TIFF -v -d ******** /usr/local/source_install/fax01674.tif
Try to connect to fax number 03628584423 in TIFF mode on controller 1.
Dial and starting transfer of TIFF-File /usr/local/source_install/fax01674.tif with normal resolution.
Connection dropped with Reason 0x3490 (Normal call clearing).



Sendfax macht folgendes

Code: Alles auswählen

sendfax -n -d ******** /usr/local/source_install/fax01674.tif
request id is 22 (group id 22) for host localhost (1 file)


danach steht das fax in der queue liste mit dem fehler
an error occured while trying to established the connection

auszug xferfaxlog.log

Code: Alles auswählen

01/19/07 09:48   SEND   00000170   faxCAPIli   19   ""   root@debian-faxserver   "******"   "******"   256   0   0:54   0:24   "An error occured while trying to establish the connection."
01/19/07 10:21   SEND   00000180   faxCAPI   21   ""   root@debian-faxserver   "******"   "******"   256   0   2:01   0:00   "An error occured while trying to establish the connection."



auszug aus der capi4hylafax.log

Code: Alles auswählen

Jan 19 10:27:48.82: [ 2499]: c2faxrecv - INFO: 
Device "faxCAPI" uses 2 receive thread(s) with the following config:
Jan 19 10:27:48.82: [ 2499]: c2faxrecv - INFO: Controller=1 : IncomingMSNs=30
Jan 19 10:27:48.83: [ 2499]: c2faxrecv - INFO: 
Device "faxCAPIli" uses 2 receive thread(s) with the following config:
Jan 19 10:27:48.83: [ 2499]: c2faxrecv - INFO: Controller=1 : IncomingMSNs=35
Started in Hylafax mode and waiting on incoming calls.
Jan 19 10:28:42.80: [ 2715]: CapiFaxSend - INFO: Try to connect to fax number ****** in TIFF mode on controller 1.
Jan 19 10:28:42.86: [ 2715]: CapiFaxSend - INFO: Dial and starting transfer of TIFF-File /usr/local/source_install/fax01674.tif with normal resolution.
Jan 19 10:29:20.20: [ 2715]: CapiFaxSend - INFO: Connection dropped with Reason 0x3490 (Normal call clearing).



meine config.faxCAPI

Code: Alles auswählen

#
# EDIT THIS CONFIGURATION TO REFLECT YOUR SETUP
#
SpoolDir:              /var/spool/hylafax
#
FaxRcvdCmd:            /var/spool/hylafax/bin/faxrcvd
#
PollRcvdCmd:            /var/spool/hylafax/bin/pollrcvd
#
FaxReceiveUser:        uucp
#
FaxReceiveGroup:        dialout
#
LogFile:                /var/spool/hylafax/log/capi4hylafax
#
LogTraceLevel:          4
#
LogFileMode:            0600
#
#
######################
######################
#
{
HylafaxDeviceName: faxCAPI
RecvFileMode: 0600
FAXNumber: +49.*****.*****30
LocalIdentifier: "DynamicWare30"
MaxConcurrentRecvs: 2
OutgoingController: 1
OutgoingMSN: 30
SuppressMSN: 0
NumberPrefix:
UseISDNFaxService: 1
RingingDuration: 0
{
Controller: 1
AcceptSpeech: 1
UseDDI: 0
DDIOffset: "38690"
DDILength: 2
IncomingMSNs: 30
AcceptGlobalCall: 0
}
}
{
HylafaxDeviceName: faxCAPIli
RecvFileMode: 0600
FAXNumber: +49.*******.******35
LocalIdentifier: "DynamicWare35"
MaxConcurrentRecvs: 2
OutgoingController: 1
OutgoingMSN: 35
SuppressMSN: 0
NumberPrefix:
UseISDNFaxService: 1
RingingDuration: 0
{
Controller: 1
AcceptSpeech: 1
UseDDI: 0
DDIOffset: "38690"
DDILength: 2
IncomingMSNs: 35
AcceptGlobalCall: 0
}
}



meine config

Code: Alles auswählen

#ContCoverPage:        "etc/cover.templ"
DestControls:      "etc/destctrls"
DialStringRules:      "etc/dialrules"
QualifyCID:      "etc/cid"
QualifyTSI:      "etc/tsi"
ServerTracing:      0x08501
InternationalPrefix:   00
SendFaxCmd:       "/usr/bin/c2faxsend"
#SendFaxCmd:      /usr/bin/c2faxsend.wrap



Kann mir damit einer weiterhelfen warum ich nicht faxen kann aber der Faxempfang für beide devices einwandfrei klappt

bin für jeden rat dankbar

vielen dank im voraus

Mfg.
BjT

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste