Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

LTSP 4-2 und ASUS M2NPV: Booten klappt nicht (gelöst)

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Anhur
Newbie
Newbie
Beiträge: 2
Registriert: 2. Jan 2007, 22:33

LTSP 4-2 und ASUS M2NPV: Booten klappt nicht (gelöst)

Beitrag von Anhur » 2. Jan 2007, 22:51

Hallo

Ich kämpfe hier im Moment mit einem kleinen Problem.

Ich habe einen Debian Etch RC1 Server mit LTSP Server aufgesetzt.
Der DHCP Server, der die Clients mit den wichtigsten Infos versorgen soll ist NICHT der LTSP Server.

Der Client ist ein Diskless Rechner mit ASUS M2NPV-VM Hauptplatine (NVIDIA GeForce 6150 + nForce 430). Der Client soll über PXE gestartet werden. So weit so gut. DHCP Daten bekommt der Client. Er lädt auch den Kernel über TFTP. nur dann kommt irgendwann die Meldung:

Code: Alles auswählen

ERROR!  Could not automatically detect the network card.
                PCI cards should be detected automatically.
                ISA cards cannot be detected, so they require
                the nic driver to be specified in a 'NIC=' parameter
                to be passed on the kernel command line,
                usually specified in option-129, in the
                /etc/dhcpd.conf file.  See the LTSP docs for more info.
Der DHCP Server hat die IP 192.168.1.254 und folgende config:

Code: Alles auswählen

ddns-update-style none;
option domain-name "ragnarok.local";
option domain-name-servers 192.168.1.1;
default-lease-time 600;
max-lease-time 7200;
authoritative;
log-facility local7;
subnet 192.168.1.0 netmask 255.255.255.0 {
        range 192.168.1.50 192.168.1.100;
        option broadcast-address 192.168.1.255;
        option routers 192.168.1.1;
        option subnet-mask 255.255.255.0;

... hier steht ein bisschen was für andere Rechner ...

        host ws001 {
                hardware ethernet 00:18:F3:75:24:F4;
                fixed-address 192.168.1.70;
                next-server 192.168.1.3;
                filename "pxelinux.0";
                option root-path "192.168.1.3:/opt/ltsp-4.2/i386";
        }
}
Der TFTP Server wird über inetd gestart:

Code: Alles auswählen

tftp            dgram   udp     wait    root    /usr/sbin/tcpd  /usr/sbin/in.tft
pd -s /tftpboot/lts/2.6.17.8-ltsp-1
Hat da jemand eine Idee dazu? Der 2.6.17.8 Kernel sollte mit dem Chip ja klar kommen von einem ASUS M2N-E Board kann er mal die Netzwerkkarte erkennen.


Ich freue mich schon auf Antworten ...

Bernd
Zuletzt geändert von Anhur am 3. Jan 2007, 18:10, insgesamt 1-mal geändert.

Werbung:
Anhur
Newbie
Newbie
Beiträge: 2
Registriert: 2. Jan 2007, 22:33

Beitrag von Anhur » 3. Jan 2007, 18:09

Hallo


Kaum sucht man mal einen Tag lang nach dem Fehler ist die Sache auch schon gelöst :-)

Das Problem ist, dass die Jungs vom LTSP Team wohl nicht sehr viele nvidia Netzwerkkarten berücksichtigen. Aus diesem Grund wurde auch das Ethernet device eines MCP51 nicht mit dem forcedeth Treiber verknüpft. Ich gehe mal davon aus, dass dies bei allen aktuelleren nvidia Chips so laufen wird. Daher hier mal eine kurze Anleitung wie ich das zum laufen bekommen habe:

Code: Alles auswählen

cd /tmp
mkdir initrd
cd initrd
gzip -dc /tftpboot/lts/2.6.17.8-ltsp-1/initramfs.gz | cpio -id
emacs etc/niclist
Diese Zeilen entpacken die initrd. Am Ende wird noch die Datei geöffnet in der PCI Kennungen einem Modul zugeordnet werden.
Jetzt habe ich mal nach forcedeth gesucht. Hier sind nur 3 Zeilen zu finden gewesen. Unterhalb von diesen 3 habe ich nun folgende Zeilen eingefügt:

Code: Alles auswählen

10de:0086       forcedeth
10de:008c       forcedeth
10de:00e6       forcedeth
10de:00df       forcedeth
10de:0056       forcedeth
10de:0057       forcedeth
10de:0037       forcedeth
10de:0038       forcedeth
10de:0269       forcedeth
Nun die Datei schliessen und möglicherweise die temp-Dateien des Editors löschen. Nun muss nur noch die initrd neu zusammengebaut und in den richtigen Ordner kopiert werden.

Code: Alles auswählen

find ./ | cpio -H newc -o > /tftpboot/lts/2.6.17.8-ltsp-1/initramfs
cd /tftpboot/lts/2.6.17.8-ltsp-1/
rm initramfs.gz
gzip initramfs
Nun sollte das ganze klappen. Bei mir geht es zumindest mal. Für den MCP51 ist übrigend die 10de:0269 verantwortlich. Die anderen habe ich im Netz gefunden und vorsichtshalber gleich mal eingefügt.

Antworten