Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[HoTow]openSuSE 10.2 automatisch herunterfahren

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
obec
Advanced Hacker
Advanced Hacker
Beiträge: 1193
Registriert: 27. Dez 2005, 21:34
Wohnort: /home/obec

[HoTow]openSuSE 10.2 automatisch herunterfahren

Beitrag von obec » 31. Dez 2006, 13:26

Hi,

dieses HoTow ist nur für die jenigen, bei dem das System bei folgendem Code stehen bleibt:

Code: Alles auswählen

The System halted immediately

1. Problem:
Das System fährt nicht herunter, sondern bleibt hängen. Schuld ist ACPI, da dieser für das Powermanagment(siehehttp://de.wikipedia.org/wiki/ACPI )zuständig ist, auch für die Suspend-Modi.

2. Problemlösung:
1. Ihr öffnet eine Konsole als root unf gebt nacheinnander ein:

Code: Alles auswählen

acpi=on
acpid=on
apic=on
2. Dann öffnet ihr Yast unterSystem/Konfiguration des Bootladers und gebt als Bootparameter, bei dem Abschnitt openSuSE 10.2, das hier ein:

Code: Alles auswählen

acpi=force
oder

Code: Alles auswählen

acpi=force pci=noacpi(Thx RWTHler)
Bei der ersten Option können evntl. Harware-Problem auftreten, z.b. keine Internet-Verbindung e.t.c
3. Die beiden Möglichkeiten müsst ihr ausprobieren. Bei haben beide funktioniert.

3.Weitere Probleme
Wenn das System bei diesem Schritt stehen bleibt

Code: Alles auswählen

Skipped in Runlevel 0: reached
läst sich momentan noch nichts machen, da das ein Bug ist. Ich arbeite an einer Lösung.

Hier könnt eure Fragen und Anregungen zum HoTow stellen.
http://www.linux-club.de/viewtopic.php?p=433370#433370

Gruß

obec
openSuSE 11.0
Mandriva Linux 2008 Spring
Gigabyte P35-DS3
Intel Pentium D Prozessor 3,40GHZ
4096 MB Arbeitsspeicher
Nvidia Geforce 7600GS 512MB

Werbung:
Benutzeravatar
blaster_master
Member
Member
Beiträge: 58
Registriert: 8. Jun 2005, 11:09
Kontaktdaten:

Beitrag von blaster_master » 20. Feb 2007, 17:01

Hallo,

hast du vielleicht noch eine andere Idee?
Bei mir fuktioniert das alles nicht.
Hab die gleiche Meldung wenn mein Rechner runterfährt.

Code: Alles auswählen

 The System halted immediately 
Unter suse 9.3 und 10.1 hatte ich das auch schon, aber da konnte ich das durch

Code: Alles auswählen

 acpi=off 
beheben.
Weis langsam nicht mehr weiter.

Hab schon soviel probiert.

Erstmal danke im vorraus.[/code]

obec
Advanced Hacker
Advanced Hacker
Beiträge: 1193
Registriert: 27. Dez 2005, 21:34
Wohnort: /home/obec

Beitrag von obec » 20. Feb 2007, 17:56

Hi,

das hier ist veraltet, ich setze ein neuses ins Wiki.

Gruß

obec
openSuSE 11.0
Mandriva Linux 2008 Spring
Gigabyte P35-DS3
Intel Pentium D Prozessor 3,40GHZ
4096 MB Arbeitsspeicher
Nvidia Geforce 7600GS 512MB

Benutzeravatar
blaster_master
Member
Member
Beiträge: 58
Registriert: 8. Jun 2005, 11:09
Kontaktdaten:

Beitrag von blaster_master » 3. Mär 2007, 16:12

Hallo Leute,

hab den Eintrag im Wiki gerade gelesen, aber mein suse fährt sowohl bei

Code: Alles auswählen

acpi=on

Code: Alles auswählen

acpi=force

Code: Alles auswählen

acpi=off
nicht runter.
Ein Online Update bringt auch nichts. Könnte es vielleicht noch an etwas anderem liegen?

obec
Advanced Hacker
Advanced Hacker
Beiträge: 1193
Registriert: 27. Dez 2005, 21:34
Wohnort: /home/obec

Beitrag von obec » 3. Mär 2007, 19:01

Hi,

wie bist du mit diesen Befehlen umgegangen? Du musst einen von ihnen als root in die Konsole eingeben und dann den selben als Bootoption setzen. Wo bleibt denn das System jetzt stehen?

Gruß

obec
openSuSE 11.0
Mandriva Linux 2008 Spring
Gigabyte P35-DS3
Intel Pentium D Prozessor 3,40GHZ
4096 MB Arbeitsspeicher
Nvidia Geforce 7600GS 512MB

Benutzeravatar
blaster_master
Member
Member
Beiträge: 58
Registriert: 8. Jun 2005, 11:09
Kontaktdaten:

Beitrag von blaster_master » 3. Mär 2007, 22:19

hey obec,

ich hab das als root in der Konsole und in die Bootoptionen geschrieben und er hängt immer noch bei

Code: Alles auswählen

The System halted immediately
Hab das jetzt schon mehrere Male versucht und mir ist aufgefallen, dass wenn ich

Code: Alles auswählen

acpi=force
oder

Code: Alles auswählen

acpi=on
benutze, hängt sich der Rechner nach einer gewissen Zeit auf.

Das passiert bei

Code: Alles auswählen

acpi=off
nicht.
Aber runterfahren geht halt trotzdem nicht.

obec
Advanced Hacker
Advanced Hacker
Beiträge: 1193
Registriert: 27. Dez 2005, 21:34
Wohnort: /home/obec

Beitrag von obec » 3. Mär 2007, 23:33

Hi,

das ist schlecht. In diesem Fall weiß ich auch nicht weiter. Kannst du vielleicht mal das automatische Herunterfahren mit einer anderen Distribtion testen(z.b. Kubuntu). Wenn das dann da auch nicht funktioniert, passt was mit deiner Hardware nicht.

Gruß

obec
openSuSE 11.0
Mandriva Linux 2008 Spring
Gigabyte P35-DS3
Intel Pentium D Prozessor 3,40GHZ
4096 MB Arbeitsspeicher
Nvidia Geforce 7600GS 512MB

Benutzeravatar
blaster_master
Member
Member
Beiträge: 58
Registriert: 8. Jun 2005, 11:09
Kontaktdaten:

Beitrag von blaster_master » 4. Mär 2007, 08:17

Juhu es funktioniert wieder. :lol:

Also ich hab meine Kanotix(live) cd rausgekramt und hab mal geguckt was der für Bootoptionen benutzt und dort stand außer

Code: Alles auswählen

acpi=off
noch

Code: Alles auswählen

apm=power-off
Und das funktioniert jetzt. Mich würde nur interessieren, was apm=power-off
zubedeuten hat.
Schaltet es das apm komplett aus?
Oder schaltet es nur eine Funktion des apm aus.

Kannst das ja noch ins Wiki dazu schreiben. :D

obec
Advanced Hacker
Advanced Hacker
Beiträge: 1193
Registriert: 27. Dez 2005, 21:34
Wohnort: /home/obec

Beitrag von obec » 4. Mär 2007, 10:15

Hi,

so habe es entprechend editiert :wink: . Thx für die Verbesserungsvorschläge dieses Artikels.

Gruß

obec
openSuSE 11.0
Mandriva Linux 2008 Spring
Gigabyte P35-DS3
Intel Pentium D Prozessor 3,40GHZ
4096 MB Arbeitsspeicher
Nvidia Geforce 7600GS 512MB

trunkenpolz
Member
Member
Beiträge: 61
Registriert: 24. Okt 2006, 06:24

Beitrag von trunkenpolz » 20. Feb 2008, 08:38

Und das funktioniert jetzt. Mich würde nur interessieren, was apm=power-off
zubedeuten hat.
Schaltet es das apm komplett aus?
Oder schaltet es nur eine Funktion des apm aus.
Bei meinem IBM R30 hatte ich auch das Problem wenn die Bootoption ACPI=OFF gesetzt war, dann war weder ACPI noch APM Support im Kernel war.
(Mit ACPI schaltete der Rechner zwar ab, Benutzung war aber nicht möglich weil dann der CPU-Lüfter wild randalierte)

Der Eintrag

Code: Alles auswählen

 modprobe apm 
in /etc/init.d/boot.local
und der Bootparameter

Code: Alles auswählen

acpi=off apm=power-off 
in Grub haben das Problem (bis jetzt...) gelöst. APM läuft und der Rechner schaltet sich ab.

eckhard1
Newbie
Newbie
Beiträge: 3
Registriert: 17. Feb 2008, 13:11

Beitrag von eckhard1 » 22. Feb 2008, 14:40

Hallo,

ich bin noch sehr unerfahren mit Linux, habe das gleiche Problem. Auch mein Rechner schaltet sich nicht aus.

Zunächst erstmal die Frage, wo genau diese Parameter eingetragen werden müssen, wie gesagt - ich habe noch überhaupt keine Ahnung was Suse angeht.

Als nächstes würde mich interessieren, wie das automatische Runterfahren bei Linux geht, das sieht für mich ähnlich aus wie ein Skript oder eine Batch Datei. Wenn dem so wäre, könnte man denn das Runterfahren des Rechners nicht so verändern, das das APIC während des runterfahrens automatisch eingeschaltet wird?

Gruß
Eckhard!

obec
Advanced Hacker
Advanced Hacker
Beiträge: 1193
Registriert: 27. Dez 2005, 21:34
Wohnort: /home/obec

Beitrag von obec » 22. Feb 2008, 19:56

eckhard1 hat geschrieben: Zunächst erstmal die Frage, wo genau diese Parameter eingetragen werden müssen, wie gesagt - ich habe noch überhaupt keine Ahnung was Suse angeht.
Schau doch mal hier: http://wiki.linux-club.de/opensuse/Open ... ren_lassen

Gruß

obec
openSuSE 11.0
Mandriva Linux 2008 Spring
Gigabyte P35-DS3
Intel Pentium D Prozessor 3,40GHZ
4096 MB Arbeitsspeicher
Nvidia Geforce 7600GS 512MB

acoofh
Newbie
Newbie
Beiträge: 32
Registriert: 18. Mai 2006, 08:19

Beitrag von acoofh » 2. Mär 2008, 21:36

hallo,

wollt da auch mal noch was einwerfen.
bei mir klappt das leider alles nicht.
apm wir vom kernel nicht unterstützt....
aber ich hab da was anderes.

wenn ich den treiber für den fritz wlan usb stick stoppe

Code: Alles auswählen

rmmod fwlanusb
und dann die kiste herunterfahre klappt es ohne probleme.
vergess ich das...bleibt er beim herunterfahren stehen.

vielleicht hat ja hierzu jemand ne idee

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste