Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Howto: XEN3 mit virtuellen Netzwerken unter SuSE 10.1

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
sbehnam73
Newbie
Newbie
Beiträge: 3
Registriert: 23. Dez 2006, 16:35

Howto: XEN3 mit virtuellen Netzwerken unter SuSE 10.1

Beitrag von sbehnam73 » 23. Dez 2006, 22:02

Hier beschreibe ich die Installation von XEN3 und das Einrichten von virtuellen Netzwerken samt Firewalling und Routing unter SuSE 10.1 (remastered) und höher. Der Beitrag ist zwar auf englisch aber auf Wunsch würde ich ihn auch auf deutsch rausbringen, wenn Bedarf besteht (ab 25 Anfragen :) ).

http://en.opensuse.org/Xen3_yet_another ... rk_Concept

Zurzeit läuft das Ganze bei mir mit 3 Udoms, wo ich einen abgehärteten Apache auf einer dieser Udoms laufen habe. Am besten hier mal einen Blick darauf werfen:

http://sbehnam73.homelinux.org

Viel Spass!

Werbung:
Mr.Tito
Member
Member
Beiträge: 98
Registriert: 30. Okt 2006, 06:54
Wohnort: Schaumburg

Beitrag von Mr.Tito » 1. Jan 2007, 09:08

Hallo Saman,

erstmal freut es mich, dass mal jemand was mit Xen macht, ich bin jedenfalls begeistert davon.
Mit englisch tue ich mich etwas schwer. Wenn ich einer bin, der die 25 für die Übersetzung mit vollmacht, dann freue ich mich
Ich habe selbst eine alte Kiste mit 3 DomU's laufen. Was mir leider nicht gelang (ich habe hier im Forum schon nachgefragt -> keine Lösung) ist, ein Image zu kopieren, in der Konfiguration eine andere Mac-Adresse vergeben uns so einen neuen virtuellen Rechner aufzusetzen. Irgendwie bleibt die alte Mac-Adresse bestehen, keine Ahnung wo die herkommt.

Was mir dann noch zu meine Glück fehlt, ist, eine PCI-Karte (Fritz PCI) in einer DomU zu benutzen. Alles, was man so findet mit pciback.hide, scheint bei Suse (10.1 & 10.2) nicht zu funktionieren: unknown boot-Option oder so ähnlich wird beim Start vom Dom0 gemeldet. Dazu gabs hier auch noch keine Lösung.

Wenn Du die Lösung eines meiner Probleme kennst oder einen Tip hast, würde ich mich über eine Antwort freuen.
In jedem Fall schonmal einen guten Rutsch ins neue Jahr.
Gruß von
Thomas

sbehnam73
Newbie
Newbie
Beiträge: 3
Registriert: 23. Dez 2006, 16:35

Beitrag von sbehnam73 » 1. Jan 2007, 17:29

Hi Tomas,

Das ist schon richtig XEN ist cool, da die extra laufenden Kernel in Echtzeit laufen (wichtig bei Firewalling und TCP stream filtering und analyzing ... etc. ..... das kann man sehr gut beobachten, wenn man die CPU Zeiten mit top in allen Dom's anschaut und verschiedene CPU zeitintensive Prozesse in den verschidenen Doms startet ... es wird zu keinem Zeitpunkt irgend ein anderer Kernel ausgebremst!). Bei usermode Linux ist das zum Beispiel nicht der Fall und auch nicht bei all den emulatoren VMware ... etc ...

Du bist noch nicht der 25te, aber ich arbeite trotzdem schon daran.

Ein image kopieren und als eine weitere domu laufen zu lassen sollte kein Problem sein, so habe ich es auch bei jeder weitren Domu bei mir auch gemacht. Du musst nur bei den folgenden Punkten aufpassen!

- Du legst eine neue config Datei für die neue Domu an (am besten Du kopierst eine bestehende config Datei und passt sie an.)

- Bei der disk Direktive gibst Du die unter neuem Namen kopierte Image Datei an

- bei memory musst du aufpassen, dass Du nicht deine RAM-Grenzen sprengst .... achte auf die Logs, wenns dann nicht hochfährt!

- bei name sollte auch ein neuer Name drin stehen.

- bei vif trägst Du eine neue mac adresse ein und evtl. auch in welcher bridge die nic sein soll.

Wenn das Ding bootet, dann hast Du schon mal fürs Erste gewonnen, aber wir sind nocht fertig!

Nach dem Booten sind natürlich im neuen System die alten Einstellungen noch drin. (ähnlich dem, wenn du eine Netzwrkkarte bei einem schon installierten Rechner auswechselst)

Das Problem mit der Netzwerkkarte ist einfach zu erklären!

- Es geht um, einen meiner Meinung nach, einen Bug im udev System von SuSE seit Einführung von udev. Das hätte ich im Howto auch erwähnen sollen.

- Also jetzt nach /etc/udev/rules.d wechseln und in der Datei 30-net_persistent_names.rules die alten Einträge der alten nic löschen, am besten alle Einträge löschen.

- Danach mit yast oder wie auch immer ( ifconfig bzw. etc/sysconfig/network ) die alte Konfiguration der alten nic auch löschen.

- Die Domu rebooten, damit hwscan ...etc... die nic jetzt neu erkennt.

- Mit yast bzw. ifconfig jetzt die neue nic einrichten ....

- Ab jetzt sollte es gehen und in udev ist auch die neue nic jetzt auch drin.

- Apropos. nic = Netzwerkkarte

- Man kann die Konfiguration einer nic (z.B. damit eine als eth0 konfigurierte nic bei Ändern der Netzwerkkonfiguration danach immer noch eth0 bleibt und nicht auf einmal eth1... wird und die Netzwerkkonfiguration durcheinander kommt) fixieren in dem man in der config Datei der entsprechnen nic unter /etc/sysconfig/network den Eintrag PERSISTENT_NAME='eth0' schreibt. In diesem Beispielfall wird die nic als eth0 konfiguriert.

Die Option pciback.hide wird wie ein Treibermodul unter SusE bahandelt, d.h. ähnlich dem Laden eines Treibermoduls zur Kernellaufzeit bzw. Booten und das gibt man in modprobe.conf bzw. besser (wenn das System z.B. upgedatet bzw. migriert werden sollte) modprobe.conf.local. Diese Dateien liegen bei SuSE direkt unter /etc. Bitte nicht mit modules.conf verwechseln, diese gibts nämlich bei anderen Distributionen.

Die SuSE Leute kompilieren u.a. ihre Kernel etwas anders als ein Debian Kernel und zwingen die Benutzer einbischen, sich an ihr Konzept zu halten, was ja nicht das schlechteste ist, solange es opensource bleibt. SuSE ist halt etwas domestizierter als Debian z.B. :) . Spass bei Seite! Deshalb geht das nicht, das als Bootoption an den Kernel zu übergeben.

- Hier ein Beispiel für eine LAN Karte mit dem Treibermodul namens skge. Wie der Treibermodulname für dein an die entsprechende Domu durchzureichnendes Gerät heißt, bekommst Du raus mit lsmod in Dom0, bevor Du das Gerät versteckst (hidest!). Die folgenden Einträge sind in der /etc/modprobe.conf.local vorzunehmen.

# hide (0000:06:02.0)
options pciback hide=(0000:06:02.0)
install skge /sbin/modprobe pciback ; /sbin/modprobe --first-time --ignore-install skge
options netloop nloopbacks=128

Da ich noch nicht vor der Situation gestanden bin, eine ISDN-Karte an eine Domu durchzureichen, weiss ich auch nicht genau wie das von pcifront bzw. Hardwareerkennung innerhalb der Domu zu handhaben ist. Ich meine es gibt noch den Parameter bzw. die Direktive pci, die man in der Domu config Datei angeben kann, um hardware zuzuweisen, aber die Details dazu müsstest Du ergoogeln.

Hoffe des hilft etwas!

Schönen Gruß und ein gutes neues Jahr

Saman

SuseFan15
Member
Member
Beiträge: 204
Registriert: 15. Dez 2005, 16:57
Wohnort: Wien
Kontaktdaten:

Beitrag von SuseFan15 » 2. Jan 2007, 14:05

ich würde mich auch über ein deutsches tutorial freuen... ich kann zwar recht gut englisch (denk ich mal)... aber sowas fachspezifisches liest sich doch auf deutsch leichter (aber plz nicht die ganzen fachbegriffe eindeutschen.. das hasse ich ^^)

mfg, bernhard
Asus Z9252VA, Intel Centrino 1,73GHz, 2048MB DDR2 533MHz, ATI Radeon X700 128MB, 100 GB HD, openSuse 10.3, WinXP
Pentium D805@3,9GHz (Zalman 9700LED), Abit Al8-V, 2GB DDR2@667MHz, Geforce 8800GTS(640), 80GB SATAII, openSUSE 10.3, WinXP, WinVista

Mr.Tito
Member
Member
Beiträge: 98
Registriert: 30. Okt 2006, 06:54
Wohnort: Schaumburg

pciback.hide

Beitrag von Mr.Tito » 2. Jan 2007, 20:08

...die Lösung zu meiner Frage nach pci-Karten in DomU:
In /etc/sysconfig/kernel
muss dem Parameter INITRD_MODULES einfach pciback hinzugefügt werden. Nach mkinitrd und Neustart greift auch das pciback.hide in menu.lst und man kann seine Karte mit pci=... in der DomU benutzen (-> Xen-Doku).

Danke und Gruß
Thomas

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast