Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Problem mit Azureus Beta 2.5.0.1_B40

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
Xclone
Newbie
Newbie
Beiträge: 20
Registriert: 24. Apr 2005, 19:09
Wohnort: Ehingen an der Donau

Problem mit Azureus Beta 2.5.0.1_B40

Beitrag von Xclone » 19. Dez 2006, 13:04

System:10.2, x86_64
Hi wenn ich auf Datei öffnen gehe friert das gerade geöffnete Fenster ein. Es öffnet sich auch kein Fenster um denn torrent zu suchen. Dann friert Azureus komplett ein.

Hier mal die Ausgabe wenn ich Azureus aus der Konsole starte:
master@linux-mvvz:~> azureus
java virtual machine used: /usr/lib64/jvm/jre/bin/java
classpath used: /usr/share/java/Azureus/Azureus2.jar:/usr/share/java/Azureus/swt.jar
main class used: org.gudy.azureus2.ui.swt.Main
flags used:
options used: -Xms16m -Xmx128m -Djava.library.path=/usr/lib64/Azureus:/usr/lib/Azureus
arguments used:
Gott hat den Menschen erschaffen, weil er vom Affen enttäuscht war. Danach hat er auf weitere Experimente verzichtet.

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 19. Dez 2006, 13:12

poste mal den Inhalt von der Log-Datei aus /tmp/Azureus.log
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
Xclone
Newbie
Newbie
Beiträge: 20
Registriert: 24. Apr 2005, 19:09
Wohnort: Ehingen an der Donau

Beitrag von Xclone » 19. Dez 2006, 13:43

Hier die Log-Datei:
[plug] [UPnP] UPnP: Zuordnung 'Eingehender Datenport für Quellen (UDP/9960)' fehlgeschlagen
DEBUG::Tue Dec 19 13:36:35 CET 2006::com.aelitis.azureus.plugins.upnp.UPnPPluginService::checkMapping::266:
com.aelitis.net.upnp.UPnPException: Invoke of 'urn:schemas-upnp-org:service:WANIPConnection:1#AddPortMapping' fails: HTTP request failed:HTTP/1.1 500 Internal Server Error
at com.aelitis.net.upnp.impl.services.UPnPActionInvocationImpl.invoke(UPnPActionInvocationImpl.java:134)
at com.aelitis.net.upnp.impl.services.UPnPSSWANConnectionImpl.addPortMapping(UPnPSSWANConnectionImpl.java:319)
at com.aelitis.azureus.plugins.upnp.UPnPPluginService.checkMapping(UPnPPluginService.java:234)
at com.aelitis.azureus.plugins.upnp.UPnPPlugin.checkState(UPnPPlugin.java:1125)
at com.aelitis.azureus.plugins.upnp.UPnPPlugin.addService(UPnPPlugin.java:1012)
at com.aelitis.azureus.plugins.upnp.UPnPPlugin.processServices(UPnPPlugin.java:947)
at com.aelitis.azureus.plugins.upnp.UPnPPlugin.processDevice(UPnPPlugin.java:907)
at com.aelitis.azureus.plugins.upnp.UPnPPlugin.processDevice(UPnPPlugin.java:913)
at com.aelitis.azureus.plugins.upnp.UPnPPlugin.processDevice(UPnPPlugin.java:913)
at com.aelitis.azureus.plugins.upnp.UPnPPlugin.rootDeviceFound(UPnPPlugin.java:699)
at com.aelitis.net.upnp.impl.UPnPImpl$1.runSupport(UPnPImpl.java:237)
at org.gudy.azureus2.core3.util.AERunnable.run(AERunnable.java:38)
at org.gudy.azureus2.core3.util.ThreadPool$threadPoolWorker$1.runSupport(ThreadPool.java:523)
at org.gudy.azureus2.core3.util.AEThread.run(AEThread.java:69)
Caused by: java.io.IOException: HTTP request failed:HTTP/1.1 500 Internal Server Error
at com.aelitis.net.upnp.impl.UPnPImpl.performSOAPRequest(UPnPImpl.java:727)
at com.aelitis.net.upnp.impl.UPnPImpl.performSOAPRequest(UPnPImpl.java:588)
at com.aelitis.net.upnp.impl.services.UPnPActionInvocationImpl.invoke(UPnPActionInvocationImpl.java:98)
... 13 more

[alert] Alert:3:UPnP: Zuordnung 'Eingehender Datenport für Quellen (UDP/9960)' fehlgeschlagen
[plug] [UPnP] UPnP: Zuordnung 'Eingehender Datenport für Quellen (TCP/9960)' fehlgeschlagen
DEBUG::Tue Dec 19 13:36:35 CET 2006::com.aelitis.azureus.plugins.upnp.UPnPPluginService::checkMapping::266:
com.aelitis.net.upnp.UPnPException: Invoke of 'urn:schemas-upnp-org:service:WANIPConnection:1#AddPortMapping' fails: HTTP request failed:HTTP/1.1 500 Internal Server Error
at com.aelitis.net.upnp.impl.services.UPnPActionInvocationImpl.invoke(UPnPActionInvocationImpl.java:134)
at com.aelitis.net.upnp.impl.services.UPnPSSWANConnectionImpl.addPortMapping(UPnPSSWANConnectionImpl.java:319)
at com.aelitis.azureus.plugins.upnp.UPnPPluginService.checkMapping(UPnPPluginService.java:234)
at com.aelitis.azureus.plugins.upnp.UPnPPlugin.checkState(UPnPPlugin.java:1125)
at com.aelitis.azureus.plugins.upnp.UPnPPlugin.addService(UPnPPlugin.java:1012)
at com.aelitis.azureus.plugins.upnp.UPnPPlugin.processServices(UPnPPlugin.java:947)
at com.aelitis.azureus.plugins.upnp.UPnPPlugin.processDevice(UPnPPlugin.java:907)
at com.aelitis.azureus.plugins.upnp.UPnPPlugin.processDevice(UPnPPlugin.java:913)
at com.aelitis.azureus.plugins.upnp.UPnPPlugin.processDevice(UPnPPlugin.java:913)
at com.aelitis.azureus.plugins.upnp.UPnPPlugin.rootDeviceFound(UPnPPlugin.java:699)
at com.aelitis.net.upnp.impl.UPnPImpl$1.runSupport(UPnPImpl.java:237)
at org.gudy.azureus2.core3.util.AERunnable.run(AERunnable.java:38)
at org.gudy.azureus2.core3.util.ThreadPool$threadPoolWorker$1.runSupport(ThreadPool.java:523)
at org.gudy.azureus2.core3.util.AEThread.run(AEThread.java:69)
Caused by: java.io.IOException: HTTP request failed:HTTP/1.1 500 Internal Server Error
at com.aelitis.net.upnp.impl.UPnPImpl.performSOAPRequest(UPnPImpl.java:727)
at com.aelitis.net.upnp.impl.UPnPImpl.performSOAPRequest(UPnPImpl.java:588)
at com.aelitis.net.upnp.impl.services.UPnPActionInvocationImpl.invoke(UPnPActionInvocationImpl.java:98)
... 13 more

[alert] Alert:3:UPnP: Zuordnung 'Eingehender Datenport für Quellen (TCP/9960)' fehlgeschlagen

(SWT:5257): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width 250 and height -1
Exception in thread "main" java.lang.UnsatisfiedLinkError: _g_idle_add
at org.eclipse.swt.internal.gtk.OS._g_idle_add(Native Method)
at org.eclipse.swt.internal.gtk.OS.g_idle_add(OS.java:1572)
at org.eclipse.swt.widgets.FileDialog.openChooserDialog(FileDialog.java:325)
at org.eclipse.swt.widgets.FileDialog.open(FileDialog.java:300)
at org.gudy.azureus2.ui.swt.OpenTorrentWindow$2.handleEvent(OpenTorrentWindow.java:333)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:66)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1095)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3226)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2898)
at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.<init>(SWTThread.java:134)
at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.createInstance(SWTThread.java:68)
at org.gudy.azureus2.ui.swt.mainwindow.Initializer.<init>(Initializer.java:107)
at org.gudy.azureus2.ui.swt.Main.<init>(Main.java:80)
at org.gudy.azureus2.ui.swt.Main.main(Main.java:180)
/usr/share/java-utils/java-functions: line 117: 5257 Getötet $JAVACMD $FLAGS -classpath $CLASSPATH $OPTIONS $MAIN_CLASS "$@"


das mit denn Smilies war ich nicht.
Gott hat den Menschen erschaffen, weil er vom Affen enttäuscht war. Danach hat er auf weitere Experimente verzichtet.

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 19. Dez 2006, 14:07

deswegen stürzt Azureus ab/hängt.

Code: Alles auswählen

...
Exception in thread "main" java.lang.UnsatisfiedLinkError: _g_idle_add ...
das heisst diese Bibliothek welche diese Funktion beinhaltet, scheint bei dir nicht zu existieren oder ist in einer falschen Version verfügbar. Diese Funktion ist soweit ich das weiss in glib2 enthalten.

Du kannst mal in deinem Azureus.sh Startscript folgendes ergänzen in den Optionen:

Code: Alles auswählen

-Djava.library.path=/usr/lib64/Azureus:/usr/lib/Azureus:/opt/gnome/lib64:/opt/gnome/lib 
d.h. wir erweitern den Pfad um die /opt/gnome Bibliotheken
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
Xclone
Newbie
Newbie
Beiträge: 20
Registriert: 24. Apr 2005, 19:09
Wohnort: Ehingen an der Donau

Beitrag von Xclone » 19. Dez 2006, 14:27

leider bleibt es beim alten das Fenster und Azureus friert ein.

log:
(SWT:15706): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width 250 and height -1
Exception in thread "main" java.lang.UnsatisfiedLinkError: _g_idle_add
at org.eclipse.swt.internal.gtk.OS._g_idle_add(Native Method)
at org.eclipse.swt.internal.gtk.OS.g_idle_add(OS.java:1572)
at org.eclipse.swt.widgets.FileDialog.openChooserDialog(FileDialog.java:325)
at org.eclipse.swt.widgets.FileDialog.open(FileDialog.java:300)
at org.gudy.azureus2.ui.swt.OpenTorrentWindow$2.handleEvent(OpenTorrentWindow.java:333)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:66)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1095)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3226)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2898)
at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.<init>(SWTThread.java:134)
at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.createInstance(SWTThread.java:68)
at org.gudy.azureus2.ui.swt.mainwindow.Initializer.<init>(Initializer.java:107)
at org.gudy.azureus2.ui.swt.Main.<init>(Main.java:80)
at org.gudy.azureus2.ui.swt.Main.main(Main.java:180)
/usr/share/java-utils/java-functions: line 117: 15706 Getötet $JAVACMD $FLAGS -classpath $CLASSPATH $OPTIONS $MAIN_CLASS "$@"
Gott hat den Menschen erschaffen, weil er vom Affen enttäuscht war. Danach hat er auf weitere Experimente verzichtet.

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 19. Dez 2006, 14:45

da dieses Verhalten nur bei 64bit Systemen auftriit, ist es vielleicht ein BUG im Azureus und/oder swt.

evtl mal in der Azureus Mailingliste oder Azureus IRC nachfragen.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Haegar
Member
Member
Beiträge: 74
Registriert: 11. Nov 2006, 12:21

Beitrag von Haegar » 19. Dez 2006, 18:30

Ich habe übrigens genau das gleiche Problem.
Auch mit Suse 10.2 64Bit....hat anscheinend doch was damit zu tun

Haegar

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 19. Dez 2006, 19:10

könnt ihr diese Datei mal downloaden:
http://torrents.aelitis.com:88/files/Az ... 01-B41.jar

und nach /usr/share/java/Azureus2.jar kopieren ?
wenn das eine Besserung bringt würde ich ein neues Paket erstellen.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
Xclone
Newbie
Newbie
Beiträge: 20
Registriert: 24. Apr 2005, 19:09
Wohnort: Ehingen an der Donau

Beitrag von Xclone » 19. Dez 2006, 19:56

Erst mal Danke für deine Hilfe oc2pus, aber leider bringt auch die neue azureus2.jar keinen Erfolg. Das Problem mit dem einfrieren bleibt bestehen.
Gott hat den Menschen erschaffen, weil er vom Affen enttäuscht war. Danach hat er auf weitere Experimente verzichtet.

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 23. Dez 2006, 12:40

es gibt ein neues Azureus-libswt3-gtk2 Paket, welches dieses Problem nun beheben sollte.

http://packman.links2linux.de/package/A ... bswt3-gtk2
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Haegar
Member
Member
Beiträge: 74
Registriert: 11. Nov 2006, 12:21

Beitrag von Haegar » 24. Dez 2006, 10:43

Also mit dem Update vom 23.12.2006 startet Azureus garnicht mehr bei mir. Suse 10.2 64Bit
Wenn ich es auf der Konsole starte kommen folgende Meldungen:

Code: Alles auswählen

haegar@dhcppc0:~> azureus
java virtual machine used: /usr/lib64/jvm/jre/bin/java
classpath used: /usr/share/java/Azureus/Azureus2.jar:/usr/share/java/Azureus/swt.jar
main class used: org.gudy.azureus2.ui.swt.Main
flags used:
options used: -Xms16m -Xmx128m -Djava.library.path=/usr/lib64/Azureus:/usr/lib/Azureus
arguments used:
haegar@dhcppc0:~> 
Er steigt einfach ohne Fehlermeldung aus

Haegar

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 25. Dez 2006, 13:16

Haegar hat geschrieben:Er steigt einfach ohne Fehlermeldung aus
nö, die stehen in /tmp/Azureus.log
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

green_johnny
Newbie
Newbie
Beiträge: 2
Registriert: 26. Dez 2006, 13:41

Beitrag von green_johnny » 26. Dez 2006, 13:51

Haegar hat geschrieben:Also mit dem Update vom 23.12.2006 startet Azureus garnicht mehr bei mir. Suse 10.2 64Bit
Wenn ich es auf der Konsole starte kommen folgende Meldungen:

Code: Alles auswählen

haegar@dhcppc0:~> azureus
java virtual machine used: /usr/lib64/jvm/jre/bin/java
classpath used: /usr/share/java/Azureus/Azureus2.jar:/usr/share/java/Azureus/swt.jar
main class used: org.gudy.azureus2.ui.swt.Main
flags used:
options used: -Xms16m -Xmx128m -Djava.library.path=/usr/lib64/Azureus:/usr/lib/Azureus
arguments used:
haegar@dhcppc0:~> 
Er steigt einfach ohne Fehlermeldung aus

Haegar
Hallo, bei meinen SuSE 10.2 x86_64 leider die gleiche Meldung und kein Fenster in Sicht.

urbanswelt
Member
Member
Beiträge: 112
Registriert: 17. Jul 2006, 17:52
Wohnort: Bernbeuren
Kontaktdaten:

Beitrag von urbanswelt » 27. Dez 2006, 21:11

Oje hätte vom Systemupdate gerade absehen müssen ... nun geht mein Azureus auch nicht mehr ;D ... bin mal gespannt an was das liegt.

Code: Alles auswählen

Exception in thread "main" java.lang.NoSuchMethodError: fixedClassInitProc
	at org.eclipse.swt.internal.Callback.bind(Native Method)
	at org.eclipse.swt.internal.Callback.<init>(Callback.java:123)
	at org.eclipse.swt.internal.Callback.<init>(Callback.java:78)
	at org.eclipse.swt.internal.Callback.<init>(Callback.java:60)
	at org.eclipse.swt.widgets.Display.createDisplay(Display.java:816)
	at org.eclipse.swt.widgets.Display.create(Display.java:789)
	at org.eclipse.swt.graphics.Device.<init>(Device.java:152)
	at org.eclipse.swt.widgets.Display.<init>(Display.java:460)
	at org.eclipse.swt.widgets.Display.<init>(Display.java:451)
	at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.<init>(SWTThread.java:91)
	at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.createInstance(SWTThread.java:68)
	at org.gudy.azureus2.ui.swt.mainwindow.Initializer.<init>(Initializer.java:107)
	at org.gudy.azureus2.ui.swt.Main.<init>(Main.java:80)
	at org.gudy.azureus2.ui.swt.Main.main(Main.java:180)
hier mein log
AMD C-60 APU with Radeon(tm) HD Graphics , RAM 4gb , ATI SBx00 Azalia (Intel HDA) ,Linux 3.1.9-1.4-desktop x86_64, Distri openSUSE 12.1Bild

green_johnny
Newbie
Newbie
Beiträge: 2
Registriert: 26. Dez 2006, 13:41

Beitrag von green_johnny » 27. Dez 2006, 21:44

Hallo,

ich konnte mit dem direkten Download des Tarballs von Azureus nach Vorlage der Readme es zum Laufen bekommen.

RUNNING:
1. Extract the contents of this .tar.bz2 file.
2. Change to the 'azureus' directory where the files were extracted.
3. Start Azureus by running the script named 'azureus'; ex. "./azureus"

Gruß
Green_Johnny

urbanswelt
Member
Member
Beiträge: 112
Registriert: 17. Jul 2006, 17:52
Wohnort: Bernbeuren
Kontaktdaten:

Beitrag von urbanswelt » 27. Dez 2006, 22:28

Das freut mich =) ... jedoch löst das nicht das bestehende Problem, das Azureus mittels apt installiert wird ,wurde und nach einem update nicht mehr funktioniert ;)
AMD C-60 APU with Radeon(tm) HD Graphics , RAM 4gb , ATI SBx00 Azalia (Intel HDA) ,Linux 3.1.9-1.4-desktop x86_64, Distri openSUSE 12.1Bild

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 28. Dez 2006, 12:16

Jungs, jetzt seid doch mal nicht so ungeduldig ...

der Fehler ist lokalisiert !
Eine neue Version wird kommen ... also stay tuned :mrgreen:

es würde alles etwas schneller gehen, wenn sich hier
http://www.linux-club.de/viewtopic.php?t=70497
mehr Leute melden würden... c'est la vie
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Haegar
Member
Member
Beiträge: 74
Registriert: 11. Nov 2006, 12:21

Beitrag von Haegar » 2. Jan 2007, 18:45

Hallo,

es gibt mittlerweile bei Packman eine neue Version von Azureus...jetzt die Azureus-2.5.0.1-B50.pm.1.noarch.rpm.
Bei mir (10.2 64Bit Java 1.5 64Bit) bringt das Update aber keine Änderung...d.h. das Programm fängt an zu laden und bricht einfach wieder ab mit laden (Fehlermeldungen siehe die anderen Antworten).
Allerdings funktioniert dass runtergeladene File von der Azureus Homepage ohne Probleme.

Das alle nur als kleines "Update" zu diesem Thread, der ja noch nicht gelöst ist...

Haegar

Haegar
Member
Member
Beiträge: 74
Registriert: 11. Nov 2006, 12:21

Beitrag von Haegar » 6. Jan 2007, 20:26

Weiteres Update:

Mit dem Update der Pakete vom Packman vom 6.01.2007 (Azureus-2.5.0.1-B53.pm.1.noarch.rpm und Azureus-libswt3-gtk2-3.3M4_I20061214_1445-0.pm.3.x86_64.rpm) bleibt das oben beschriebene Problem weiterhin bestehen...

Wie siehts bei den anderen aus?
Gibt mal irgendjemand einen Kommentar dazu...

Haegar

urbanswelt
Member
Member
Beiträge: 112
Registriert: 17. Jul 2006, 17:52
Wohnort: Bernbeuren
Kontaktdaten:

Beitrag von urbanswelt » 6. Jan 2007, 22:50

Jup das selbe :/
AMD C-60 APU with Radeon(tm) HD Graphics , RAM 4gb , ATI SBx00 Azalia (Intel HDA) ,Linux 3.1.9-1.4-desktop x86_64, Distri openSUSE 12.1Bild

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste