Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[Gelöst] Suse 10.2 mit VMware und USB (war: USB zickt rum)

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Jochen-of-Borg
Member
Member
Beiträge: 135
Registriert: 25. Okt 2005, 12:00

[Gelöst] Suse 10.2 mit VMware und USB (war: USB zickt rum)

Beitrag von Jochen-of-Borg » 14. Dez 2006, 19:54

Hallo!

Ich weiß, der Betreff ist etwas unscharf.. aber mein Problem schon etwas merkwürdig...
Also, ich hab Suse 10.2, und seit gestern macht mein USB Probleme.

Was nicht mehr funktioniert:
Cups meint zu meinem USB-Drucker nur noch "Printer not connected; will retry in 30 seconds..."
VMWare Workstation zeigt plötzlich kein einziges USB-Gerät mehr an!

Was geht:
Der USB-Controller wird erkannt, die USB-Maus geht und der Speicherstick geht auch.

Code: Alles auswählen

jochen:~ # lsusb
Bus 003 Device 002: ID 05a9:a511 OmniVision Technologies, Inc. OV511+ WebCam
Bus 003 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
Bus 002 Device 014: ID 090c:1000 Feiya Technology Corp. Memory Bar
Bus 002 Device 013: ID 03f0:1204 Hewlett-Packard DeskJet 930c
Bus 002 Device 011: ID 046d:c501 Logitech, Inc. Cordless Mouse Receiver
Bus 002 Device 010: ID 05fe:0011 Chic Technology Corp. Browser Mouse
Bus 002 Device 009: ID 04e1:0201 Iiyama North America, Inc. Monitor Hub
Bus 002 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Stecke ich zb den Drucker an, wird es auch in /var/log/messages angezeigt. Nur interessiert es halt weder cups noch VMWare :(


Was kann das sein?
(Unter Windows geht der Drucker übrigens noch)
Zuletzt geändert von Jochen-of-Borg am 16. Dez 2006, 13:21, insgesamt 2-mal geändert.

Werbung:
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 3986
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Beitrag von misiu » 15. Dez 2006, 10:45

Läuft Linux in der VM auf Windows basis?
Wenn ja , dann dürfte es an VMWare liegen, die die USB-Aufrufe nicht
weiter an das Wirtsystem abgibt. Schau dich nach Patches
bei denen um, bzw. schreibe deren Support an.

Ich verschiebe es mal in "Emulatoren"

MfG
misiu

Jochen-of-Borg
Member
Member
Beiträge: 135
Registriert: 25. Okt 2005, 12:00

Beitrag von Jochen-of-Borg » 15. Dez 2006, 11:39

> Läuft Linux in der VM auf Windows basis?

Nö, Linux ist der Host.
USB geht unter VMWare nicht mehr, egal mit welchem Gastsystem.

> Ich verschiebe es mal in "Emulatoren"

Keine wirklich gute Idee...
Cups mag meinen USB-Drucker nämlich zZ auch nicht. Unabhängig von VMWare!

Die lsusb-Ausgabe oben war übrigens nicht aus VMWare, sondern vom Hostsystem.

Edit: Ich hab Cups neu installiert, jetzt geht mein Drucker wieder! :D

Jetzt bleibt doch nur noch das Problem, daß VMWare keinen Zugriff auf die USB-Geräte hat.

stefan.becker
Advanced Hacker
Advanced Hacker
Beiträge: 1140
Registriert: 12. Mär 2006, 17:23

Beitrag von stefan.becker » 15. Dez 2006, 20:42

Code: Alles auswählen

usbfs                /proc/bus/usb        usbfs      auto                  0 0
Klimper mal genau diese Zeile in die Datei /etc/fstab ein.

Jochen-of-Borg
Member
Member
Beiträge: 135
Registriert: 25. Okt 2005, 12:00

Beitrag von Jochen-of-Borg » 15. Dez 2006, 23:50

Hat leider nichts gebracht :(

Aber ich hab in einem anderen Forum was gefunden: (http://www.vmware.com/community/thread. ... eID=531130)
Users of openSUSE 10.2 will have to recompile the kernel if they require USB support to work in WS5.5.x. The openSUSE people maintain that VMware was well aware of the change but the latest release, WS5.5.3, does not take account of the change.
Klingt nicht gut....
Ich wundere mich nur, daß ich anscheinend der erste hier mit dem Problem bin.

Hat hier wer Suse 10.2 (als host) mit VMware Workstation und USB am laufen?

Jochen-of-Borg
Member
Member
Beiträge: 135
Registriert: 25. Okt 2005, 12:00

Beitrag von Jochen-of-Borg » 16. Dez 2006, 13:21

Problem gelöst! :D

Also, das Problem lag daran, da OpenSuse eine USB-Option als zu unsicher ansieht, VMWare diese in der aktuellen Version noch braucht.
Sprich: USB in VMware Workstation 5.5.3 unter Suse 10.2 funktioniert nicht!

Damit es geht, muß man selber einen Kernel bauen, in dem die Option "USB device filesystem (USB_DEVICEFS)" aktiviert ist.

In die /etc/fstab muß dann noch die Zeile
" /dev/bus/usb /proc/bus/usb usbfs defaults 0 0"
(Wie auch schon bei Suse 10.1, nur daß dies bei der 10.2 mit dem Standard-Kernel halt nicht funktioniert :evil: )


Mann, was für ein Aufwand... :roll:

jengelh
Guru
Guru
Beiträge: 4039
Registriert: 20. Nov 2004, 17:42
Kontaktdaten:

Beitrag von jengelh » 16. Dez 2006, 15:46


JochenH
Newbie
Newbie
Beiträge: 8
Registriert: 23. Apr 2006, 08:26
Wohnort: Bayern

Beitrag von JochenH » 16. Dez 2006, 20:36

Damit es geht, muß man selber einen Kernel bauen, in dem die Option "USB device filesystem (USB_DEVICEFS)" aktiviert ist.
Und was mache ich jetzt?

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste