Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

reiferfs-Modul nicht gefunden

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
internal32
Newbie
Newbie
Beiträge: 6
Registriert: 15. Nov 2006, 12:53

reiferfs-Modul nicht gefunden

Beitrag von internal32 » 16. Nov 2006, 12:54

Hallo,

nachdem ich mir gestern einen Kernel gebacken habe, scheint soweit auch alles zu funktionieren (Vanilla-Kernel 2.6.13 mit Xenomai-Patch unter openSuse 10.1), und das obwohl es beim "make modules_install install" eine Fehlermeldung gab (zweimal direkt hintereinander):

"cannot determine dependencies of module reiserfs. Is modules.dep up to date?"

reiserfs ist allerdings fest in den kernel eingebunden (nicht als Modul), und der Kernel liest das reiserfs-Dateisystem auch ohne Probleme.

Wie kommt es zu dem Fehler, bzw. kann man ihn irgendwie beheben?


Eine Frage hätte ich auch noch zu APIC:

Da ich keinen solchen in meinem System habe (und weil sonst Xenomai nicht funktioniert), erstelle ich mir gerade einen neuen Kernel ohne APIC-Unterstützung. Was muss ich da alles weglassen? Ich habe in menuconfig nur zwei Punkte gefunden (unter "Processor Architecture" oder so ähnlich). Ist da noch irgendwo etwas versteckt oder war es das schon (hatte mal etwas von drei Punkten in der .config gelesen)?

Werbung:
jengelh
Guru
Guru
Beiträge: 4039
Registriert: 20. Nov 2004, 17:42
Kontaktdaten:

Beitrag von jengelh » 16. Nov 2006, 15:04

Mal `depmod -a` machen.

internal32
Newbie
Newbie
Beiträge: 6
Registriert: 15. Nov 2006, 12:53

Beitrag von internal32 » 16. Nov 2006, 15:52

Danke für den Tipp! Leider ist trotzdem noch alles unverändert, der Fehler wird immer noch gemeldet.

Leviathan
Hacker
Hacker
Beiträge: 510
Registriert: 30. Aug 2006, 15:30
Wohnort: Nürnberg

Beitrag von Leviathan » 16. Nov 2006, 15:58

Fehlermeldung kommt vlt. vom initrd-erstellen.

Check mal /etc/sysconfig/kernel
ob er reiserfs als modul in die initrd mit einbinden will.

Ansonsten mal in die modules.dep gucken ob da alles stimmt ..

Gruß Dominik

Freecoffee
Guru
Guru
Beiträge: 1750
Registriert: 29. Sep 2004, 17:00
Wohnort: Bayern

Beitrag von Freecoffee » 17. Nov 2006, 08:41

Kommt definitiv von der initrd, da ist das Dateisystem-Modul nämlich eingetragen und existiert nun nicht. Kannst du aber in diesem Fall ignorieren.
Gruß, Freecoffee

internal32
Newbie
Newbie
Beiträge: 6
Registriert: 15. Nov 2006, 12:53

Beitrag von internal32 » 17. Nov 2006, 08:42

In der /etc/sysconfig/kernel heißt es:
"INITRD_MODULES="piix processor thermal fan reiserfs edd"

Bei einem erneuten Kompiliervorgang kam jetzt die selbe Fehlermeldung, diesmal für: processor, thermal, fan, reiserfs, processor, thermal, fan, reiserfs

Gegenüber letztem Mal hab ich diesmal noch folgende Module weggelassen: apm, acpi, apic (da nicht in hardware vorhanden), kernel preemption ist auf voluntary, cpu freq. scaling, pci, pc-card, prozessor/register arguments, module versioning support, ext2, ext3

interrupt pipeline wollte ich auch weglassen, das lies sich aber nicht deaktivieren (--- statt [*] oder [M] oder [ ])

Der Kernel bootet, nach kurzer Zeit hängt aber dann das System...(wie schon beim letzten Kompilieren)...

internal32
Newbie
Newbie
Beiträge: 6
Registriert: 15. Nov 2006, 12:53

Beitrag von internal32 » 17. Nov 2006, 13:15

Hi freecoffee,

gut, dass ich Deinen Beitrag noch gefunden habe, wir hatten ja fast zeitgleich gepostet.

Danke für Deine Info! Offensichtlich konnte Linux ja auf die reiserfs-Partitionen zugreifen, insofern war es mehr ein "Schönheitsfehler".

Kennt sich jemand mit den anderen Symptomen aus? Warum das System hängt (wofür man vermutlich Hellseher sein müsste..) und warum jetzt noch mehr Fehlermeldungen kamen?

Und vor allem: Wie lässt sich Interrupt Pipeline einbinden?

Freecoffee
Guru
Guru
Beiträge: 1750
Registriert: 29. Sep 2004, 17:00
Wohnort: Bayern

Beitrag von Freecoffee » 17. Nov 2006, 14:40

Wenn du das pci-Modul weglässt, kann der PC auf keinerlei Komponenten am PCI-Bus mehr zugreifen, das ist überhaupt nicht empfehlenswert. ;)
Gruß, Freecoffee

internal32
Newbie
Newbie
Beiträge: 6
Registriert: 15. Nov 2006, 12:53

Beitrag von internal32 » 17. Nov 2006, 14:47

Das ist ein Argument! Ich überlege gerade, ich ich das ernsthaft weg gelassen habe...

Wobei das System aber vorher schon gehangen hat.

Danke für die Hilfe jedenfalls!

Vielleicht kennt sich ja noch jemand mit der "Interrupt Pipeline" aus, wie man die einbinden kann...

jengelh
Guru
Guru
Beiträge: 4039
Registriert: 20. Nov 2004, 17:42
Kontaktdaten:

Beitrag von jengelh » 17. Nov 2006, 17:08

Freecoffee hat geschrieben:Wenn du das pci-Modul weglässt, kann der PC auf keinerlei Komponenten am PCI-Bus mehr zugreifen, das ist überhaupt nicht empfehlenswert. ;)
Es sei denn dein IDE-Controller ist noch ISA. Äääh wo waren wir? Wieso nimmst du nicht einen schönen vorkompilierten Kernel (Werbung jen37 Werbung) wo alles dabei ist, oder kompilierst notfalls mit `make allmodconfig`?

internal32
Newbie
Newbie
Beiträge: 6
Registriert: 15. Nov 2006, 12:53

Beitrag von internal32 » 22. Nov 2006, 10:32

Ich hatte natürlich nicht PCI weggelassen, sondern nur ein Teilmodul, und es dann ungenau notiert. Ich habe inzwischen die Lösung gefunden - es war ein Bug, der in Kürze behoben wird.

Warum kein Standardkernel? Ich musste Xenomai mit einbinden.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste