Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

VMware und Internet

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
OmasEnkel
Hacker
Hacker
Beiträge: 572
Registriert: 19. Dez 2005, 14:59
Wohnort: Frankfurt
Kontaktdaten:

VMware und Internet

Beitrag von OmasEnkel » 6. Nov 2006, 09:33

Hallo,
ich habe mittels VMware Workstation ein virtuelles Windows XP. Die Netzwerkkarte sollte "bridged" sein. Leider komme ich aber nicht mit XP ins Internet. Wo ist der Fehler? Welche Angaben braucht Ihr?
So long,
OmasEnkel
--------------------

Werbung:
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach » 6. Nov 2006, 09:43

Wie geht denn der host ins Internet ? Wenn der über einen Router geht ist bridged i.a. OK. Sonst probier mal NAT.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !

OmasEnkel
Hacker
Hacker
Beiträge: 572
Registriert: 19. Dez 2005, 14:59
Wohnort: Frankfurt
Kontaktdaten:

Beitrag von OmasEnkel » 6. Nov 2006, 09:51

Der Host (also meine Linuxmaschine) ist selbst Router für einen Windowsrechner. Aber das Kabel für die DSL- Verbindung geht nicht mehr in einen Router, sondern direkt in den DSL- Anschluss.

Sollte es dann auch NAT sein?
Bei dem Gastsystem auf VM muss ich doch aber die Internetverbindung so einrichten, als wäre der Rechner real, oder? Also ganz normal eine Internetverbindung herstellen, oder?
So long,
OmasEnkel
--------------------

bolder
Member
Member
Beiträge: 120
Registriert: 20. Mär 2006, 09:08
Wohnort: Mainz

Beitrag von bolder » 6. Nov 2006, 11:43

Wenn du eine Bridged Verbindung wählst, dann bedeutet das, dass deine VM eine eigene IP-Adresse hat, die nach außen sichtbar sein soll.
Dein DSL-Anschluss lässt aber nur die eine IP-Adresse des Routers zu.
Deshalb musst du NAT verwenden.

Gruß
Olaf

OmasEnkel
Hacker
Hacker
Beiträge: 572
Registriert: 19. Dez 2005, 14:59
Wohnort: Frankfurt
Kontaktdaten:

Beitrag von OmasEnkel » 6. Nov 2006, 11:56

Die IP des Routers... ich hab doch garkeinen... Oder meinst Du, dass diese DSL- Kiste selbst eine IP hat?

Okay, aber wenn ich NAT verwende, wie muss ich dann auf dem virtuellen XP die Internetverbindung einrichten?
So long,
OmasEnkel
--------------------

bolder
Member
Member
Beiträge: 120
Registriert: 20. Mär 2006, 09:08
Wohnort: Mainz

Beitrag von bolder » 6. Nov 2006, 12:05

Du hast doch selbst geschrieben, dass dein Linux-Host der Router für die VM ist. Und der erhält seine IP-Adresse von deinem DSL-Provider.
Kannst du mit ifconfig abfragen.

Nach innen hat der Router dann auch eine Adresse (192.168.x.y)
Die erhält er, wenn du NAT konfiguriert hast.

Diese interne Adresse gibst du als Gatewayadresse in der VM ein und stellst diese auf DHCP - that's it!

Olaf

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast