Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] vmware-config.pl schllägt fehl.

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
G aus W
Hacker
Hacker
Beiträge: 346
Registriert: 3. Mai 2006, 10:39

[gelöst] vmware-config.pl schllägt fehl.

Beitrag von G aus W » 22. Okt 2006, 20:13

Hallo Forum,

nach einem Kernel-Update läßt sich VMWare bei mir nicht mehr starten.
Folgende Fehlermeldung kommt beim Ausführen von vmware-config.pl:

Code: Alles auswählen

make: Leaving directory `/tmp/vmware-config3/vmmon-only'
Unable to make a vmmon module that can be loaded in the running kernel:
insmod: error inserting '/tmp/vmware-config3/vmmon.o': -1 File exists
There is probably a slight difference in the kernel configuration between the
set of C header files you specified and your running kernel.  You may want to
rebuild a kernel based on that directory, or specify another directory.

For more information on how to troubleshoot module-related problems, please
visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
"http://www.vmware.com/support/reference/linux/prebuilt_modules_linux.html".
Die Tips auf den angegebenen Links mit "make cloneconfig" und "make modules_prepare" habe ich befolgt - selbes Ergebnis.
Martins hervorragendes HowTo habe ich gelesen und auch den any-any-Patch probiert - dennoch kein Erfolg. Fehlermeldung wie oben.
Kurios: Beim ersten Versuch nach einem Reboot läuft vmware-config.pl durch und bringt KEINEN Fehler. Wenn ich dann vmware starte, kommt dennoch die Meldung, ich müßte vmware-config-pl ausführen (was ich gerade habe!) Versuche ich es erneut, kommt der Fehler wieder wie beschrieben.

Was nun?

Hier noch die Infos zum Kernel:

Code: Alles auswählen

Anna:/home/Gregor/Desktop/vmware-any-any-update104 # uname -r
2.6.16.13-4-smp
Anna:/home/Gregor/Desktop/vmware-any-any-update104 # rpm -qa | grep kernel
kernel-default-2.6.16.13-4
kernel-bigsmp-2.6.16.13-4
kernel-smp-2.6.16.13-4
kernel-xenpae-2.6.16.13-4
kernel-xen-2.6.16.13-4
kernel-source-2.6.16.13-4
Ratlose Grüße...
Greg
Zuletzt geändert von G aus W am 22. Okt 2006, 22:40, insgesamt 1-mal geändert.

Werbung:
stefan.becker
Advanced Hacker
Advanced Hacker
Beiträge: 1140
Registriert: 12. Mär 2006, 17:23

Beitrag von stefan.becker » 22. Okt 2006, 21:07

Welche VMWARE Version?

jengelh
Guru
Guru
Beiträge: 4039
Registriert: 20. Nov 2004, 17:42
Kontaktdaten:

Beitrag von jengelh » 22. Okt 2006, 21:26

vmware-config sollte das `rmmod vmmon` eigentlich für dich machen...

Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Re: vmware-config.pl schllägt fehl.

Beitrag von Martin Breidenbach » 22. Okt 2006, 21:44

G aus W hat geschrieben:There is probably a slight difference in the kernel configuration between the set of C header files you specified and your running kernel.
Die Meldung besagt eigentlich daß die C header files (aus den Kernelquellen) nicht zum laufenden Kernle passen. Laut der weiter unten geposteten Kernelversionen passen die aber zusammen.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !

G aus W
Hacker
Hacker
Beiträge: 346
Registriert: 3. Mai 2006, 10:39

Beitrag von G aus W » 22. Okt 2006, 22:06

Danke schonmal an Euch, daß Ihr Euch meiner Sache angenommen habt.

Hier noch die fehlende Info: Es ist VMware-server-1.0.1-29996.

Mich wundert auch, daß die Anpassung auf den Kernel nicht automatisch klappt, ich habe mehrere Kernel-Updates gemacht, nach denen jeweils das vmware-config.pl ganz ohne Probleme durchgelaufen ist und die Sache war erledigt...

Vielleicht ein Wort zu den "verschiedenen" Kernels bei mir: Eigentlich brauche ich nur einen, den Xen-Kernel würde ich nicht benötigen, den hatte ich drin, als ich ein paar Häkchen im YAST zu viel gesetzt hab' - jetzt die Frage, kann ich den über YAST deinstallieren, ohne daß ich mir mein System abschieße? Welche Kernel-Pakete muß ich unbedingt drinlassen?

Martin hat recht - die Quellen sollten zum Kernel passen, soweit ich das als Laie sehen kann. Sehr dubios.

Immer noch ratlos grüßt Euch
Greg

G aus W
Hacker
Hacker
Beiträge: 346
Registriert: 3. Mai 2006, 10:39

Problem besteht nicht mehr.

Beitrag von G aus W » 22. Okt 2006, 22:46

Hallo Forenfreunde, lieber Martin, Jengelh und Stefan,

was genau vorhin quer geschossen hat, weiß ich nicht. Ich habe das Problem ruhen lassen und mich vorübergehend meiner anderen Baustelle gewidmet (ADS Tech Dual TV Cardbus PTV331 - hat mir lange Bauchschmerzen gemacht und geht jetzt endlich). Nach einer Neuinstallation der DVB-T-Treiber und einem weiteren Neustart habe ich dann erneut vmware-config.pl ausgeführt, und siehe da - diesmal war alles wie gewohnt, das Programm lief durch und anschließend startete vmware, als sei nichts gewesen.

Kann eine nicht korrekt erkannte DVB-T-Karte (PCI) solche Auswirkungen haben? Oder steckte meinem Pinguin einfach nur "ein Furz quer", wie man es eigentlich mehr von anderen Systemen her kennt, ich weiß es nicht. Ich freu' mich jetzt einfach, daß alles wieder geht, und sage Euch nochmal vielen Dank für Eure Hilfe!

Euer Greg

Antworten