Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] ssh + Invalid Port Numer

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
montykarlo
Newbie
Newbie
Beiträge: 34
Registriert: 14. Mär 2006, 16:31
Wohnort: Neckartailfingen

[gelöst] ssh + Invalid Port Numer

Beitrag von montykarlo » 18. Sep 2006, 21:10

Guten Abend,

ich möchte mich auf meinen Linux Server in Zukunft nur noch per Zertifikat einloggen. Habe mir das HowTo von framp zu Rate gezogen.
http://www.linux-club.de/ftopic65007.html
Leider scheitert es bei mir gleich nach der Erstellung der Schlüssel beim Export von Windows zu Linux mittels Putty Konsolenbefehl.

Code: Alles auswählen

putty>pscp id_rsa_public_linux monty@192.168.2.35:id_rsa_public
Nun kommt die Meldung "Invalid Port Number"
Irgendwann hatte schonmal jemand das Problem aber ich finde es nicht mehr.
Mein sshd lauscht auf Port 22
Gebe ich Port 22 explizit mit, geht es auch nicht

wer weiß rat?
Danke bis dann
[/code]
Zuletzt geändert von montykarlo am 19. Sep 2006, 10:37, insgesamt 1-mal geändert.

Werbung:
lurchi2k1
Newbie
Newbie
Beiträge: 4
Registriert: 11. Sep 2006, 21:47

Re: ssh + Invalid Port Numer

Beitrag von lurchi2k1 » 18. Sep 2006, 21:18

montykarlo hat geschrieben:

Code: Alles auswählen

putty>pscp id_rsa_public_linux monty@192.168.2.35:id_rsa_public
Nun kommt die Meldung "Invalid Port Number"
Ich bilde mir ein, es müsste heißen:

Code: Alles auswählen

putty>pscp id_rsa_public_linux monty@192.168.2.35:~/id_rsa_public
sonst wird der sshd auf dem zielsystem denken, dass du ihm nen port angeben willst und nicht den dateinamen.

klappts so?

jengelh
Guru
Guru
Beiträge: 4039
Registriert: 20. Nov 2004, 17:42
Kontaktdaten:

Re: ssh + Invalid Port Numer

Beitrag von jengelh » 18. Sep 2006, 21:56

montykarlo hat geschrieben:

Code: Alles auswählen

putty>pscp id_rsa_public_linux monty@192.168.2.35:id_rsa_public
Nun kommt die Meldung "Invalid Port Number"
Dann hast du potentiell einen Bug gefunden. (Sofern man das nicht als "Feature" von Putty sieht.) Denn OpenSSH macht es so:

Code: Alles auswählen

scp [-P port] source [user@]ziel:file

Benutzeravatar
montykarlo
Newbie
Newbie
Beiträge: 34
Registriert: 14. Mär 2006, 16:31
Wohnort: Neckartailfingen

Beitrag von montykarlo » 19. Sep 2006, 00:07

Hi danke für die Antworten,

Ich habe es mal mit ner anderen Putty Version getestet.
Zuerst hatte ich die Version 0.58 dann die r6855 ??
Das selbe Problem. Ich habe die Keys jetzt einfach auf den anderen PC kopiert. Sollte ja auch gehen.
Nun meint Putty beim Verbinden über Cert:

Code: Alles auswählen

Fatal Error: No supported authentication methods available
Server refused our key
Ich denke mal am Putty liegt das nicht.
Fehlt vielleicht meinem Linux ein Paket?
Die sshd_config ist konfiguriert und schlüssig. Mache ich die Option PasswordAuthentification auf yes dann ist es wieder möglich sich einzuloggen. Also wird die sshd_config auch benutzt...
Der Public Key id_rsa_public wurde nach /home/monty/.ssh/authorized_keys gepiped
Der Verweis AuthorizedKeyFiles in der sshd_conf verweisst auf das Verzeichnis /home/monty/.ssh/authorized_keys
PubkicKeyAuth ist auf yes ...

... ratlos DICKES FRAGEZEICHEN

bis dann[/code]

Benutzeravatar
montykarlo
Newbie
Newbie
Beiträge: 34
Registriert: 14. Mär 2006, 16:31
Wohnort: Neckartailfingen

Beitrag von montykarlo » 19. Sep 2006, 10:36

Wer lesen kann.....

Code: Alles auswählen

.....Danach muessen alle Zeilen in eine Zeile zusammengefasst werden
Tut
Bis dann

Antworten